-   Ubuntu (
-   -   DMA problems on SiS746FX IDE channel (

Ptrs!OP 04-28-2005 05:19 PM

DMA problems on SiS746FX IDE channel
Hello to all,

I have switched to Ubuntu for months now and though I've been searching for all this time I still haven't been able to switch on DMA on my IDE channel.

I have an Athlon XP processor on a QDI K7S746FX motherboard (I SiS 746 chipset). My drives are set: /dev/hda: hard drive, /dev/hdb: DVD, /dev/hdc: CDRW. All of them have DMA off and can't change it with hdparm. And then I have a PCI SATA controller with a Maxtor hard disk. But I have the feeling that it is working really slow too. hdparm /dev/sda gives me:
Timing cached reads: 1020 MB in 2.00 seconds = 509.82 MB/sec
Timing buffered disk reads: 102 MB in 3.06 seconds = 33.38 MB/sec
Is that normal or slow?

I have tried editing the /etc/modules file, adding amd74xx or via82cxxx, but they didn't work. I have also changed the order in which the modules are loaded at startup, as those solutions where the ones that worked for most people in the forum. I think that it has to do with my chipset... Should I replace amd74xx or via82cxxx with something else that is specific for the SiS chipset?

Any help would be much appreciated!

chile712 05-04-2005 11:16 AM

may be this link will help. It help me alot. i know have DMA working on my HD, cdrw & dvdrw drives.


Ptrs!OP 05-05-2005 04:40 PM

Thank you for the link, but unfortunately it is not of any help. The problem is that for some reason it is the SiS chipset that gives me headaches. It seems that I should add a "SiS-something" module in my /etc/modules file. I am not in my linux computer at this moment so I can't tell you the exact module. The problem is that adding that, the computer stops during boot. It doesn't freeze, it just stops at some point, where it is "Configuring RAID devices" and if I press Ctrl+C it will just go on to the next step and there it will once again stop but will not respond any more to Ctrl+C. I don't know what else to do. It seems like the only thing left to do is to compile a new kernel, but I can't start such thing at this moment, for lack of time. Is there anything else I could try?

chile712 05-05-2005 05:57 PM

dont add "SiS-something" remove module in the /etc/modules file.

i followed the commands from " Configuring your system " section, to make sure my ide could do dma. To add DMA at boot i added these lines to my "/etc/init.d/" file.

/sbin/hdparm -m16C3 /dev/hda # sets multcount=16 && 32bit w/sync
/sbin/hdparm -d1u1c1X66 /dev/hdc # dma=on unmaskirq=on 32bit UDMA2
/sbin/hdparm -d1u1c1X66 /dev/hdd # dma=on unmaskirq=on 32bit UDMA2

i hope this helps

All times are GMT -5. The time now is 06:51 PM.