LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-03-2007, 09:13 AM   #1
Sordelka
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu + Win XP Pro
Posts: 26

Rep: Reputation: 15
D-Link driver not working properly


I have one more question.

My Card: D-Link DWL-G122 rev. B1 (USB)is having problems. I've installed ndiswrapper, the driver, made it launch with start up. Did basically everything the documentation said. But I am still not getting any network. Can anyone help me on the possibilities of what it could be?

Yes. I have also installed the ndiskg tool, the automatic set up interface for ndiswrapper. (the ndiswrapper came with the live CD, as well as, the util 1.9). It shows me that the hardware is present, but no network is shown.

When I type ifconfig: the card isn't shown in whoa0 (i think that is what it is called for wireless)
iwconfig: does show the card driver in whoa0

Um checking if the driver is installed in the terminal gives that it is installed.

I have really no idea how to fix that...

Maybe anyone could tell me how to install this driver found on ralink, the RT2005USB (it gives me a sourcecode, I have no idea how to compile)

Because in the help section, it says that if ifconfig doesn't show my card, it means the driver is not functioning properly!
 
Old 12-03-2007, 10:32 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,123

Rep: Reputation: 418Reputation: 418Reputation: 418Reputation: 418Reputation: 418
Quote:
I have one more question.
Only one?

I haven't had to use ndiswrapper, but I am getting better at getting networks to connect

If your wireless interface is showing up with iwconfig, there's hope yet. Please tell us what iwconfig reports.

Quote:
Um checking if the driver is installed in the terminal gives that it is installed.
What does this mean, exactly?

Please post your /etc/network/interfaces file (Inside CODE tags, please - Click Go Advanced, then the # button)

Are you using encryption on your wireless link?
 
Old 12-03-2007, 11:25 AM   #3
Sordelka
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu + Win XP Pro
Posts: 26

Original Poster
Rep: Reputation: 15
Alright, I will post all that asap. Just give me some time =)
 
Old 12-03-2007, 04:46 PM   #4
Sordelka
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu + Win XP Pro
Posts: 26

Original Poster
Rep: Reputation: 15
This is what iwconfig gives me

Code:
iwconfig 
lo        no wireless extensions. 

eth0      no wireless extensions. 

wmaster0  no wireless extensions. 

wlan0     IEEE 802.11g  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Link Quality:0  Signal level:0  Noise level:0 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0 
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

This is what ifconfig gives me

Code:
ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:16:17:BA:0B:60  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1 
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b) 
          Interrupt:17 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0 
          inet6 addr: ::1/128 Scope:Host 
          UP LOOPBACK RUNNING  MTU:16436  Metric:1 
          RX packets:192 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:192 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:0 
          RX bytes:14784 (14.4 KB)  TX bytes:14784 (14.4 KB) 

wlan0     Link encap:Ethernet  HWaddr 00:13:46:E8:4C:CD  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1 
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b) 

wmaster0  Link encap:UNSPEC  HWaddr 00-13-46-E8-4C-CD-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1 
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

This is what I see in my /etc/network/interface

Code:
auto lo
iface lo inet loopback

This is what I see when I input "ndswrapper -l" command


Code:
ndiswrapper -l
netrtusb : driver installed
        device (2001:3C00) present (alternate driver: rt2500usb)
I took the driver from the D-Link Installation cd. I did copy it in one of my linux directories and installed it from there, not from the cd.

The ndisgtk tool shows me a similar to this picture

http://farm1.static.flickr.com/218/4...7af73f41f9.jpg

But instead of the driver there, I do see my driver.

So can you help me?

Yes, wireless info

Code:
Wireless
MAC Address 
	00-15-e9-1d-68-10
SSID 
	setka
Channel
	6
ENCRYPTION 
	WPA-PSK (TKIP)

Last edited by Sordelka; 12-03-2007 at 04:52 PM.
 
Old 12-04-2007, 03:20 AM   #5
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,123

Rep: Reputation: 418Reputation: 418Reputation: 418Reputation: 418Reputation: 418
Thank you for that information. The card driver looks OK.
Now you have to get it to connect. Please do not use GUI applications to do this. Instead, just make your /etc/network/interfaces file look like this (you can copy & paste):
Code:
# lo is your loopback interface, you need this 
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# This is your ethernet interface
auto eth0
iface eth0 inet dhcp

# This is your wireless interface
auto wlan0
iface eth1 inet dhcp
wpa-passphrase "This_is_your_passphrase"
wpa-ssid "setka"
wireless-channel 6
setka is you APs SSID, Yes?
Obviously you'll have to change "This_is_your_passphrase"

Now try restarting your wireless interface:

sudo ifdown wlan0
sudo ifup wlan0


You may see interesting messages about the connection attempt. Then you should be connected.
You can see the details with ifconfig

If not, what is the output of sudo iwlist scanning

PS No need to email me that you have posted here, I am notified automatically by LQ, and I'll get back when I have time
 
Old 12-04-2007, 09:13 AM   #6
Sordelka
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu + Win XP Pro
Posts: 26

Original Poster
Rep: Reputation: 15
Thank you a lot for help. The network is still down however. But there is some stuff that changed.

First, the output of sudo iwlist scanning

Code:
sudo iwlist scanning 
lo        Interface doesn't support scanning. 

eth0      Interface doesn't support scanning. 

wmaster0  Interface doesn't support scanning. 

wlan0     Scan completed : 
          Cell 01 - Address: 00:15:E9:1D:68:10 
                    ESSID:"" 
                    Mode:Master 
                    Channel:6 
                    Frequency:2.437 GHz 
                    Signal level=-68 dBm  
                    Encryption key:on 
                    IE: WPA Version 1 
                        Group Cipher : WEP-40 
                        Pairwise Ciphers (1) : WEP-40 
                        Authentication Suites (1) : PSK 
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s 
                              36 Mb/s; 48 Mb/s; 54 Mb/s 
                    Extra:tsf=0000024a09d1617e
Secondly, the errors:

Code:
sordelka@sordelka-desktop:~$ sudo ifdown wlan0 
ifdown: interface wlan0 not configured 
sordelka@sordelka-desktop:~$ sudo ifup wlan0 
Ignoring unknown interface wlan0=wlan0.

And this is how my network manager look like (it has wired connection set up instead of wireless)

http://img47.imageshack.us/img47/380...shothd4.th.png

And do I need to change anything here:

Code:
# lo is your loopback interface, you need this 
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0
Or I leave the addresses as is?

Last edited by Sordelka; 12-04-2007 at 09:28 AM.
 
Old 12-04-2007, 09:56 AM   #7
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,123

Rep: Reputation: 418Reputation: 418Reputation: 418Reputation: 418Reputation: 418
Code:
sudo iwlist scanning
wlan0     Scan completed : 
          Cell 01 - Address: 00:15:E9:1D:68:10 
                    ESSID:"" 
                    Mode:Master 
                    Channel:6 
                    Frequency:2.437 GHz 
                    Signal level=-68 dBm  
                    Encryption key:on 
                    IE: WPA Version 1 
                        Group Cipher : WEP-40 
                        Pairwise Ciphers (1) : WEP-40 
                        Authentication Suites (1) : PSK 
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s 
                              36 Mb/s; 48 Mb/s; 54 Mb/s 
                    Extra:tsf=0000024a09d1617e
The card can see an access point, maybe it is yours, maybe not, but it has no ESSID. I thought you said it was called setka, but you do not seem to have configured your AP to have that ESSID. You need to do this (See the manual for your AP)

Quote:
And this is how my network manager look like
I cannot read that image, the quality is way too poor!

Also, did I not ask you not to use GUI tools (Like "Network Manager") - see post #5, but just edit the /etc/network/interfaces file instead?

The "Network Manager" sometimes makes changes to the interfaces file that we do not want, because they are wrong. So please, stop using it. If you insist on using the GUI, then (a) You do not know what you are doing and (b) I cannot know what you are doing.

Quote:
And do I need to change anything here:

Code:

# lo is your loopback interface, you need this
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

Or I leave the addresses as is?
I told you in post #5 what changes to make to the interfaces file. So why are you asking this question?

You must not change anything about the loopback interface, or your computer will probably stop working.

You must make the other changes I listed in post #5, including entering your AP's ESSID and wpa-passphrase where indicated. Naturally, the wpa-passphrase must be the same as the one you entered into your AP / Wireless router.
 
Old 12-04-2007, 10:23 AM   #8
Sordelka
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu + Win XP Pro
Posts: 26

Original Poster
Rep: Reputation: 15
I did exactly like you have told me, without using any GUI. I have checked the settings of my AP.

What I see is exactly this:

Code:
Device Information
Firmware Version: 1.23 , Mon, 24 Jul 2006
LAN
MAC Address 
	00-15-e9-1d-68-10
IP Address 
	192.168.0.1
Subnet Mask 
	255.255.255.0
DHCP Server 
	Enabled
  	 
WAN
MAC Address 
	00-15-e9-1d-68-11
Connection 
	DHCP Client Connected  
IP Address 
	192.168.2.10
Subnet Mask 
	255.255.255.0
Default Gateway 
	192.168.2.1
DNS 
	192.168.2.1
  	
Wireless
MAC Address 
	00-15-e9-1d-68-10
SSID 
	setka
Channel
	6
ENCRYPTION 
	WPA-PSK (TKIP)
My configured SSID is setka. For the interface file, I did exactly as you've told me, even just copy pasted and added my password.

For my AP: The default ESSID is "default". During the setup, I reconfigured it to setka (a long time ago) and that is what I see when I use windows.

I am sorry for my noobism =) But I have done all you've told me "a la lettre". Maybe there is a way to use the access point anyways?

And what to do with wlan0 not being configured as interface (see the errors I posted).


Actually I have found something, after like a while passed on google.

It is this:

http://rt2x00.serialmonkey.com/phpBB...pic.php?t=4475

Seems my card has destinctive problems on Ubuntu...Does it tell you anything? [I'm doing my maximum to like provide all the info I could suck out of my machine and internet]

Last edited by Sordelka; 12-04-2007 at 01:15 PM.
 
Old 12-04-2007, 06:09 PM   #9
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,123

Rep: Reputation: 418Reputation: 418Reputation: 418Reputation: 418Reputation: 418
Quote:
For my AP: The default ESSID is "default". During the setup, I reconfigured it to setka (a long time ago) and that is what I see when I use windows.
OK, but linux isn't seeing setka. Look at your post #7:
sudo iwlist scanning shows an AP but ESSID:""

So that isn't right. The ESSID is blank. It should say ESSID:"setka"

I wonder, have you set your Wireless AP to broadcast the ESSID? Many have an option for it not to, and if it is not broadcasting its ESSID, linux will have trouble conecting to it. Windows is a little less fussy (and insecure). Maybe windows will connect to just about anything it can find. In a way this is good (I have INTERNET! Yaaay!), but maybe it is also bad (I am using the wrong AP, this is not my secure connection, but someone else's, and someone else is now busy sniffing my data / infecting me, but I have INTERNET, so I don't care). Not a good scenario

In post #7 you gave me this link to a picture:

http://img47.imageshack.us/img47/380...shothd4.th.png

I said it was way too poor to read (and you didn't follow this up in your next post ), but I have examined the URL you posted, and realise you have the wrong link, because your link is to a thumbnail. The link should have been posted like this:

http://img47.imageshack.us/img47/3803/screenshothd4.png

This one I can read, and it clearly shows you are using a "Network Settings" GUI, running on gnome, by the looks of things. Please, please don't ever use the GUI (until we have this sorted out), for the reasons I have outlined above (you might profitably re-read this thread from the very beginning, and try and make sense of it again). Don't say "I did exactly like you have told me, without using any GUI", when you have just posted a screenshot of you doing exactly that. Grrrrrr.

The trouble (well, part of the trouble) is that everything has to be just exactly right if you are going to make a connection to an encrypted AP:

- Your wireless card needs a module to handle it: I think you have already managed this with ndiswrapper (congratulations! )
- Your AP needs an SSID (it seems it has one - setka)
- Your AP needs to be broadcasting this SSID (Is it doing this - please check in the AP's configuration page, don't just "assume"!)
- Your linux system needs to know how to handle WPA encryption - do you have wpasupplicant installed? I think you need it (I certainly do). Install it if you haven't.
- The WPA encryption passphrases need to be exactly the same on your AP and linux PC
- The channel number needs to be known and set (maybe, better safe than frustrated)
- You need to be within range, without interference.... the list goes on and on and on.

Also, from the screenshot you posted, you seem to be already connected by ethernet. If that is the case, getting another connection with wireless is going to make things unnecessarily complicated. Use one, or the other.

So when you are trying to check out the wireless connections, bring down your ethernet connection by unplugging it, and just to make sure sudo ifdown eth0

Then try your wireless: Check your interfaces file is correct. This is important because you have been using the GUI and it might have made unwelcome changes. Then bring the wireless interface down in case it was badly configured, then bring it up again as in my post #5 (and on your readable screenshot).

I could perhaps help you better if you just re-posted your interfaces file again. I know you will think "But I already did that", but you have been using the GUI "Network Manager", and things may have been changed.

When you repost it, please do not obscure the passphrases etc: Nobody even knows which country you live in, and I doubt anyone reading this is within range, and you can always change the key when you get it working. Besides, sudo iwlist scanning showed there was the only the one AP within range, I am assuming it it yours.

Meanwhile, you have edited your post, and given me another link to follow. That you have been doing some research is good, and I encourage you. But I am too tired now to follow extra links and need food and bed. Try the above for a start. Then report back

Last edited by tredegar; 12-04-2007 at 06:13 PM.
 
Old 12-04-2007, 06:49 PM   #10
Sordelka
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu + Win XP Pro
Posts: 26

Original Poster
Rep: Reputation: 15
Just a quicky question:

How do I turn Network Manager off?

Contents of /etc/network/interfaces

(copy pasted exactly as is)


Code:
# lo is your loopback interface, you need this 
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# This is your ethernet interface
auto eth0
iface eth0 inet dhcp

# This is your wireless interface
auto wlan0
iface eth1 inet dhcp
wpa-passphrase "marianopolis"
wpa-ssid "setka"
wireless-channel 6
MAJOR ADVANCEMENT:

Well, first of all, I have no idea how to turn Network Manager off. Still, as soon as I put the AP to broadcast the SSID, it detected my "setka" connection. You've told me to not use the Network Manager, but don't get me wrong, as I have no idea how to actually turn it off, I saw the connection appear there, but didn't use it to try to connect, even didn't touch a thing in there.

However, now, the command sudo iwlist scanning gives me No results for wlan0...

But it actually does see the network, which is a plus.

What do you think I should do now? I mean, is it working? Or am I like dreaming and it is a false impression?


Am I almost there

Last edited by Sordelka; 12-04-2007 at 09:34 PM.
 
Old 12-05-2007, 04:24 PM   #11
Sordelka
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu + Win XP Pro
Posts: 26

Original Poster
Rep: Reputation: 15
<up>

I seem to be seeing the connection. But there is still no connection...What should I do?
 
Old 12-05-2007, 04:52 PM   #12
knot2003
Member
 
Registered: Oct 2003
Location: Rio de Janeiro, Brazil
Distribution: Ubuntu 7.10
Posts: 32

Rep: Reputation: 15
Take a look to this tutorial...It might add some more information to you.

http://ubuntuforums.org/showthread.p...hlight=linksys
 
Old 12-05-2007, 07:09 PM   #13
Sordelka
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu + Win XP Pro
Posts: 26

Original Poster
Rep: Reputation: 15
I just wonder, how do you turn the Network Manager off? Like, um, when is it considered off?
 
Old 12-07-2007, 09:00 AM   #14
Sordelka
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu + Win XP Pro
Posts: 26

Original Poster
Rep: Reputation: 15
'up"

What exactly are you people lacking in order to help me? I will provide any information necessary!!!
 
Old 12-07-2007, 01:53 PM   #15
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,123

Rep: Reputation: 418Reputation: 418Reputation: 418Reputation: 418Reputation: 418
Quote:
What exactly are you people lacking in order to help me?
Time.

And patience:

It is really annoying when I have asked you to make sure that your AP is set to broadcast its SSID, you post that it is broadcasting its SSID, and I spend time thinking "this is really strange, why does sudo iwlist scanning say ESSID:"" ????"

Then, when I have thought of some highly unlikely scenarios and try to answer you, I find you have gone back, edited that bit out of your post, and then gone on to say in your next post:

Quote:
as soon as I put the AP to broadcast the SSID, it detected my "setka" connection
So you are posting mis-information, and not being consistent, and wasting my time thinking about problems that don't even exist. And then messing about editing your previous posts. We notice these things

You post things that aren't really questions at all:

Quote:
However, now, the command sudo iwlist scanning gives me No results for wlan0...
But it actually does see the network, which is a plus.
What, exactly, do you mean by this? What "sees the network"? What do you mean by "No results"? Please post the exact results of commands.

Quote:
I seem to be seeing the connection. But there is still no connection...What should I do?
What do you mean "I seem to be seeing the connection", how are you "seeing" it? Why do you think "there is no connection"? How did you test it?

Knot posted a very useful link for you, did you follow it? You have made no reference to it at all - not even a "Thanks for that link but it is waaay too long for me to read. I'm a really busy person, and just want instant answers without any effort on my part"

Quote:
I will provide any information necessary!!!
How about your bank account details, passwords, PIN numbers etc. for a start? PM me please, I want to empty those accounts before the rest of the world gets there

Seriously though, please read this link: http://www.linuxsilo.net/docs/smart-questions_en.html

I am not being nasty, just nudging you in the right direction.
Now, go away and do your homework. Welcome back when you are done.
Persevere, you will be rewarded
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
IT821X driver not working properly in 2.6.21.1 TSquaredF Linux - Kernel 0 05-05-2007 11:42 AM
Nvidia driver is not working properly on Mandrake 10.1 Spitz Linux - Hardware 0 01-29-2005 02:28 PM
X not working properly. MylesCLin Linux - Software 1 09-15-2004 11:46 AM
Link/Applet not working in all Linux browsers, but working in IE MasterPatricko Linux - Software 6 09-04-2004 04:39 AM
Got my nVidia driver working properly! orange400 LinuxQuestions.org Member Success Stories 0 03-20-2003 02:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 10:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration