-   Ubuntu (
-   -   Connected to router but not the internet? (

chri5 11-11-2005 03:13 PM

Connected to router but not the internet?
Strange problem, I'm trying to use my wireless laptop to connect to the inteRnet with ubuntu 5.10.

I've got my wireless card working with ndiswrapper etc and it's getting the correct IP information back from my DHCP router. I can even log into to my router from ubuntu but I can't get out to the internet?
Any ideas?

fouldsy 11-11-2005 03:20 PM

Are you running wep, which can sometimes cause issues? Also, is your default gateway correctly set? Type "route" from a console and it should display an entry for your default gateway. If not, set it as such (assumming your router is netmask

route add default gw netmask
. Then try pinging an website on the Internet. If that fails, try adding the default gateway again, but without the "netmask" at the end.

rubella 11-11-2005 03:22 PM

when you can establish a connection between your laptop and your router, it think everything between those 2 is fine...

Is it possible to check your router with a webinterface? Check there if you have a connection with the internet.... did you get an external ip from your ISP? Everything could be fine on your local network, when you didn't get an external ip, it will not be possible to connect to the outside. Did you try a ping to a website?

Did you give the correct DNS-servers with your router? When your client don't find a correct DNS-server, it will not be possible to resolve the correct ip-adres from a given url. And on the internet, everything works with ip-adresses. URL are only made to make it readable (easy)...

chri5 11-11-2005 03:40 PM

Thanks for the quick replies; but still no joy!

I can login to my router from ubuntu and I can ping websites on the internet but firefox doesn't connect.

I've disabled WEP and made sure my gateway & mask are correct.

Any more ideas??

fouldsy 11-11-2005 04:43 PM

Okay, so if you're able to ping websites from your computer based on domain names such as, then it must simply be the connection settings within Firefox. Go into Preferences | Connection Settings and check it's trying to connect through an incorrect default gateway. Setting it to automatically detecting settings should work, or even direct connection since you have your routing table already setup.

chri5 11-11-2005 05:00 PM

This just isn't making sense. I can ping com from the terminal; I get 0 packet loss 100% success. This must mean Ubuntu is getting the correct IP info.

But firefox wont get me on the net. Tried auto & direct in connection settings.
It just times out after about 2 minutes.


daniela 11-12-2005 06:36 AM

sorry for breaking into your thread...i just thought it wouldn't make sense to open a new one since my problem is very similar to yours...

the only difference is that i can't ping anything on the internet. but i'm able to connect to the router's webinterface & every single computer/laptop on the wlan is able to surf the internet. i can't ping neither an ip nor a hostname outside.
when i try to ping my isp's dns-server i get "connect: network unreachable" & trying to ping google results in "unknown host". (resolv.conf shows the right dns-server, though)

i'm using a thinkpad t43p with debian & an atheros chipset built-in wlan card. thus using the madwifi-driver.

chri5 11-12-2005 03:36 PM

After many hours I got there. Ubuntu didn't remember what I told it after rebooting as well as a router config out of place that sent me round in circles!

I've decided to stick windows back on for now.

daniela 11-13-2005 05:29 AM

i'm glad to hear that you got to know your problem (& less glad that you stick windows back on) ;)

well i'm still stuck with my thinkpad. so i'd appreciate any comment on this...

All times are GMT -5. The time now is 11:45 PM.