-   Ubuntu (
-   -   Changed CPU, Ubuntu won't boot! (

Child of Wonder 09-05-2006 07:44 PM

Changed CPU, Ubuntu won't boot!
I'm about to put the old CPU back in but I doubt it will help.

Today I received an Athlon XP 2100+ in the mail to replace the 3000+ I had installed in my Linux server. The 3000+ will be going into a different PC.

So I installed the 2100+ into the server, motherboard auto detected it just fine. The kernel starts to boot and...

initrd /boot/initrd.img-2.6.15-26-k7

Error27: Unrecognized command

Press any key to continue...

From what I've found "savedefault" is what Grub is no longer recognizing (don't know why swapping CPUs would cause that) so I removed it and tried booting only to get:

Uncompressing Linux...

crc error

-- System halted

The same thing happens if I try to boot in recovery mode, too.

So I tried popping in the Ubuntu LiveCD and get the crc error again.

Any clue what's going on? Did I zap the hard drive or memory some how?

Penguin of Wonder 09-05-2006 08:17 PM

Since you too are "of wonder" I'll throw out my best guesses.

1.) Did they ship you a lemon?
2.) Did you break it before you installed? i.e. static shock, break a pin, etc.
3.) Both are either 64 or 32 bit right?

Child of Wonder 09-05-2006 08:50 PM

Thanks for the response PoW.

I just figured it out. Apparently clearing the CMOS wasn't enough to get the mobo to fully recognize the CPU. It was still trying to run with a 333MHz FSB when the CPU is 2100+. The BIOS was reporting the CPU as a 2700+ during boot but I didn't look close enough and mistakenly thought it said 2100+. Upon my Nth reboot, I noticed it was displaying the wrong CPU.

Since this board is out of an eMachines POS, I had to find the jumpers to switch the FSB to 266MHz and now it works like a charm!

Penguin of Wonder 09-05-2006 09:30 PM

Rock. Thanks for reporting back.

All times are GMT -5. The time now is 05:01 PM.