-   Ubuntu (
-   -   Can't startx; FreeFontPath: FPE log message (

tidiman07 03-18-2008 08:33 PM

Can't startx; FreeFontPath: FPE log message
Yesterday my system broke! I reboot to get to windows to take care of something and when i tried to boot back into Kubuntu Gutsy it goes to login manager. I had automatically set it to login and all.
When i type in the user and pass, it flashes screen like its starking the Desktop but then it goes back to login window.
I proceeded to a console session to figure things out. The last thing i installed was skype before i rebooted, so i purged it- still no fix.
When i do startx, it flashes Desktop for a sec then goes back to console. I took a look at /var/log/Xorg.0.log and found this:

(II) I810(0): xf86UnbindGARTMemory: unbind key 5
(II) I810(0): xf86UnbindGARTMemory: unbind key 6
(II) I810(0): xf86UnbindGARTMemory: unbind key 7
(WW) I810(0): Successfully set original devices (2)
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.
searching forums told me that the last line was not significant to cause X to stop so i purged all xserver-xorg applications and reinstalled them. Tried startx, nothing, flashes like it normally does to start the Desktop, but goes back to console. I have not made changes to xorg.conf or anything. I've been scanning the log file and cant find nothing our of line.

Please help me out, I've exhausted my knowledge base.


comprookie2000 03-19-2008 03:06 PM

Look at the kde log

tidiman07 03-19-2008 10:37 PM

Thanks comprookie2000. When I looked at it was a dbus error.
Turns out its an Xorg bug, i was missing a directory, session.d.
I just

$ sudo mkdir /etc/dbus-1/ session.d
Then startx,


federicodemaria 10-30-2008 09:59 AM

i have the same problem
i tried, but...

$ sudo mkdir /etc/dbus-1/ session.d

mkdir: no se puede crear el directorio 'etc/dbus-1/' : el fichero ya existe


(((in english:
mkdir: impossible to create directory 'etc/dbus-1/': the file already exists)))

And now?


comprookie2000 10-30-2008 01:55 PM

Going to need a lot more information. What distro? What Desktop Manager?
Did you look at /var/log/Xorg.0.log ?

federicodemaria 10-31-2008 03:57 AM

well, i'm a very beginner, so...
- kubuntu 7.04
- Desktop manager, i don't know. Might it be kdm?
- What is /var/log/Xorg.0.log?
I removed /tmp/.X0-lock

my complete story at

i do appreciate your help,
sorry for the ignorance :->


comprookie2000 10-31-2008 05:03 AM

What happens when you try startkde as a regular user not root.

All times are GMT -5. The time now is 03:02 AM.