LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Can't ping my Ubuntu! (https://www.linuxquestions.org/questions/ubuntu-63/cant-ping-my-ubuntu-453901/)

keiwu 06-12-2006 02:15 AM

Can't ping my Ubuntu!
 
Just fresh install my Ubuntu.
However, I can't ping this machine from my other computer.

nadroj 06-12-2006 02:32 AM

is the network configured properly? whats the exact output? can the target computer ping the computer your testing from? was there a firewall set up? router?

keiwu 06-12-2006 02:42 AM

this Ubuntu machine can ping other machine.
It just other machine can't ping the ubuntu machine.
It says: request timed out.
the ubuntu machine uses wireless connection.
not sure how to check if the firewall is up or not.

we need to disable firewall if it is up?
how?

nadroj 06-12-2006 02:43 AM

you could check something like 'iptables -L' as root.. or whatever software ubuntu uses as firewall. look around in your GUI for a network/security section for firewall. or on ubuntuforums website.

keiwu 06-12-2006 02:59 AM

by reading more infos, I think ubuntu doesn't come with a firewall.

keiwu 06-12-2006 03:17 AM

by reading more, I found out that Ubuntu by default leaves 0 port open (this means no port is open then you can not ping it?)
read this:

"As a matter of fact, Ubuntu has a "no open ports" policy by default. If you don't believe me, try running this on a fresh install of Ubuntu 5.10 (Breezy Badger Release):
nmap -sV -O

If you notice, nmap will tell you that 0 ports are open.

The reason Ubuntu doesn't ship with a firewall is because 0 ports are open."

keiwu 06-12-2006 03:58 AM

My iptables rule now:
# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT tcp -- anywhere anywhere tcp dpt:ssh
ACCEPT tcp -- anywhere anywhere tcp dpt:www

And still can not ping this ubuntu machine

bit128_linux 06-12-2006 04:09 AM

Please post the output of(executed as root, of course):

ifconfig

from both machines.
Maybe there is your problem :confused:...

keiwu 06-12-2006 03:48 PM

Link encap:Ethernet HWaddr 00:0D:02:58:75:36
inet addr:192.168.0.106 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20d:2ff:fe58:7536/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:197 errors:175 dropped:0 overruns:0 frame:175
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:200
RX bytes:72101 (70.4 KiB) TX bytes:4917 (4.8 KiB)
Interrupt:11 Memory:d4b40000-d4b50000

The other is a Windows XP machine.

nadroj 06-12-2006 03:59 PM

the windows command would be something like 'ipconfig /all'

try, as root, 'iptables -F' to clear all rules for the firewall.. then try pinging again, if that works then its the iptables rules and we'll have to fix those.

manishsingh4u 06-12-2006 04:23 PM

Sorry, I missunderstood the problem. Sorry folks.

keiwu 06-12-2006 07:09 PM

after exectuing #iptables -F, now I can ping.
But I still can't visit my apache test page from other computer

fragos 06-12-2006 07:33 PM

ping by IP should work but ping by host name will require that you configure a route. For Ubuntu in System - Administration - Networking - Hosts tab - Add - IP address & Alias. For example on my local network of two boxes the other box is host "x86" and IP 192.168.0.3 and this box is host "Geo" and IP 192.168.0.2. I configured the routes in both boxes so I could go in either direction with alias x86 or Geo.

nadroj 06-12-2006 07:42 PM

keiwu the 'iptables -F' command that i told you is used to 'flush' (ie remove) all the rules in the iptables firewall. since you flushed the rules, your computer is now unprotected with a firewall and if you have software on your computer that is subject to remote attacks then you should be careful.

look into iptables basics to setup a firewall that is good for you. or we can help you set it up if you tell us what services the computer will be serving.

for the apache test page, it is not a firewall problem as there is no firewall configured after you ran the command. meaning its a configuration problem with the apache software. double check the setup process/documentation to make sure you didnt miss anything.

keiwu 06-12-2006 10:03 PM

I only want to host my site using Ubuntu.

the instructions for setting up Apache2 are from my Professor, and it works on the school lab machine. But I tried it in my home computers and none of them work.
(If machine A is my Ubuntu machine, and I can visit the test page using machine A by typing: http://localhost/test.html or http://192.x.x.x/test.html. It is only that I can't visit the test page using the other machine say B by typing: http://192.x.x.x/test.html)

keiwu 06-12-2006 10:07 PM

this is all my professor taught us to setup Apache,
And it works in the school lab. What else we need to configure?

1.: How to install Apache HTTP Server for HTTP (Web) Server service?

sudo apt-get install apache2

test: http://localhost

nadroj 06-12-2006 10:08 PM

iv never had to setup apache so i dont know the details.

i suggest reading the documentation that came with it or reading it on the official site, and see if the instructions given to you missed something.

its odd that you can access it from the local machine but not from another computer. you said computer B can ping A, now, and vice versa?

keiwu 06-12-2006 10:37 PM

yes, that's why I don't think it's apache's problem since I can access the test page using the same machine. It says if you can do http://localhost/, then it means apache is working fine.
That's why I am thinking about the connection problem.
But I've already allowed all traffics to get in by typing : #iptables -F.

And I've just installed a firewall, and allowing www services on port 80, and still not work.

nadroj 06-12-2006 10:40 PM

you said the computers can each ping each other?

keiwu 06-12-2006 11:50 PM

yes, they can ping each other.
but when visiting the page on the apache server from other machine, it says page not found.

nadroj 06-12-2006 11:56 PM

again, im not familiar with apache as iv never had to set it up or look into it. search google.com/linux for appropriate search terms. look in your configuration files too.
sorry cant help further, hope someone whos familiar with apache can comment


All times are GMT -5. The time now is 03:17 AM.