-   Ubuntu (
-   -   Can't move files from usb flash drive (

WillingToLikeLinux 07-05-2009 04:09 AM

Can't move files from usb flash drive
I currently use 9.04 (ext3). Somehow I can't copy my document files in my usb... to my computer.

When I tried to copy my files from my drive to my computer it shows: Error reading from file: Input/output error

When I tried to rename my document files in my usb, it shows : Error renaming file: Read-only file system

I used this flash drive since 8.10 (ext3). I didn't have any problems 2 days ago with it. Is there a special locking mechanism in the flash drive's file system or is this a serious bug?

I don't know but it seems so fishy. Hmm, maybe I shouldn't use Ubuntu next time.


Now some of my files in my usb are corrupted. I don't think it's a virus since I only use it in my computer.

Update 2

I can't change permissions for changing my usb's properties. It always says: The permissions could not be changed. in bold

unSpawn 07-05-2009 08:30 PM

Thread closed as it is basically addressed in the threads and Please don't open up multiple threads for one problem. That's kind of inefficient.

All times are GMT -5. The time now is 06:33 AM.