-   Ubuntu (
-   -   can't delete (send to trash) files on usb devices. (

vacuman 01-26-2007 04:26 AM

can't delete (send to trash) files on usb devices.
I (seemingly) was able to delete on a 256 SD card by changing the permissions-but it only created a trash file on the disk and put it in there. I couldn't even do that on a 1 GIG SD card. I have to keep going back to my Windows 2000 laptop and reformatting to delete.On my I-River mp3 player I have to use the built in reformatting program to delete in order to put in new music. What a pain. I did not have any trouble deleting files with SuSE 9.2.,Red Hat,Fedora,Mandrake or a slew of others-Why does this seem to be a problem with (K)Ubuntu? WHAT DO I HAVE TO DO TO DELETE ON A SD CARD? I don't have any problem deleting other things within the system-just on input devices.


Simon Bridge 01-26-2007 04:35 AM

What have you tried? (Changing permissions by itself doesn't delete files.)

You select "move to trash" as normal, then you rt-click on trash and select "empty trash"... while the SD card is still mounted. The last bit is important.

OR: in a nautilus windows,
edit > preferences --> behavior tab
under "trash"
check the box labeled "include a delete command that bypasses trash"

OR: use the terminal to browse to your media fs, and use the rm command.

statyk 01-26-2007 12:19 PM

Do you have read write access to the drive?

sudo apt-get install ntfs-3g

vacuman 01-26-2007 11:38 PM

can't delete from sd card or usb devices.
Thanks for all assistance. I try one thing and if that doesn't work I try something else. This time the first thing worked.

I typed from terminal :sudo apt-get install ntfs-3g. gave my password where asked and then enter.

Now I can delete things off input devices like SD cards and mp3 players. Thanks

Simon Bridge 01-27-2007 05:33 AM

Oh - the SD card holds an ntfs file system! Well spotted statyk!

All times are GMT -5. The time now is 08:54 PM.