-   Ubuntu (
-   -   Cannot start X server after upgrade from Oneiric Ocelot to Precise Pangolin (

iqbala 05-08-2013 02:56 AM

Cannot start X server after upgrade from Oneiric Ocelot to Precise Pangolin
I am running Kubuntu.
I just upgraded from Oneiric Ocelot to Precise Pangolin, and apparently everything went well.
But when i tried to login in the graphical window, I got the following error message:

"WARNING: Cannot open ConsoleKit session: unable to open session: the permission of the setuid helper is not correct".

After that, i get back the login screen.

If I shut down the Xserver and log in the system by console, the login goes well and I can navigate directories and do things (the few I can do by shell...), so I definitely think the problem is with the Xserver.

If it can help, I add that I have Nvidia graphic card running with the proprietary driver. The only other proprietary driver that I have in the system is for the Samsung printer. Everything else is standard Kubuntu.

I could obviously renounce the upgrade and make a clean install, but if it is possible, I would like to avoid that.

Any help is appreciated.


kedarp 05-08-2013 06:02 AM

Display problems are due to Nvidia driver usually.
Uninstall and reinstall the Nvidia driver and check.

Also see that you can boot Ubuntu in the safe graphics mode or not.

iqbala 05-08-2013 06:03 AM

Can you tell me how to uninstall Nvidia drivers from command line?

kedarp 05-08-2013 09:56 AM

Try this -


sudo apt-get purge nvidia-current
Also try to boot in the safe graphics mode from Recovery mode. Then the Nvidia drivers will not
be loaded and see if Xserver starts.

iqbala 05-09-2013 03:05 AM

Booting in safe mode got me nowhere, so the problem should not be the Nvidia drivers.

Googling the error message I found some advice but no results.

If I type

"sudo dpkg --configure -a"

I get the following error message

"error parsing file '/var/lib/dpkg/status' near line xxxx: blank line in value of field Description of package yyy"

I booted from install CD and looked at that file, but it all seems OK to me, the description for the rogue package is properly filled...

What will it happen if I just delete from that file all the section regarding the rogue package (that by the way is just a useless application that never worked)?

Could some guru answer this?

By the way, i tried also

"sudo apt-get -f install"

but it results in the very same error message.

Hope for some help


All times are GMT -5. The time now is 07:24 AM.