-   Ubuntu (
-   -   Cannot install Skype on Ubuntu 8.04 LTS (

smurthy 10-29-2008 03:33 AM

Cannot install Skype on Ubuntu 8.04 LTS
I am totally new to Linux. Have Ubuntu 8.04 LTS installed on my PC. Managed to get most things working reading forums/FAQs etc, but am completely lost trying to install Skype on Ubuntu 8.04 LTS. However easily installed Skype on my Puppy Linux booting from USB stick. Have tried almost everything I have read - gone to medibuntu, downloaded deb from Skype etc. The only thing I haven't tried is to try convert the rpm file to deb - I don't seem to be able to get 'alien' or something to convert.

Am I chasing something not do-able or has anyone actually installed Skype to Ubuntu 8.04 LTS?

budword 10-29-2008 12:02 PM

Simply add the following line to your sources.list file (usually /etc/apt/sources.list):


deb stable non-free

Now you can use apt-get update to sync to latest repository and then apt-get install skype to install Skype on your machines.

Is it that you can't get it installed or you can't get it to work ? Sometimes you have to adjust some audio settings.


smurthy 10-29-2008 08:11 PM

Thanks David,

I have tried what you suggest before, and tried again. Skype doesn't appear in the list of available packages after adding, and when I tried to install via apt-get I get an error code. Have also tried to install directly by downloading the skype-debian_2.0.0.72-1_i386.deb but again it fails to install - something about a 'broken pipe'.

Perhaps there is something wrong with the deb file from skype? I have also downloaded the rpm file from skype but don't know how to convert it to deb.

Appreciate your help though.


budword 10-30-2008 08:34 PM

Have you tried typing "skype" into a terminal ?

smurthy 10-31-2008 12:30 AM

Thanks again. Yes, I have. But 'skype' is not installed.

When I tried to add the repository for skype I get the following error message:

"Failed to fetch cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/dists/hardy/main/binary-i386/Packages.gz Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Failed to fetch cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/dists/hardy/restricted/binary-i386/Packages.gz Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Some index files failed to download, they have been ignored, or old ones used instead."

I don't know why its trying to get from a CD-ROM, even though I specified the skype http. This has also happened during some other software upgrades as well thru the Synaptic Package Manager.

I downloaded the skype deb file from Skype, but the installation thru Gdebi also fails due some "dpkg error - process killed (broken pipe)."

Thinking there was a problem with the deb file, I downloaded the rpm file from skype and tried to convert to deb file with alien. But alien does not seem to recognize the rpm file on the desktop.

This is real frustrating - I can run Skype from a USB stick on any Windows computer - and just when I am beginning to enjoy using Ubuntu!! :-)

Oh well, I guess all good things must come to an end...

budword 10-31-2008 10:32 PM

It's trying to download skype and other things from your cdrom drive because you still have the install cdrom listed in your /etc/sources.list file. It always hits the cdrom first if it's there, to avoid going to the net for things that are available locally. You can either edit the cdrom out by hand, or open synaptic or your package manager of choice and disable the cdrom as an install choice from there.

This is the line you put into your /etc/apt/sources.list file.

deb stable non-free

What did you mean by "even though I specified the skype http" ?

I just upgraded to 8.10, and installed skype with the instructions from that link, and it worked for me, first time. Did you follow the instructions closely ? It does work, I just did it.


P.S. I'm sorry...I didn't give you the complete link. My fault. First, edit out the cdrom entry in /etc/apt/sources.list

Then, put in the line above. From where it says "deb" to the end of that line. (copy and paste the whole line.) Then open a terminal, and type....

sudo apt-get update

Then type in....

sudo apt-get install skype

Let us know if it works....

Oh, the LTS is really only of value if you are purchasing support from canonical. If you aren't, then I would use the most recent version of Ubuntu, as they have most likely worked out a great many bugs that might drive you insane.

smurthy 11-01-2008 12:25 AM

Thanks a bunch!!

I removed the CD-ROM as a source as you suggested, and this time I got no messages with respect to CD-ROM type failures. Then followed your instructions on apt-get to get skype and install. The install failed, and looking thru the script - there appeared to be a problem with some duplication in the skype-common package.

I removed the skype-common package and installed skype thru Synaptic Package Manager. Bingo!! Skype was listed in my applications and I was up and running!!

Now I don't have to get out of Ubuntu just to use Skype!!

Also thanks for your comments re 8.04LTS vs 8.10 - I was just looking for a stable version while I learned some basics. Most likely will upgrade when I am more confident.

Again, thanks - for your patience. You have been a real help.

jay73 11-01-2008 06:00 AM

Frankly, that is making things way too complex. All you need to do is go to
and read the repository how-to to set it up. After that, you can install not only skype skype but google-earth, dvd functionality, codecs, etc. from synaptic.

smurthy 11-02-2008 12:27 AM

Thanks. Actually, medibuntu was the first thing I tried after reading as much as I could about the problems I had - unfortunately the CD-ROM issue described above prevented me from doing anything. Now that this has been fixed I can see that that was the real problem!! And I think having the 'extra' skype-common package also prevented me from installing the deb from skype direct.

I have since gone to medibuntu and installed music /dvd codecs etc. without difficulty, thanks.

All times are GMT -5. The time now is 07:40 PM.