LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 07-06-2010, 01:58 PM   #1
wingman358
Member
 
Registered: Mar 2008
Location: Northeast US
Distribution: Mint, Ubuntu, Backtrack
Posts: 77

Rep: Reputation: 16
Can't Type an Exclamation Mark


I can't type an exclamation mark with my keyboard. I can type other symbols that require the shift key (~ @ # $, etc) but Shift + 1 does not give an exclamation point.

Here's the intriguing part: following a tip from another thread, I changed my Visual Effects setting (System > Preferences > Appearance > Visual Effects tab) from the default "Normal" to the setting "None". Immediately after doing this, I was able to type exclamation points. Problem solved, right?

Not quite. After discovering the solution, I decided it would be a great idea to experiment to make sure the Visual Effects setting was really the culprit. So I flipped my Visual Effects back to the default "Normal", and sure enough, I stopped being able to type exclamation marks.

Having verified the (apparent) cause of the issue, I tried my solution of changing the Visual Effects to "None". Of course the "solution" didn't work this time (so much for my great idea) and I am left unable to type an exclamation point.

I have concluded that the fault must lie within my user's configuration (I can type as many exclamations as I want when logged in as other users).

Quote:
Originally Posted by Yarui:
If you think it's something going on with your user account, you could try renaming your home folder from your name to something else temporarily. That way the next time you log in none of your config files will be loaded. If this fixes the problem you will know that it has something to do with your config files in your home folder. You could then try to narrow it down by testing out your config files in the same way one by one, if you have the patience for that.

Yarui has a great idea. Anybody have a recommendation as to which config files I might try first?

Last edited by wingman358; 07-06-2010 at 02:07 PM. Reason: update
 
Old 07-06-2010, 02:38 PM   #2
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 167Reputation: 167
I would suggest you do the reverse actually. Do what he initially suggested and then logout and move back the important bits you need until it reoccurs or you're happy with your setup.

That being said, try ~/.config/compiz/* first.
 
Old 07-06-2010, 03:30 PM   #3
wingman358
Member
 
Registered: Mar 2008
Location: Northeast US
Distribution: Mint, Ubuntu, Backtrack
Posts: 77

Original Poster
Rep: Reputation: 16
Talking

I did the above method suggested by Yarui and narrowed it down to .gconf/apps/metacity. I vaguely remembered editing something in there, so I ran

Code:
$ gconf-editor
Then I remembered I was in /apps/metacity/global_keybindings recently, so I brought that directory up and looked for "<Shift>1", which I immediately found as run_command_1. I disabled the keybinding by replacing the text "<Shift>1" with "disabled". I then hopped over to the corresponding file at /apps/metacity/keybinding_commands and erased the command I wrote in for command_1.

Now I've got my !! back
 
  


Reply

Tags
mark, point, type, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Another thread about escaping an exclamation point in bash. pr_deltoid Programming 4 06-26-2010 03:27 PM
[SOLVED] iptable Mark packet and use this mark in other rule toure32 Linux - Networking 3 04-21-2010 02:35 PM
Server Indicate Exclamation mark (!) Prabuddha Linux - Hardware 1 06-15-2009 07:43 AM
Exclamation The smsc9115 driver can't receive normally kine920 Linux - Embedded & Single-board computer 3 07-17-2008 11:24 PM
Shell scripting: exclamation marks in strings Dark_Helmet Programming 9 06-16-2003 06:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 02:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration