-   Ubuntu (
-   -   Can't start xmms (

Luke771 01-13-2007 06:04 PM

Can't start xmms
I'm running Ubuntu 6.10 Edgy with Gnome + kwin and kicker (dual panel + kde windows decorations)

Xmms used to work perfectly; it did until I had to reinstall because of a disk failure, then I got a new HDD, installed Edgy, and when I tried to run xmms it didn't start. The sound works with other multimedia programs, so I run xmms from a terminal to see some otput, here it is:


<user>:~$ xmms
Message: device: default
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 239 error_code 8 request_code 2 minor_code 0

How do I fix this?

Simon Bridge 01-13-2007 08:43 PM

Have you also enabled the Composite Extension?

------- Comment #5 From Guido Boehm 2005-01-08 00:48:48 -------

after doing some google-research on this topic a came up with this page:

Q: After enabling the Composite extension, XMMS refuses to start!
A: True, the gtk 1.x gdk part does not work too good with the Composite
extension and i do not know a patch to correct that.
Furthermore - any gtk 1.x application won't work too good with the xcompmgr,
because it will allways appear additive composed (if you place the gtk 1.x
window over a white background, you won't see anything
At least for XMMS, the Beep Media Player (xmms gtk 2.x port) is a good solution.
It does a very good job and gtk 2.x looks much better anyway =)

as mentioned in the text above, doing
'export XLIB_SKIP_ARGB_VISUALS=1 && xmms' works just fine, while xmms without
that variable set fails to start saying

Gdk-ERROR **: BadMatch (invalid parameter attributes)
serial 259 error_code 8 request_code 2 minor_code 0

// lenix

Luke771 01-14-2007 02:20 AM

That fixed it, thx a bunch.

All times are GMT -5. The time now is 10:01 PM.