-   Ubuntu (
-   -   Can't get screen to work with /dev/ttyS0 (Fine on ttyUSB0) (

Connel 02-17-2010 06:35 AM

Can't get screen to work with /dev/ttyS0 (Fine on ttyUSB0)
Hi Linux folk,

I have revived an old Dell D610 by installing Ubuntu. (What an installation process, that's how it should be done.)

I am using the machine as a console to connect to a security device on a client site. I need to use both the built in hardware serial port, and a second USB serial port.

I use "screen /dev/ttyS0", and "screen /dev/ttyUSB0".

The USB screen works fine. The ttyS0 one does not. (I tested the port under windows, with Hyperterminal, and it works fine - i looped the two ports together, and could talk between them.)

One thing I did notice, when I run the info command (Ctrl-A - I) in each screen, while connected to the device, is a difference in the CTS flag...

ttyUSB0: +flow UTF-8 {RTS (CTS) DTR !DSR (!CD) }

ttyS0: +flow UTF-8 {RTS (!CTS) DTR !DSR (!CD) }

I tried running the screen command with -fn for no flow control, but no joy. Also, I used a stty command to set -crtscts on the /dev/ttyS0, but still no joy.

I suspect it's to do with flow control, but can't get it working. Can any kind soul who is old enough to have experience with serial comms help me out?


theNbomr 02-17-2010 11:01 AM

Hmm, never seen screen used that way before. What I have done quite a bit is run a C-kermit session inside of Gnu screen, and that works just fine for serial or IP connections. I prefer the flexibility and configurability that C-kermit offers for serial comm's applications. minicom is probably already installed on your host, and may work just as well.
--- rod

All times are GMT -5. The time now is 06:13 AM.