LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-26-2010, 10:52 AM   #1
K.out
LQ Newbie
 
Registered: Oct 2008
Posts: 23

Rep: Reputation: 1
Question Can't connect to internet using wireless on Ubuntu 10.10 despite having a connection


Hi,

I was instructed to repost this question here; so, here it is. I tried to post the previous thread below. Thanks for any help.


I would like some help setting up using a wireless connection. I can connect using wired connection, and I have no trouble browsing. I have a strong wireless connection as well; however, when I try to browse I get a server not found error.

I have done a lot of research but I don't know if any answers really matched my situation.

I did download the necessary drivers. Before that, I didn't have a wireless connection.

I was able to connect on this pc before the install, and all other devices still connect using wireless. I have a linksys router.

The one thing that stands out at me is the ip address that it says the wireless connection is using. It says it is 10.42.43.1
I feel like that might be problematic because I'm pretty sure my router only accepts connections with values that are between 192.168.1.100 and 192.168.1.200.

Thank you for the help,
K.out
linuxubuntu K.out is online now Click to check your reputation for this post Report This Post Edit/Delete Message Reply With Quote
K.out
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
Send email to K.out
Find More Posts by K.out
Add K.out to Your Contacts
Old 12-24-10, 04:41 PM #2
wpeckham
Member

Registered: Apr 2010
Location: USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix
Posts: 84

Rep: Reputation: 15

Problem
This sounds like a networking issue rather than a Linux issue.
Can you tell us what kind of internet connection you have (in a general way), what kind of wireless router you use, and how you have security (encryption) set for your wireless connections?
I have to wonder if you are getting a wireless link to the wrong device, can you check that?
windows_xp_2003 wpeckham is offline Add to wpeckham's Reputation Report This Post Reply With Quote
Did you find this post helpful? Yes
wpeckham
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
View LQ Wiki Contributions
Send email to wpeckham
Find More Posts by wpeckham
Add wpeckham to Your Contacts
Old 12-24-10, 06:31 PM #3
K.out
LQ Newbie

Registered: Oct 2008
Posts: 15

Original Poster
Rep: Reputation: 0

Router: linksys wrt54g
Encryption: wpa2 personal
How would I check if it's connecting to the wrong device?
Also, I disabled ipv6.
In addition, there is now a neighboring network being detected but it is secured as well so I can't try it. I disconnected the wired connection and my router still has my Linux box listed in the dhcp table with the ip that was being used when I was connected by cable; even after refresh
macos K.out is online now Click to check your reputation for this post Report This Post Edit/Delete Message Reply With Quote
K.out
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
Send email to K.out
Find More Posts by K.out
Add K.out to Your Contacts
Old 12-24-10, 06:59 PM #4
markush
Senior Member

Registered: Apr 2007
Location: Germany
Distribution: Slackware and Gentoo
Posts: 1,032

Rep: Reputation: 160Reputation: 160

Hi K.out,

are you using DHCP in your network?

Please post the output of
Code:

iwconfig

and
Code:

ifconfig

maybe you'll need the sudo command to execute this in Ubuntu.

How (with which tools) did you configure your WPA2 personal encryption?

Markus
__________________
If the answer helped you, feel free to click "Add to Reputation" at the left side of the window.
linux markush is offline Add to markush's Reputation Report This Post Reply With Quote
Did you find this post helpful? Yes
markush
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
View LQ Wiki Contributions
Send email to markush
Visit markush's homepage!
Find More Posts by markush
Add markush to Your Contacts
Old 12-24-10, 08:29 PM #5
K.out
LQ Newbie

Registered: Oct 2008
Posts: 15

Original Poster
Rep: Reputation: 0

Yes, I am using DHCP; I think that was default.

The encryption is set up with the router as well, lynksys software.

I always see people ask to post the results of iwconfig and ifconfig. What is gained from these postings, or what are you looking for in the results? Is it safe to post these? For instance, is it safe to give out your mac address?


Thank you,
K.out
linuxubuntu K.out is online now Click to check your reputation for this post Report This Post Edit/Delete Message Reply With Quote
K.out
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
Send email to K.out
Find More Posts by K.out
Add K.out to Your Contacts
Old Yesterday, 03:34 AM #6
markush
Senior Member

Registered: Apr 2007
Location: Germany
Distribution: Slackware and Gentoo
Posts: 1,032

Rep: Reputation: 160Reputation: 160

Quote:
Originally Posted by K.out View Post
I always see people ask to post the results of iwconfig and ifconfig. What is gained from these postings, or what are you looking for in the results? Is it safe to post these? For instance, is it safe to give out your mac address?
Well, you're inside a network which uses NAT (Network Adress Translation) which means that your router has a public IP-adress (which you really should not post here) and on the other side of the router, where your computer resides, there are private IP-adresses used, mostly 192.168.1.xxx and similar. The ifconfig command shows you, amongst other things, the private IP-adress which is useless for someone who would compromise your system from the internetside. So it is safe to post your private IP-adress here.

For the MAC-adress it is slightly different. When it comes to wireless networks, you're router can refuse unknown MAC-adresses (if you've configured this feature). If someone wants to connect to your wireless network and sees your MAC-adress here at LQ, he/she might use so called MAC-spoofing in order to make his/her computer's wireless adapter pretend to have the same MAC-adress as your's. But this is more a theoretical problem. You may therefore change the MAC-adress in the output of ifconfig or iwconfig to xx.xx.xx.xx.xx.xx.
Quote:
...or what are you looking for in the results?...
At iwconfig I look for Accesspoint, connected or not authenticated.
At ifconfig I look if you have an apropriate IP-configuration for your network and if there is no output at all, one can assume that the apropriate driver is missing.

Markus
__________________
If the answer helped you, feel free to click "Add to Reputation" at the left side of the window.
linux markush is offline Add to markush's Reputation Report This Post Reply With Quote
Did you find this post helpful? Yes
markush
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
View LQ Wiki Contributions
Send email to markush
Visit markush's homepage!
Find More Posts by markush
Add markush to Your Contacts
Old Yesterday, 10:54 AM #7
K.out
LQ Newbie

Registered: Oct 2008
Posts: 15

Original Poster
Rep: Reputation: 0

Cool, thanks for the description. It's nice to actually learn about some of this stuff instead just having somebody fix it for me.

me@me-name:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:"connection"
Mode:Ad-Hoc Frequency:2.412 GHz Cell: xx:xx:xx:xx:xx:xx
Tx-Power=20 dBm
Retry long limit:7 RTS thrff Fragment thrff
Power Managementff

me@me-name:~$ ifconfig
eth0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:6079 errors:0 dropped:0 overruns:0 frame:0
TX packets:5650 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5254777 (5.2 MB) TX bytes:790697 (790.6 KB)
Interrupt:18

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:236 errors:0 dropped:0 overruns:0 frame:0
TX packets:236 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:17800 (17.8 KB) TX bytes:17800 (17.8 KB)

wlan0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet addr:10.42.43.1 Bcast:10.42.43.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:4786 (4.7 KB)



Ok, here is the output of the iwconfig and ifconfig. I just replaced the mac addresses with x's. I don't know what CELL is, or what it is used for, but it was different than any mac address and I replaced it with x's as well. I entered the commands when I was only connected to wireless. I just used a wired connection to copy them here after the fact. I don't think that matters though... because it seems like a history of your connections?

Also, as I said before it seems strange that it would say that I am connected, but I don't have a router assigned IP; I have that strange IP.


Thanks again,
K.out
linuxubuntu K.out is online now Click to check your reputation for this post Report This Post Edit/Delete Message Reply With Quote
K.out
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
Send email to K.out
Find More Posts by K.out
Add K.out to Your Contacts
Old Yesterday, 11:08 AM #8
markush
Senior Member

Registered: Apr 2007
Location: Germany
Distribution: Slackware and Gentoo
Posts: 1,032

Rep: Reputation: 160Reputation: 160

This is at least a valid IP-configuration for a 10.42.43.0/24 network with the SSID "connection".
Is this the name of your wireless lan?
But I'm missing some output in iwconfig.

What did you do in order to configure your wireless adapter for your wireless network?

could you please post the output of
Code:

cat /etc/resolv.conf

this is the adress of the nameserver and should also be configured via DHCP.

Markus
__________________
If the answer helped you, feel free to click "Add to Reputation" at the left side of the window.
linux markush is offline Add to markush's Reputation Report This Post Reply With Quote
Did you find this post helpful? Yes
markush
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
View LQ Wiki Contributions
Send email to markush
Visit markush's homepage!
Find More Posts by markush
Add markush to Your Contacts
Old Yesterday, 09:49 PM #9
K.out
LQ Newbie

Registered: Oct 2008
Posts: 15

Original Poster
Rep: Reputation: 0

Yes, that is the ssid that of my network.
Also, what is a 10.42.43.0/24 network?
I thought that I had a 192.168.1.100/150

That was the complete iwconfig output.

I don't know of doing anything to configure the wireless
Adapter aside from installing the broadcom b43 wireless
Driver. Is that what you mean?

The cat /etc/resolve.conf just says
# Generated by NetworkManager
macos K.out is online now Click to check your reputation for this post Report This Post Edit/Delete Message Reply With Quote
K.out
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
Send email to K.out
Find More Posts by K.out
Add K.out to Your Contacts
Old Today, 03:59 AM #10
markush
Senior Member

Registered: Apr 2007
Location: Germany
Distribution: Slackware and Gentoo
Posts: 1,032

Rep: Reputation: 160Reputation: 160

Well, what about the encryption? did you tell your computer which key to use? and if so, which tool did you use? Did you configure your computer to use DHCP?

And there is no entry for a nameserver in the resolv.conf, which means altogether you'r computer has got no valid IP-configuration via DHCP.

I'd assume that you are not connected to your network. Unfortunately I don't have any experience with Ubuntu, so I can't tell where to enter the key and how to restart wlan0.

Maybe you'd be better off to post this issue in an Ubuntu forum http://www.linuxquestions.org/questions/ubuntu-63/

Quote:
...Also, what is a 10.42.43.0/24 network?...
it's another notation for a network with networkadress 10.42.43.0 (the lowest ip in a network is the network adress) and 24bit subnetmask (255.255.255.0)
Quote:
...I thought that I had a 192.168.1.100/150
no, this is not a valid networkadress.

Markus

Markus
__________________
If the answer helped you, feel free to click "Add to Reputation" at the left side of the window.
linux markush is offline Add to markush's Reputation Report This Post Reply With Quote
Did you find this post helpful? Yes
markush
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
View LQ Wiki Contributions
Send email to markush
Visit markush's homepage!
Find More Posts by markush
Add markush to Your Contacts
Old Today, 07:35 AM #11
ssreddy555
LQ Newbie

Registered: Dec 2010
Posts: 3

Rep: Reputation: 0

Select TKIP
In the wireless router interface, select security option as WPA2, select Encryption Protocol as AES - CCMP (& not TKIP) & Authentication method as Pre Selection Key (PSK) & give ur password in PSK field.

Selection of AES protocol is important. Seems Linux cannot decrypt TKIP.

Let me know whether u are successful.
linux ssreddy555 is offline Add to ssreddy555's Reputation Report This Post Reply With Quote
Did you find this post helpful? Yes
ssreddy555
View Public Profile
View LQ Blog
View Review Entries
View HCL Entries
Send email to ssreddy555
Find More Posts by ssreddy555
Add ssreddy555 to Your Contacts
Old Today, 10:22 AM #12
K.out
LQ Newbie

Registered: Oct 2008
Posts: 15

Original Poster
Rep: Reputation: 0

It is already set to wpa2 and aes. There is no option for ccmp; so, I can't select that. I don't have tkip selected, and the is no field labeled psk, but I am guessing that the field I entered the password in is the same thing.
 
Old 12-26-2010, 11:16 AM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Okay. I've read the entire post above. It looks like you are on the right track.

The first thing that I would do is to log on to the wireless router and see how it is configured. The network subnet of 10.42.43.x may be the way the wireless router is set up or it may not be. If it is not then it means that you have gotten that address another way, probably by some configuration file on your computer.

I would plug an Ethernet cable into your computer and the wireless router. Log on to the router. Look at the wireless settings. See what address range the wireless router is configured to use. Also check to see if your wireless router is limiting service to specific MAC addresses. That is good to do when you have everything running but it could be a problem at this point.

Next I would use the Network Manager in Ubuntu to create the connection to the wireless router. System -> Preferences -> Network Connections -> Wireless. I would probably remove anything that is in there then add a new connection. You should be able to enter the correct information into that application to create the connection.

Last edited by stress_junkie; 12-26-2010 at 11:19 AM.
 
1 members found this post helpful.
Old 12-26-2010, 08:21 PM   #3
K.out
LQ Newbie
 
Registered: Oct 2008
Posts: 23

Original Poster
Rep: Reputation: 1
Thank you for the reply. The router is not configured to take the address 10.42.43.x it is configured to lease IPs in the range of 192.168.1.100 - 192.168.1.149. I am not blocking any mac addresses.

In NetworkManager, how do I know what to enter in device MAC address, and how do I know what to enter in DCHP client id in IPv4 settings?


Thanks again,
K.out
 
Old 12-27-2010, 05:11 AM   #4
ssreddy555
LQ Newbie
 
Registered: Dec 2010
Posts: 4

Rep: Reputation: 2
If DHCP is set to ON in the router, Simply check Auto in network connections in the computer. It will get the IP Address automatically within the range specified in the router & will also get the DNS from the router automatically provided the DNS is configured in the router.

See that the MAC Address in the router is not configured either for white list or black list. It should be "disabled".

Last edited by ssreddy555; 12-27-2010 at 05:15 AM.
 
1 members found this post helpful.
Old 12-28-2010, 05:55 PM   #5
K.out
LQ Newbie
 
Registered: Oct 2008
Posts: 23

Original Poster
Rep: Reputation: 1
Yup, thanks for the help; I think the problem might just have been the user rather than the system. I am not positive, but I think that I was entering my network key wrong and I didn't realize it until another node in the network couldn't connect yesterday. Eventually, I looked in the router settings and noticed what I was typing was not the actual password.

I don't know what I was supposedly "connecting" to before. Also, it was printing something called "CELL" in iwconfig. I didn't know what that was. I reinstalled the OS, and tried the ndiswrapper route following some online instructions and installing a windows driver. Then, I became confused and/or that didn't seem to connect at all. Then, I tried installing the recommended b43 driver from the system->administration->addition drivers window. This time my network was automatically realized, and iwconfig printed the access point instead of the cell. Then, once I typed the right key I was able to connect.

Thanks for all of the help,
K.out
 
1 members found this post helpful.
Old 01-06-2011, 12:36 AM   #6
himanshumarwaha
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
Unhappy

Hi

I have just downloaded 10.10 yesterday and was liking it so far, until i did an update and some 220 applications got updated. Ever since I am unable to browse internet on wifi. It was working fine before the update. I can browse when connected to ethernet, but not on wifi
My network connections as follows:
ADSL modem --> Linksys WRT54G wifi router

if i connect directly to the modem, internet works!
I have tried resetting the DNS on the computer as per on the modem but no luck!

It works when i log on to win7 which was my original OS. Also wifi works smooth on my pda and smart phone, its only ubuntu its not working on!

Please help.
 
Old 03-05-2011, 01:14 PM   #7
majickmann
LQ Newbie
 
Registered: Mar 2006
Location: Outside the Nashville, TN area...
Distribution: RHEL, UBUNTU
Posts: 2

Rep: Reputation: 0
Please don't hijack... open a new thread with description of your issue.

thanks,
:-)
 
  


Reply

Tags
connection, ubuntu+10.10, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't connect to internet using wireless on Ubuntu 10.10 despite having a connection K.out Linux - Newbie 12 12-28-2010 05:59 PM
how to connect to internet using dsl connection at a time for wireless and wired itrilok Linux - Networking 2 06-14-2010 09:27 AM
Linux Connect to internet via Windows XP wireless connection khskinsfan Linux - General 6 09-02-2009 09:45 PM
Looking for help to connect to internet with wireless connection donnymac2005 Linux - Wireless Networking 2 10-05-2008 09:54 PM
Unable to connect to internet via wireless OR wired connection frznchckn Linux - Wireless Networking 5 06-19-2008 01:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 09:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration