LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Brother scanner problems (https://www.linuxquestions.org/questions/ubuntu-63/brother-scanner-problems-4175661222/)

wufo 09-20-2019 03:46 PM

Brother scanner problems
 
I have installed a Brother DCP-7040 printer/scanner and the print part works fine. I am having problems with the scanner part.

After running the Brother installer and adding the user to the lp group i do this:

sane-find-scanner
..
found USB scanner (vendor=0x04f9, product=0x01e9) at libusb:001:019
..

So it finds the scanner.But, I run
scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

And, of course simple scan, etc find no scanner.

ONe detects the scanner and the other does not. Why?

I know the sacnner works as I used it under Windows.

ubuntu 18.04

tj

ferrari 09-20-2019 05:45 PM

Some things to check....

1. Did you install the Brother scanner package yet?

2. Check that the relevant user is a member of the ‘lp’ group for r/w access to a USB-connected scanner.

3. Check that the Brother SANE backend (brother3) is present and uncommented in /etc/sane.d/dll.conf

ferrari 09-20-2019 05:49 PM

Further to point 1 above, the requisite packages for the DCP-7040 are here....

https://support.brother.com/g/b/down...0_us_as&os=127

wufo 09-21-2019 10:49 AM

Yes, brother3 ids in /etc/sane.d/dll.conf and user is in lp group.

tj

ferrari 09-21-2019 05:44 PM

Which Ubuntu version? Review the Brother scanner FAQ for any distro-specific steps that may be required. Make sue there is a udev rules file for the Brother scanner device in the /etc/udev/rules.d/ directory. For example, I have 55-brother-brscan4-libsane-type1.rules installed (as part of the scanner package install).

We can also examine the kernel messaging when the device is first attached. For that open a terminal window and do
Code:

dmesg -follow
then plug in the scanner and observe/capture the output. When posting such output, please enclose within code tags (refer to the '#' button in the advanced forum editor).

ferrari 09-21-2019 06:30 PM

Another thought - sometimes USB 3.0 host controllers can cause issues with older scanner hardware, so if you have a mixture of USB 2.0 and USB 3.0 ports available, try using the former to see whether that makes a difference.

wufo 10-02-2019 04:45 PM

I upgraded my hard drive, so I did a completely fresh ubuntu 18.04 install and once againg tried to install scanner, and once again failure.
I have a vm of 16.04 that the scanner works perfectly under. I compared the udev files, etc to the 18.04 and everything is the same.

The only quirk I saw was that during the instgall on 18.04 I got this message:
Unpacking brscan-skey (0.2.4-1) ...
Setting up brscan-skey (0.2.4-1) ...
ls: cannot access '/etc/udev/rules.d/*.rules': No such file or directory

However, when I look the directory does exist with 60-brother-libsane-type1-inst.rules in it. I guess the install program created the directory.

I don't know what to try next.

tj

ferrari 10-02-2019 06:31 PM

Return to the advice in post #5 and provide the dmesg output please.

wufo 10-05-2019 10:49 AM

Here is dmesg output at plug in

[ 393.508832] usb 1-1.3: new full-speed USB device number 7 using ehci-pci
[ 393.622170] usb 1-1.3: New USB device found, idVendor=04f9, idProduct=01e9, bcdDevice= 1.00
[ 393.622176] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=3
[ 393.622180] usb 1-1.3: SerialNumber: 000C8N162711
[ 393.751654] usblp 1-1.3:1.0: usblp1: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x04F9 pid 0x01E9
[ 393.751941] usbcore: registered new interface driver usblp
[ 399.189872] usblp1: removed
[ 399.197387] usblp 1-1.3:1.0: usblp1: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x04F9 pid 0x01E9

tj

ferrari 10-05-2019 04:29 PM

Check the device permissions pertaining to your USB-connected scanner...
Code:

ls -l /dev/bus/usb/*/*
*If you need help determining that, run
Code:

sane-find-scanner
and that will report the bus and device number for the attached scanner.


All times are GMT -5. The time now is 01:25 AM.