LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-30-2009, 05:09 PM   #1
hawk__0
Member
 
Registered: Nov 2008
Posts: 105

Rep: Reputation: 15
Broke default theme somehow


I can't figure this out, everything checks out. My problem is that the default themes all disappeared from the appearance menu. After copying the icons and themes from /usr/share/icons and /usr/share/themes to ~/.icons/ and ~/.themes/ I have gained access to most of the stuff. Icons still not working correctly, but bits of the themes are. Permissions are all set to 755, and username:username, just like the rest of the stuff in my home folder. Certain parts of the theme are broken though. Even at the login screen

What could be wrong? Things I did to my system recently would be:
-compiled/installed atk-1.29.4 from source
-compiled/installed gtk+-2.19.2 (<--- my guess as to what the issue is).

I also installed a few other packages with apt-get, but didn't uninstall anything... I don't think so at least.

I did this so I could install a game from source, my buddy did the exact same on ubuntu 8.10 and he has no problems. Any idea how I can fix this?? Where does ubuntu store it's main default theme? The login screen is even ugly...
 
Old 12-31-2009, 07:12 AM   #2
DragonSlayer48DX
Registered User
 
Registered: Dec 2006
Posts: 1,454
Blog Entries: 1

Rep: Reputation: 74
Quote:
Originally Posted by hawk__0 View Post
-compiled/installed gtk+-2.19.2 (<--- my guess as to what the issue is).
Possibly a broken dependency, there. Try:

Code:
sudo dpkg-reconfigure gtk
in the terminal. If that doesn't work, boot Recovery Mode, and run XFIX.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade from KDE 3.5.3 to 3.5.6 broke Plastik theme lpwevers Linux - Software 2 02-01-2007 03:10 AM
default theme gnome hraposo Ubuntu 1 01-20-2007 06:32 PM
Theme file for default has no name darkscot Mandriva 1 01-08-2007 04:38 AM
Configuring the default theme yjshah Linux - Newbie 0 07-14-2003 05:19 AM
icewm and default theme j_developer Linux - General 2 09-13-2002 04:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 02:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration