-   Ubuntu (
-   -   Audio stopped working on 9.10 x64 (

gimpy530 06-23-2010 12:44 AM

Audio stopped working on 9.10 x64
I have a media center box running Ubuntu 9.10 x64 and XBMC. One day sound just stopped working on it. I did not install any updates around the time this happened. I have tried using a known working sound card. I verified the main volume is up and everything else in alsamixer looks OK. I have tried connecting known working headphones. Confirmed the kernel sees the hardware and loads to module for it. Confirmed several audio applications have no sound. I've confirmed it is set to use the correct sound card. I even booted into a live disk of the same version if Ubuntu and audio works fine there.

No errors are produced by any application, they act like they are playing audio just fine. The only entries in the logs about this I can find is below.

What else can I do to get audio working again?


00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
        Subsystem: Micro-Star International Co., Ltd. Device 7585
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
        I/O ports at f000 [size=256]
        I/O ports at ec00 [size=256]
        Memory at fe02d000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: Intel ICH
        Kernel modules: snd-intel8x0


white@mulberry:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: CK804 [NVidia CK804], device 0: Intel ICH [NVidia CK804]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: CK804 [NVidia CK804], device 2: Intel ICH - IEC958 [NVidia CK804 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


white@mulberry:~$ sudo modprobe snd-intel8x0
white@mulberry:~$ echo $?


Relevant entires of /var/log/messages

Jun 23 01:25:33 mulberry kernel: [  20.340054] intel8x0: clocking to 47009
Jun 23 01:25:33 mulberry kernel: [  20.340050] intel8x0_measure_ac97_clock: measured 60720 usecs (2976 samples)

halvy 06-23-2010 07:23 AM

I'm not sure what linux you are using, but in debian when you install software there is a program that lists the bugs (known) that are related to any programs or libs that are going to be installed, just to warn you in case you don't want to install them with this new knowledge.

Maybe you installed another program, which changed or otherwise updated some files that are dependencies of your sound systems programs.

I'd try reinstalling all important sound related software, servers, etc... just to see if that helps.

Also either look over your config files (sound) or just reinstall them *fresh* and then tweak them later.

It sounds like a switch has been changed *somewhere*.. but by the time you find it, it may be easier to reinstall the major components of your sound system.

Lettuce know :)

tommcd 06-23-2010 07:52 AM

The OP said he was using Ubuntu 9.10.
Try the different settings under: system > preferences > sound. Try changing sound from PulseAudio to Alsa there. Try the "test" button with each sound option and see if the test produces sound.

halvy 06-23-2010 12:08 PM

well.. thanx for taking the time for correcting me on that very important issue.

gimpy530 06-23-2010 12:24 PM

Indeed, Ubuntu 9.10 x64.

tommcd, I went into that and played around with settings while I had a small wav file looping. It still did not work so I decided to look around and changed it so that everything is pointed to the secondary card I added to it to test. Still nothing. I then went back and reverted everything back to the on board card (which they were all set to in the beginning) and the wav started playing. So, it was set to use the internal card to start with but for some reason was not using it. No idea what started the problem as the second card was added later to test with, but it works now.

Thanks for your help.

tommcd 06-24-2010 11:00 AM


Originally Posted by gimpy530 (Post 4012818)
So, it was set to use the internal card to start with but for some reason was not using it. No idea what started the problem as the second card was added later to test with, but it works now.

Glad you got it working. If you have problems again, or would like to use the other sound card, then see this thread from the Ubuntu forums for setting the default sound card when you have 2 sound cards in Ubuntu:
You should also be able to run:

alsamixer -c 0

alsamixer -c 1
to choose which sound card you want to use. I can't test that since I have only 1 sound card. The cards are numbered starting from zero 0. So if you have 2 cards they would be 0 and 1.

Of course, if you are happy using the onboard sound card, then you could just remove the added pci sound card.

Mountain Man 07-11-2010 11:23 AM

I just had the same basic thing happen on a desktop running 9.10 x64. After reading this thread, I went into system/preferences/sound and changed the profile on the hardware tab to "none" and then rebooted. When it booted back up I switched it back to analog sterio output and it seems to be working fine now. Hopefully the fix will survive my next reboot.

All times are GMT -5. The time now is 12:08 PM.