LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 05-01-2008, 01:16 AM   #1
dbg
LQ Newbie
 
Registered: May 2007
Location: Auckland, New Zealand
Posts: 23

Rep: Reputation: 15
Audio cds won't play after upgrade to Ubuntu 8.04


Hi I hope someone out there can help. On my new Ubuntu 8.04 upgrade I can hear system sounds and hear audio on YouTube etc fine, but when I put an audio cd in the drive SoundJuicer produces a shrieking, stuttering and staticky sound when I try to play a track. Same with Rhythmbox. It sounds suspiciously like a sample rate mismatch, but I could be mistaken.

I've installed all relevant packages: gstreamer, restricted extras, w32 codecs etc. Maybe I have too many?

I've tried with all options in Sound Preferences changed to ALSA and PulseAudio disabled, no difference. The tests work fine with both. I've checked alsamixer and all seems ok. Levels of CD, Master and PCM about 75%, nothing muted. On my previous install of Gutsy on the same box everything worked fine straight away.

In Device Manager I can see the drive there (/dev/scd0 ). The Places menu shows an Audio CD, and both SoundJuicer and Rhythmbox show all the tracks and artist details.

When I first insert the disc I get an error message saying it is unable to mount audio disc, drive /dev/scd0 does not contain audio files.

Searching for two days has found many similar problems, two the same but they hadn't been answered. Every suggestion to install specific gstreamer codecs resulted in the message: latest version already installed.

I'm a bit terminal-challenged, or possibly terminally-challenged, so any suggestions of this kind need to be of the copy-and-paste kind.

Thanks for your time.
 
Old 05-02-2008, 12:20 PM   #2
gcy
LQ Newbie
 
Registered: Jun 2007
Distribution: gentoo
Posts: 26

Rep: Reputation: 15
Open up a terminal:

Check the following as root or "sudo" as you have ubuntu:

1. Check /etc/fstab to see whether there is an entry for your cdrom. If you are using hal you should not have a cdrom entry there.

2. do ls -l /dev/cdrom to see that there is a link to your /dev/sdc0 (assuming you are correct in stating that your cd drive is sdc0 ) If there isn't then you should make one. (See man ln if you don't know how to do this).

3. You should probably do the following first:-- Check with your mixer that the CD sound is turned on! A common fault.
 
Old 05-02-2008, 12:26 PM   #3
gcy
LQ Newbie
 
Registered: Jun 2007
Distribution: gentoo
Posts: 26

Rep: Reputation: 15
Addendum to my previous.
Have just re-read your posting and noted that you "mounted" your CD. You do not mount music or video CD's & DVD's. I don't think that will be relevant to your problem, however.
 
Old 05-02-2008, 04:49 PM   #4
dbg
LQ Newbie
 
Registered: May 2007
Location: Auckland, New Zealand
Posts: 23

Original Poster
Rep: Reputation: 15
Hi gcy and thanks for the reply. I checked /etc/fstab and this is the line about the cdrom:

/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0


I also did ls -l /dev/cdrom and this is the link stated:

lrwxrwxrwx 1 root root 3 2008-05-03 08:23 /dev/cdrom -> hdd


I've checked the mixer and cd is unmuted.

I also didn't try to mount the audio cd, I just stuck it in the drive and clicked on Audio CD in the Places menu. The system came up with the error message 'unable to mount audio disc' all on its own...

The /dev/scd0 description came from the entry in Device Manager for Optical Drive.

Any advice much appreciated. It's probably also worth mentioning that I used the cd drive with no problems before my upgrade. Thanks.
 
Old 05-02-2008, 08:42 PM   #5
dbg
LQ Newbie
 
Registered: May 2007
Location: Auckland, New Zealand
Posts: 23

Original Poster
Rep: Reputation: 15
Update

Ok so I searched for how to create a link (ln man too challenging for me to follow), found this and put "ln -s /dev/scd0 /dev/cdrom" in a terminal, which told me that the link already exists. Was that line correct? Should I try changing /dev/hdd to /dev/scd0 in /etc/fstab as recommended by another posting I read? You said that there shouldn't be an entry in /etc/fstab for a cdrom anyway, so I'll wait for further advice... Sorry for the barrage of questions...

Thanks!
 
Old 05-03-2008, 05:38 AM   #6
gcy
LQ Newbie
 
Registered: Jun 2007
Distribution: gentoo
Posts: 26

Rep: Reputation: 15
CD problems

Quote:
Originally Posted by dbg View Post
Update

Ok so I searched for how to create a link (ln man too challenging for me to follow), found this and put "ln -s /dev/scd0 /dev/cdrom" in a terminal, which told me that the link already exists. Was that line correct? Should I try changing /dev/hdd to /dev/scd0 in /etc/fstab as recommended by another posting I read? You said that there shouldn't be an entry in /etc/fstab for a cdrom anyway, so I'll wait for further advice... Sorry for the barrage of questions...

Thanks!
From your info all seems correct if you are using the "pre-hal" "mount" command. Your cd drive is /dev/hdd. It should be mounted on /media/cdrom0, and can be accessed as /dev/cdrom. However, most later linux distos now use another form of mounting, which makes the "mount" command redundant for USB memory sticks, CD's and DVD's. If you have both there are conflicts. By having the entry in your /etc/fstab file it looks for a mount point /media/cdrom0 which probably does not exist. Using hal, the mount point is made automatically.

Try commenting out the line "/dev/hdd /media/cdrom0 udf,iso9660,noauto 0 0" by putting a '#' in front of it, in your /etc/fstab file. Then reboot. See then if the cdrom icon appears on your screen. It should be located as /media/hdd, /media/cdrom0 or similar. If that doesn't work then you can uncomment the line afterwards.

Good luck!

I would comment that if you are to proceed with linux you're going to have to struggle through a few "man" pages from time to time!!

Last edited by gcy; 05-03-2008 at 05:40 AM. Reason: letter omitted
 
Old 05-04-2008, 12:18 AM   #7
dbg
LQ Newbie
 
Registered: May 2007
Location: Auckland, New Zealand
Posts: 23

Original Poster
Rep: Reputation: 15
Here we go. I tried commenting out the line you recommended gcy, rebooted and tried again. CD won't play, but Audio CD icon did appear on desktop. I removed the # to put the line back. Obviously something wrong somewhere. Then I decided to reinstall from the only ISO I had handy (Feisty), and upgraded to a vanilla Hardy. I put an audio CD in the drive, an Audio CD icon appeared on the desktop, Rhythmbox started, the tracks loaded, I clicked Play and... the same horrible sound. I installed ubuntu-restricted extras in case a codec issue remained, rebooted, tried again, same sound.

Then I checked /etc/fstab and the same line as the previous install was there (/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0). I did ls -l /dev/cdrom and was told no such link exists. Then I did ln -s /dev/scd0 /dev/cdrom to try to establish one. That was accepted without comment, so I rebooted, put in CD, same sound except a warning message that the audio cd could not be mounted, does not contain audio files. I didn't try to mount it. So maybe Hal is missing? I have checked Synaptic and the Hal Device Manager is obsolete and was therefore removed, but other packages have hal in their title.

I'm stumped. Any advice much appreciated again. I'll re-search.
 
Old 05-04-2008, 05:24 PM   #8
dbg
LQ Newbie
 
Registered: May 2007
Location: Auckland, New Zealand
Posts: 23

Original Poster
Rep: Reputation: 15
Another update. I found this bug and it looks very similar to mine. I followed a suggestion there and added my username to haldaemon (System->Admin->Users and Groups), rebooted, and my system now recognises an audio cd, automounts (or there's no "can't mount audio cd" error message), opens Rhythmbox, lists tracks, but still plays garbage. Progress though! I've also noticed that PulseAudio's sample type is set to a default of 48000. I thought audio cds have wavs at 44100? And that's the limit of my sound knowledge... Possibly past it. I feel like I'm starting to look in the right direction, advice still much appreciated.

Last edited by dbg; 05-05-2008 at 02:58 AM. Reason: typo
 
Old 05-05-2008, 04:50 AM   #9
gcy
LQ Newbie
 
Registered: Jun 2007
Distribution: gentoo
Posts: 26

Rep: Reputation: 15
Audio CD's

Quote:
Originally Posted by dbg View Post
Another update. I found this bug and it looks very similar to mine. I followed a suggestion there and added my username to haldaemon (System->Admin->Users and Groups), rebooted, and my system now recognises an audio cd, automounts (or there's no "can't mount audio cd" error message), opens Rhythmbox, lists tracks, but still plays garbage. Progress though! I've also noticed that PulseAudio's sample type is set to a default of 48000. I thought audio cds have wavs at 44100? And that's the limit of my sound knowledge... Possibly past it. I feel like I'm starting to look in the right direction, advice still much appreciated.
...................................................................
It's tricky not having your machine in front of me. I'm sure it's just a minor problem which could be solved with a few tests!

I think a few basics should be clarified:

1. I have assumed that your drives are IDE, and that you have either three or four drives since your CD is designated hdd. It will therefore be the slave drive on IDE 2. Is this correct?

2. Is hdd a DVD that can play CD's or is it just a CD-Drive? Since you have installed your system, presumably from a DVD I assume it is a DVD drive, unless you have two optical drives.

3. I don't use Ubuntu although I have tried it out, so I have a little idea how it works, but I'm not familiar with some of the Windows type terminology that is used with it. However, in my experience all flavours of linux are basically the same, and all run pretty much the same programs. I'm not familiar either, with the pulseaudio program.

4. Hal is not redundant. Adding your name to the haldaemon in the /etc/group file is evidence that you have it on your system. You should also add your name to "plugdev" and to "cdrom" in the "group" file, remembering to enter a comma after the previous entry.

5. I wrote item 3. above since I don't know whether you have kde or gnome installed. I believe the basic ubuntu uses xfce as a window manager, but has the facility to install kde or gnome. Anyway, I suggest you try running kscd if you have kde, or a similar cdplayer program other than the one you have tried. Don't forget that it will have to be set up to recognise your drive first, but that's a simple matter.

6. I have also assumed that you have no difficulties with data disks on this drive, and if so, the drive must be sound... except that ... I once had a DVD drive that ran and wrote DVD's perfectly, although it suddenly stopped being able to read a CD .

7. If the drive is a DVD then you will also need a symbolic link to /dev/hdd for /dev/dvd. I you don't have one then do:
"ln -s /dev/hdd /dev/dvd"

I hope all this helps and doesn't confuse you further!

Last edited by gcy; 05-05-2008 at 04:52 AM. Reason: wrong program name
 
Old 05-05-2008, 05:53 AM   #10
dbg
LQ Newbie
 
Registered: May 2007
Location: Auckland, New Zealand
Posts: 23

Original Poster
Rep: Reputation: 15
Hi gcy and thanks again.
1. I have 2 IDE hard drives (master and slave) and one cd drive. It's only a cd drive, not a cdr or dvd drive, and here I run out of knowledge, so I'll guess and say of course it's a slave drive on IDE2. I'll find out. Oh and I also have a zip drive and a floppy drive. It's an old box.
2. A cd drive only - I installed Feisty from cd, then upgraded.
3. Pulseaudio is a mystery to me, but not for much longer I guess. I'm sure it's something to do with the problem. It has little, beady eyes...
4. I checked and my username is attached to plugdev and cdrom in the 'group' file.
5. Ubuntu uses Gnome, but that's a good idea, I'll try another player and see how I go. SoundJuicer doesn't work either.
6. I used the drive to install the system, and did use it a few weeks ago to copy an audio file, so I think it's ok, but worth keeping in mind.
7. Drive cd only.

I'll check out your suggestions gcy and post an update. Cheers.
 
Old 05-05-2008, 04:47 PM   #11
dbg
LQ Newbie
 
Registered: May 2007
Location: Auckland, New Zealand
Posts: 23

Original Poster
Rep: Reputation: 15
Mmm. The latest updates broke the system's ability to recognise audio cds and I get the same "unable to mount audio cd, does not contain audio files" message, and no icon on the desktop, no Rhythmbox starting etc. The /etc/group file hasn't changed though. This is it if it helps.

Quote:
root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:dbg
tty:x:5:
disk:x:6:
lp:x:7:cupsys
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:cupsys,dbg
fax:x:21:
voice:x:22:
cdrom:x:24:haldaemon,dbg
floppy:x:25:haldaemon,dbg
tape:x:26:
sudo:x:27:
audio:x:29:dbg,pulse
dip:x:30:dbg
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:dbg
sasl:x:45:
plugdev:x:46:haldaemon,dbg
staff:x:50:
games:x:60:
users:x:100:dbg
nogroup:x:65534:
dhcp:x:101:
syslog:x:102:
klog:x:103:
scanner:x:104:cupsys,hplip,dbg
nvram:x:105:
messagebus:x:106:
ssl-cert:x:107:cupsys
crontab:x:108:
ssh:x:109:
avahi-autoipd:x:110:
avahi:x:111:
netdev:x:112:dbg
lpadmin:x:113:dbg
haldaemon:x:114:dbg
powerdev:x:115:haldaemon,dbg
admin:x:117:dbg
gdm:x:118:
fuse:x:119:
dbg:x:1000:
libuuid:x:120:
pulse:x:121:dbg
pulse-access:x:122:dbg
pulse-rt:x:123:dbg
mlocate:x:124:
polkituser:x:125:
This is my audio device

Quote:
**** List of PLAYBACK Hardware Devices ****
card 0: rev50 [VIA 82C686A/B rev50], device 0: VIA 82C686A/B rev50 [VIA 82C686A/B rev50]
Subdevices: 1/1
Subdevice #0: subdevice #0
This is my /etc/fstab

Quote:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda1
UUID=fcf9d9fb-070d-4148-bd66-0c12d09253a5 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda5
UUID=2c7be6f3-959d-4913-9be4-365edc8c9c32 none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
This is my cdrom info

Quote:
*-cdrom
description: SCSI CD-ROM
product: ATAPI CDROM.
physical id: 3
bus info: scsi@1:0.1.0
logical name: /dev/cdrom1
logical name: /dev/scd0
logical name: /dev/sr0
version: 10AH
capabilities: removable audio
configuration: ansiversion=5 status=open
Hopefully not information overload. Thanks to anyone who can help.
 
Old 05-07-2008, 04:53 PM   #12
dbg
LQ Newbie
 
Registered: May 2007
Location: Auckland, New Zealand
Posts: 23

Original Poster
Rep: Reputation: 15
Update

I installed Amarok, looks great, configured it to scan cdrom for audio files. When I ask it to play audio cd, it says "cannot read audio cd". Today's updates fixed the system's ability to recognise audio discs, so it's back to just the actual audio file from cdrom issue. I've also noticed that when I double-click on the audio cd icon on the desktop, or select it from the places menu, the folder shows the disc's .wav files, all with a padlock icon. Maybe there's a remaining permissions issue?
 
Old 05-08-2008, 12:02 PM   #13
gcy
LQ Newbie
 
Registered: Jun 2007
Distribution: gentoo
Posts: 26

Rep: Reputation: 15
Quote:
Originally Posted by dbg View Post
Update

I installed Amarok, looks great, configured it to scan cdrom for audio files. When I ask it to play audio cd, it says "cannot read audio cd". Today's updates fixed the system's ability to recognise audio discs, so it's back to just the actual audio file from cdrom issue. I've also noticed that when I double-click on the audio cd icon on the desktop, or select it from the places menu, the folder shows the disc's .wav files, all with a padlock icon. Maybe there's a remaining permissions issue?
....................................................
You do need to be a member of the audio group, and I notice from the files that you are, so that is not the problem.

What does confuse me is the list you tabulated under the cdrom heading. Where did this information come from? It cannot be all of these types. If the original is /dev/hdd and connected to your ide system it cannot be designated /dev/scd0 and /dev/sr0 as well. These are sata drives. Anyway, According to your fstab file the cdrom, which you do seem able to access is mounted at /media/cdrom0. Check that by typing the command "mount" in a terminal. That will give you a list of all mounted drives, and where they are mounted. Given that your cdrom is /devhdd then I suggest you give that as it's name for any programs which ask for it in their configuration.

I assume you have tried to play more that one CD ---That it's not just one CD which is damaged and therefore unplayable?

Failing that it looks like a software problem to me. You just don't have the necessary libraries to play the sound files. This would seem to be rather odd if you have music programs installed. Check to see if you have alsa-utils installed and if not then install it. (update your modules after installation if the system does not do that automatically).

You could install audacity and rezound as well: these are both quite useful music editing programs, and installing them would probably pick up any missing sound libraries.

Beyond that, I don't think I can help you much. If you are able to read CD's, have the correct software to play them, and the CD's are not damaged but they still wont play then I'm as mystified as you are!
 
Old 05-08-2008, 12:16 PM   #14
gcy
LQ Newbie
 
Registered: Jun 2007
Distribution: gentoo
Posts: 26

Rep: Reputation: 15
Quote:
Originally Posted by dbg View Post
Update

I installed Amarok, looks great, configured it to scan cdrom for audio files. When I ask it to play audio cd, it says "cannot read audio cd". Today's updates fixed the system's ability to recognise audio discs, so it's back to just the actual audio file from cdrom issue. I've also noticed that when I double-click on the audio cd icon on the desktop, or select it from the places menu, the folder shows the disc's .wav files, all with a padlock icon. Maybe there's a remaining permissions issue?
Addendum to my last.

I wasn't thinking straight! You are quite right. It can only be a permission problem. put "users" instead of "user" in your ftab file. You could also see if you are able to play music cd's as sudo. to do this with amarok simply open the program from the command line.
If you can play the files as root then it is obviously a permissions problem.
 
Old 05-08-2008, 05:33 PM   #15
dbg
LQ Newbie
 
Registered: May 2007
Location: Auckland, New Zealand
Posts: 23

Original Poster
Rep: Reputation: 15
Thanks again gcy for taking the time to help me out. As far as I can see, my vanilla install of Hardy sees my cdrom as: /dev/hdd, /dev/cdrom1, /dev/scd0, /dev/sr0 and it's also decribed as cdrom0 in /media. Surely something's awry? I don't know what the proper configuration should be. I do recall reading somewhere that under Linux, IDE cdroms are treated as SCSI devices, not sure why, and I might be mistaken.

The device info about the cdrom came from a terminal command cd-info or something like that, I googled how to do it and I can't for the life of me track the page down again. I checked and alsa-utils is installed, and I've also re-installed just to be on the safe side. I changed user to users in /etc/fstab, rebooted but the audio issue persists, so I've changed it back again for the moment.

I checked Hardy's GUI for Users and Groups. Should root be a member of Users? I am, and the other option under User Properties (unchecked) is root. Should the same apply to the other audio groups (pulse, haldaemon etc) as only my username is checked under all these, not root? Ref bug report re Users and Groups quoted somewhere above.

Anyway, work calls. Oh and I've tried a number of cds, all of which play on my standalone cd player, none in the cdrom. I'll try the play cd from terminal option later and post an update. Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Play Audio CDs Soobwrex Linux - Hardware 14 02-10-2005 02:39 AM
cannot play audio CDs adidasguy Mandriva 2 11-09-2004 07:05 PM
Cant play audio cds with any apps. SnowSurfAir Linux - Software 9 07-24-2004 09:03 PM
Can't play audio cds p1az Fedora 3 06-01-2004 07:15 PM
Cannot play/use audio cds Riichard Linux - General 2 11-21-2003 09:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 01:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration