-   Ubuntu (
-   -   apt-get/synapic access through proxy (

KingE 09-19-2006 04:28 AM

apt-get/synapic access through proxy

I am trying to get the synaptic package manager and apt-get to work through our squid proxy.
With no authentication required by the proxy server it worked fine. However our sysadmins then went and configered squid to make sure users authenticate themselves. The squid proxy server points to a windows Active Directory domain for authentication.

I have read some of the other threads which suggest updating apt.conf with
Acquire::http::Proxy "http: //user:pwd@proxy:port"; Acquire::ftp::Proxy "ftp: //user:pwd@proxy:port";

This still did not work for me because the "user" part of the URL has to become "Domain/userid" to be authenticated. for example if my Domain = ZA and userid = mwe the in apt.conf I have
"http: //ZA/" .
Apt cannot seem to handle the '/' in the URL, and I get the following errors

Failed to fetch http: // Could not resolve ''ZA'
Failed to fetch http: // Could not resolve ''ZA'

I have tried single quoting('ZA/mwe') the user part of the URL, but still no luck.

So Im hoping that someone has encounted a problem like this and can give me a few constructive suggestions or a fix to resolve?

All times are GMT -5. The time now is 12:59 AM.