LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 07-12-2006, 06:47 PM   #1
ctkroeker
Senior Member
 
Registered: May 2005
Location: Paraguay
Posts: 1,565
Blog Entries: 1

Rep: Reputation: 50
Apt-get problem


When ever I try to do anything with apt-get, I get this error:
Code:
Preconfiguring packages ...
(Reading database ... 120897 files and directories currently installed.)
Preparing to replace samba 3.0.22-1ubuntu3 (using .../samba_3.0.22-1ubuntu3.1_i386.deb) ...
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
dpkg: warning - old pre-removal script returned error exit status 102
dpkg - trying script from the new package instead ...
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
dpkg: error processing /var/cache/apt/archives/samba_3.0.22-1ubuntu3.1_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 102
Errors were encountered while processing:
 /var/cache/apt/archives/samba_3.0.22-1ubuntu3.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Does anyone know how to solve this? I can't use apt-get for anything right now, so I'd really like to solve this ASAP.
 
Old 07-12-2006, 07:02 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 272Reputation: 272Reputation: 272
Try sudo aptitude update && sudo aptitude -f dist-upgrade. the -f switch will try to fix any problems with currently installed packages. For some reason it looks like something happened when samba was uninstalled...
 
Old 07-12-2006, 07:24 PM   #3
ctkroeker
Senior Member
 
Registered: May 2005
Location: Paraguay
Posts: 1,565

Original Poster
Blog Entries: 1

Rep: Reputation: 50
I tried that and no go. I did stop samba before doing that.
 
Old 07-12-2006, 08:19 PM   #4
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 272Reputation: 272Reputation: 272
Did you try forcing a reinstall? sudo aptitude -f reinstall samba
 
Old 07-12-2006, 08:55 PM   #5
ctkroeker
Senior Member
 
Registered: May 2005
Location: Paraguay
Posts: 1,565

Original Poster
Blog Entries: 1

Rep: Reputation: 50
Ok, it asked me if I wanted to downgrade, and I said yes and it worked! Thanks!
Weird though that I tried the same tning with apt-get, and no go, but with aptitude it worked. Now apt-get works too.
 
Old 07-12-2006, 09:01 PM   #6
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 272Reputation: 272Reputation: 272
Aptitude has actually become the preferred method for installing things. It's a little bit more robust. I use aptitude for everything and only use apt-get if I have a problem. Every once in a while, one will solve a problem the other one won't...
 
Old 07-13-2006, 06:00 PM   #7
zool2005
LQ Newbie
 
Registered: Apr 2006
Location: France
Distribution: Ubuntu 6.06
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by ctkroeker
Ok, it asked me if I wanted to downgrade, and I said yes and it worked! Thanks!
Weird though that I tried the same tning with apt-get, and no go, but with aptitude it worked. Now apt-get works too.
I had the same problem and downgrading solved it. Thanks for the hint. I'll just have to skip that upgrade until the bug is fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apt-get problem Gormless Linux - Newbie 10 05-14-2008 09:16 AM
[SOLVED] Problem with apt lloydsmart Ubuntu 3 06-02-2006 10:33 PM
problem with apt saipraveen Linux - Newbie 2 08-17-2005 05:33 PM
problem with apt-get mvp Linux - Newbie 12 02-10-2004 03:15 PM
rh9 xd2 apt apt-get problem fix and solution transeunt Red Hat 0 12-16-2003 10:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 01:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration