-   Ubuntu (
-   -   application menu disappeared and the main menu item has no response (

sunnior 10-09-2008 04:39 AM

application menu disappeared and the main menu item has no response
Just now, I was editing my main menu. When I tried to delete an item, the screen paused for two seconds. Then the edit window closed. When I click the applications icon on my panel, all the items have gone!

The main menu editor won't respond to me now. How can I fix this problem?

tommcd 10-18-2008 02:41 AM

If you still need help for this problem, try right clicking on the 'applications' menu and choose 'edit menu'. Then you can just check the items you want. If that doesn't work, then click system > preferences > main menu, and you can add things to your menu that way. If that doesn't work, then try right clicking on the yop panel and choose 'Delete this panel'. Then right click on the bottom panel and choose 'New Panel' and put the new panel at the top of the screen where the old one was. Then right click on the new top panel and select 'Add to Panel'. Then select "Menu Bar" from the list. This will give you a brand new menu bar like the old one. Then just right click on that and edit it to your needs.

sunnior 10-19-2008 04:27 AM

In fact, the problem goes with me all these days, and I need help badly. But the methods you mention above don't work for me.
Neither the 'edit menu' nor the 'system>preferences>main menu' works. They just make no response! And the brand new menu bar has the same problem as the old one. I don't know how it come. Have I deleted some necessary packages?

tommcd 10-20-2008 02:45 AM

Some googleing suggests that resetting your gnome settings might fix your problem. See this:
What I would do is to move those gnome directories in your home directory to a backup instead of deleting them.

cd ~
mv .gnome .gnome.bak
mv .gnome2 .gnome2.bak
mv .gconf .gconf.bak
mv .gconfd .gconfd.bak
mv .metacity .metacity.bak

Then log out of your desktop (ctrl + alt + back-space) and log back in; or just reboot, and see if it fixes things. Those directories you moved to *.bak will be recreated when you log back in.

If that doesn't work, then delete those directories (.gnome, .gnome2, .gconf, .gconfd, .metacity). Then reinstall gnome:

sudo apt-get install --reinstall ubuntu-desktop
If that doesn't fix it I'm out of ideas. Reinstalling the ubuntu desktop should fix it, provided you delete the user settings in the above mentioned directories first.

sunnior 10-22-2008 12:05 AM

I delete the above directories and reboot. Then every thing seems to be reseted to the default: the background, the icon theme, the shortcuts ....except one thing: The items in "applications" menu are still missing!
I won't take any further effort now. I just sit and wait the coming intrepid ibex bring me back to life.

Thank you all the same.

twitch-DR 10-28-2008 02:03 PM

I had the same problem. This worked for me:


mv ~/.config/menus/ ~/.config/menus/

sunnior 10-29-2008 09:37 AM


Originally Posted by twitch-DR (Post 3324217)
I had the same problem. This worked for me:


mv ~/.config/menus/ ~/.config/menus/

It works! amazing! Thank you so much:)

I notice this is your first post. Welcome to linuxquestions!

General Chen 11-01-2008 10:27 AM

Thanks, It's very usable, I meet the same error and solve it as your tips.


Originally Posted by twitch-DR (Post 3324217)
I had the same problem. This worked for me:


mv ~/.config/menus/ ~/.config/menus/

johnsshadow 06-01-2009 05:47 AM


Originally Posted by twitch-DR (Post 3324217)
I had the same problem. This worked for me:


mv ~/.config/menus/ ~/.config/menus/


sersously i thank you from the bottom of my heart

saving this code for later

would anyone like to elaborate one this peice of code

what it actually dose and how it fixed everything (i love reading that stuff)

because now i cant remove things from my panel (but things like this are often solved on reboot)

i cant add them ether

lol solve one problem make least i can axcess my programs now

Ross Anderson 10-21-2009 12:23 PM

How do you guys know this stuff????? I'm persevering with Ubuntu (9:04) and find most things really great BUT when things just disappear without me doing anything - well, I think I did nothing! - I begin to wonder how other people will ever move from MS to a Linux Distro.

Anyway, thanks for your help, even though you didn't know I was in trouble!

ReggiePerrin 10-31-2011 07:39 PM

Perhaps someone here can help… I have deliberately not “upgraded” from 11.04 to 11.10 just so I can keep the Gnome 2 “Ubuntu Classic” desktop which I very much prefer. Sadly, I was trying to alter the Startup Applications to allow Knemo to start on login, when my system froze for some reason, requiring a hard reboot. Upon restart, I find have lost my Applications menu entirely, and the System -> Preferences menu, and the System -> Administrator menu have disappeared too.
I must have tried the various resets that abound on the forums, to no avail.
The last thing I want to have to do is a full reinstall, which would fix it, of course, but it would kill all the customisations which one inevitably makes.

Any ideas on how I can remedy this situation? There must be some default listing that I can reinstall, or go back to. It exists somewhere on the install disk, so it must surely be resetable.

A full-reset switch is certainly something which is missing from the desktop environment, but that is a topic for another discussion.

Anyway, please help!

Thanks in advance

Heco 11-01-2011 10:59 AM

can anybody help me ,this is my problem

i have ubuntu 11.10 and everything was fine before a few hours ,my computer was stop working and i take my batery out and i put in again and turn on computer but i dont have the menu ,no taskbar ,no nothing ,just docky ,
i start terminal from docky type gnome-panel i taskbar appear until i close terminal but that taskbar is not like it was been its something ugly
what i can do to restore my previous dispay ,menu ,taskbar and everything else ????

thx on answers

ReggiePerrin 11-03-2011 05:28 AM

OK... I managed to fix my problem by way of:
"mv ~/.config/menus/ ~/.config/menus/"
"mv ~/.config/menus/ ~/.config/menus/"

Log out, login... all fixed!

I have only to add my top panel customisations again, and things are (hopefully) back to normal.

All times are GMT -5. The time now is 01:50 AM.