-   Ubuntu (
-   -   ACPI error / boot failure / kernel 2.6.15-27-386 (

allohakdan 09-30-2006 10:37 PM

ACPI error / boot failure / kernel 2.6.15-27-386

when i try to turn my Ubuntu computer on i get the following message...

Uncompressing Linux... Ok, booting the kernel.
[17179569.184000] ACPI: Unable to locate RSDP

after having done searches on this, it seems that other people have had the same problem... ive tried all the suggestions so far... but they dont seem to work. So i thought i would give some additional detail about what i was doing when the system stopped working correctly and what i have noticed since... some of this i know is probably not useful but hey... maybe the context is important, i dont know.

I have been running the latest and greatest version with updates of Ubuntu on an old Dell computer with a PentII Processor. It was working slowly, but just fine until yesterday. Origionally I had installed the BreezyBadger version, and then when Dapper came out, i had it upgrade itself to 6.06. The fact that the machine runs kind of slow isnt a huge deal because i am using it mostly as network storage for extra files and lately as a ftp server. Well was... So yesterday, i decided to switch ftp services from plain ftpd to vsftpd because the fact that i had been running ftpd had bothered me since i installed it... i decided to use ubuntus synaptic package manager tool to uninstall ftpd and install vsftpd at the same time. When i went to do this, it also wanted to update some stuff (im not sure what all... but mostly libraries and dependencies i think). That didnt bother me because i alwalys let it update everything. Well, i got some errors while doing this and it told me it was not able to complete the installations. so i did what i alwalys do, try try again... I restarted the synaptic program and attempted to do the same uninstall/install again. so this time in ran and finished successfully. but then when it went to update itself on what i had installed, it informed me that 5 packages were "broken". So i did the filter and fix broken packages and it told me that they were fixed successfully. Everything looked fine.

Then i went to try to use my new ftp service... vsftpd comes preconfigured to allow only anonoymous logins... so i went to edit the .conf file, set it to allow local users to login, and then went back to trying to access the ftp server using the login and password for one of the local users. And i discovered that the settings had not taken effect. This made sense(i guess) because i had never stoped the vsftpd service and restarted it so i thought maybe it loads the conf file when the process starts running but never looks at it again. Well i decided to just restart the whole system. And thats when i first encountered the error message

Uncompressing Linux... Ok, booting the kernel.
[17179569.184000] ACPI: Unable to locate RSDP

Now when i go to grub(v.95), it gives me the following options:
Ubuntu, kernel 2.6.15-27-386
Ubuntu, kernel 2.6.15-27-386 (recovery mode)
Ubuntu, kernel 2.6.10-6-386
Ubuntu, kernel 2.6.10-6-386 (recovery mode)
Ubuntu, kernel memtest86+

As i said earlier, i have tried some of the suggestions from other posts... namely the addition of noacpi acpi=off apm=on and combinations of these. I also tried booting in recovery mode to the kernel version 2.6.15-27-386, and it eventually comes down to the same thing as when i boot to the kernel 2.6.15-27-386... it says

[some stuff really fast that scrolls off the page]
Begin: Waiting for root file system... ...
ALERT! /dev/hda1 does not exist. Dropping to a shell!

BusyBox v1.01 (Debian 1:1.01-4ubuntu3) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty; job control turned off

Now here is the part that no one else has mentioned (or at least that i have seen). If i choose to boot to the older version of the kernel (2.6.10-6-386), it works. Kind of. While the system does boot all the way up to the login screen, allow me to logon, and then procede to load gnome, it does not have all the same look and feel type stuff i had set. the background and window schemes are different. also, when i try to logon to the ftp server from another computer, it returns (In SmartFTP)

[20:11:26] SmartFTP v2.0.997.4
[20:11:26] Resolving host name ""
[20:11:26] Connecting to Port: 21
[20:11:26] Connected to
[20:11:26] 220 Welcome to blah FTP service.
[20:11:26] USER friend
[20:11:26] 331 Please specify the password.
[20:11:26] PASS (hidden)
[20:11:27] 500 OOPS: cap_set_proc
[20:11:27] 230 Login successful.
[20:11:27] 500 OOPS: vsf_sysutil_recv_peek
[20:11:27] Server closed connection
[20:11:27] Cannot login waiting to retry (30s)...

I have a feeling that these are not the only things that are different.

I have also played with the bios some... it has a few basic power managment type options for controlling when the hard disks turn of and when the monitor goes into sleep mode to conserve power. i found it turned off, tried turning it on to different level settings, and found that they didnt seem to have any effect on the boot process).

Does anyone have any ideas for how i can fix this?

allohakdan 09-30-2006 11:10 PM

after looking at the start up dialog when booting to kernel 2.6.10-6-386, i noticed that the same ACPI: Unable to locate RSDP error shows up there as well. only it continues on with an audit(some number) and continues booting... perhaps the problem is not with acpi? any suggestions for how to maybe revert or somehow undo what i have done? im not sure what to do now...

All times are GMT -5. The time now is 09:17 AM.