LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 04-07-2007, 06:30 PM   #16
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15

Quote:
Originally Posted by GrapefruiTgirl
Hi there
The nvidia drivers from nvidia.com do work in ubuntu, and are quite an improvement over the stock ones.
I took this to mean the ones in Ubuntu, maybe I was wrong.

After the reboot, the desktop looked better, but the video is still choppy when I move windows around or scroll down a webpage. I don't think this worked 100% of what I was trying to accomplish.
 
Old 04-07-2007, 06:43 PM   #17
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Well in any event, you did get the driver installed successfully, yes?
Is the display excessively choppy. or just a little bit?
Code:
glxinfo | grep direct
Type that into a console, and see what it returns. It should say Yes, Direct Rendering Enabled.
If it is, perhaps we should look at the xorg.conf file next, and see if there's anything obvious in there misconfigured?.

Last edited by GrapefruiTgirl; 04-07-2007 at 06:44 PM.
 
Old 04-07-2007, 06:47 PM   #18
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
It's pretty darn choppy....not at all like I would expect to see a new GeForce 6100 graphics driver to be.

Results of your command:
Code:
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
 
Old 04-07-2007, 06:49 PM   #19
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Ugx..OK, make sure the Modules Section (of /etc/X11/xorg.conf) looks like this (note the GLX item; v4l is optional, only if you use any Video 4 Linux devices):
Code:
Section "Module"
    Load  "dbe"
    Load  "extmod"
    Load  "type1"
    Load  "freetype"
    Load  "glx"
    Load  "fbdevhw"
    Load  "record"
    Load  "v4l"
#   Load  "vnc"
EndSection

Last edited by GrapefruiTgirl; 04-07-2007 at 06:51 PM.
 
Old 04-07-2007, 06:57 PM   #20
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
GLX is there, but not much else...

Code:
Section "Module"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
 
Old 04-07-2007, 07:03 PM   #21
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
For one, the nvidia drivers do their own DRI, so you shouldn't need DRI in there.
When you edit the file, you should know you must restart X for any changes to take effect, in case you didn't know..
OK, if it is still all choppy and stuff, post the xorg.conf file. Let's have a look. Also, post the output of 'lspci' from a root console.

Last edited by GrapefruiTgirl; 04-07-2007 at 07:04 PM.
 
Old 04-07-2007, 07:14 PM   #22
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
You want the entire xorg.conf file?

Here is lspci:

Code:
00:00.0 RAM memory: nVidia Corporation Unknown device 03ea (rev a1)
00:01.0 ISA bridge: nVidia Corporation Unknown device 03e0 (rev a2)
00:01.1 SMBus: nVidia Corporation Unknown device 03eb (rev a2)
00:01.2 RAM memory: nVidia Corporation Unknown device 03f5 (rev a2)
00:02.0 USB Controller: nVidia Corporation Unknown device 03f1 (rev a2)
00:02.1 USB Controller: nVidia Corporation Unknown device 03f2 (rev a2)
00:04.0 PCI bridge: nVidia Corporation Unknown device 03f3 (rev a1)
00:05.0 Audio device: nVidia Corporation Unknown device 03f0 (rev a2)
00:06.0 IDE interface: nVidia Corporation Unknown device 03ec (rev a2)
00:08.0 IDE interface: nVidia Corporation Unknown device 03f6 (rev a2)
00:09.0 PCI bridge: nVidia Corporation Unknown device 03e8 (rev a2)
00:0b.0 PCI bridge: nVidia Corporation Unknown device 03e9 (rev a2)
00:0c.0 PCI bridge: nVidia Corporation Unknown device 03e9 (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation Unknown device 03d1 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Modem: PCTel Inc HSP MicroModem 56 (rev 02)
01:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. Unknown device 8167 (rev 10)
 
Old 04-07-2007, 07:17 PM   #23
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Well, the whole file shouldn't be humungous, provided it isn't like 90% comments and depending on how it's laid out, it's usually best to see the whole thing.
BTW, when you now do 'glxinfo | grep direct' what does it say?
So yes, post the file in {code} tags.
 
Old 04-07-2007, 08:10 PM   #24
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
GLX didn't change...

Code:
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

xorg file

Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
	FontPath	"/usr/share/fonts/X11/misc"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"ddc"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
	Option		"XkbOptions"	"lv3:ralt_switch"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ExplorerPS/2"
	Option		"ZAxisMapping"		"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"Generic Video Card"
	Driver		"vesa"
	BusID		"PCI:0:13:0"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-80
	VertRefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Generic Video Card"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice     "stylus" "SendCoreEvents"
	InputDevice     "cursor" "SendCoreEvents"
	InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
	Mode	0666
EndSection
 
Old 04-07-2007, 09:27 PM   #25
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Sure a newer driver may well work with an older card but I question if it will make a noticeable difference in performance. The GPU itself and associated hardware determine the performance. What I can say with certainty that the safest most trouble free driver will be provided by the the distribution developers. If you were to review all the Nvidia driver trouble posts you will see that the bulk of these users went to the command line and didn't use the nvidia-glx provided by Ubuntu. There have been issues on occasion when the kernel gets updated but those problems are solved in a day or to. If you roll your own, every kernel upgrade will be a problem and require special handling by the user. I'm certain that all help offered on the forums is well meaning but that hardly means well informed and thought out.
 
Old 04-07-2007, 09:37 PM   #26
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
Well, I have been trying to get this driver installed that I DL'd from Nvidia's site, but I can't figure out how to get our of X to install it.
 
Old 04-07-2007, 10:08 PM   #27
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
To attampt to correct the '...RGB GLX...' error in the above glxinfo output, try the following in the Screen section:
Code:
   Option  "AddARGBGLXVisuals" "True"
Now, your Device section says 'vesa' for a driver. The driver should be "nvidia".
And finally, as Mentioned before, you should not have the DRI section at the bottom. The rest looks well enough to work, even if it may benefit from some fine tuning or other options; these changes should make it work.
And, in case you or anyone is wondering, I have the entire nvidia proprietary drivers tutorial here, which is what I reference when trying to help people with nvidia driver issues. Many people do not seem to have it handy, and it has been invaluable on many occasions. It covers a wide variety of cards and motherboards.
Auto config tools are great, when they work, but in my experience, nvidia's auto-config tool did/does not make my card work, nor many others very well, and ATI's auto-config-tool is much much worse..

EDIT: This post assumes you have at least gotten the driver built and installed..
EDIT2 - this link http://www.linuxquestions.org/questi...d.php?t=299456 indicates that /etc/init.d/gdm stop is how to exit X in Ubuntu. It likely has to be entered as root.

Last edited by GrapefruiTgirl; 04-07-2007 at 10:42 PM.
 
Old 04-08-2007, 02:16 PM   #28
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
Code:
Section "Screen"
	Identifier	"Default Screen"
	Device		"Generic Video Card"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854"
Just add the "Option" line anywhere in here? Incidentally, this monitor is a Dell P1110 21" and when I setup an older box with Ubuntu as a test box, using this same monitor, about a month ago, it recognized it. This new system with the Abit mobo and the GeForece 6100 isn't recognizing it. Shouldn't I change the "Generic Video Card" and the "Generic Montitor" options here as well?

Code:
Section "DRI"
	Mode	0666
Remove this section completely? I missed you saying that before.

And I change the "vesa" part to read "nvidia" now.
 
Old 04-08-2007, 02:46 PM   #29
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Yup, the 'Option' entries, I usually have them right under the 'DefaultDepth' entry.
And yes, the Section "DRI", Mode 0666, and EndSection, are not needed for nvidia.
And yes, the vesa driver will give you no pleasure so it gets changed to 'nvidia'

As for the names of the monitor and device, it isn't too important. Just make sure you type it & spell it exactly the same way, in each reference to it.

Last edited by GrapefruiTgirl; 04-08-2007 at 02:49 PM.
 
Old 04-08-2007, 03:13 PM   #30
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
I changed the "vesa" to "nvidia" and I removed the last section about "DRI" and I placed that Option line where you told me to. I don't know which one hosed it, but now it won't even boot into X. I am typing this post from one of my XP boxes. I tried rebooting and choosing "recovery mode" from the GRUB menu, and still nothing. When it tries to load X, the whole screen goes black and nothing happens.

How can I find and edit the xorg.conf file from a cmd prompt?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GeForce 6100 xorg.conf Composite help please lizard_king825 Linux - Hardware 5 01-25-2007 10:57 AM
How to install nvidia drivers Geforce 6100 netscaper Linux - Hardware 4 07-24-2006 04:47 AM
geforce 6100 ololad8 Linux - Hardware 1 07-14-2006 06:10 PM
No Picture, onboard video and geforce fx 5500 vid card on system, using geforce?? dragoncorp.org Linux - Newbie 1 04-17-2006 01:56 PM
Mainboard on GeForce 6100 with 3D acceleration webdevel Linux - Hardware 3 12-21-2005 06:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 11:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration