LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 04-05-2007, 06:48 PM   #1
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Rep: Reputation: 15
Abit NF-M2S with Onboard GeForce 6100


I just got this new mobo/cpu combo and install Ubuntu 6.10 on it. The video is very choppy and the sound doesn't work. I searched in this forum for this and found this link for the display driver:
http://www.nvidia.com/object/linux_d..._1.0-8174.html

Will this work for Ubuntu also? Sorry, I am kinda new to Linux.

Also, I read in another thread that the correct audio driver for this board was found at this link:
http://www.realtek.com.tw/downloads/...etDown=false#2

I downloaded this file but don't know the SUDO command to install it. I think I should put it in the /sys/devices folder? But thru X I don't have root permissions.

Any help is appreciated.
 
Old 04-05-2007, 07:06 PM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Hi there
The nvidia drivers from nvidia.com do work in ubuntu, and are quite an improvement over the stock ones. If the 8174 is the one which matches your video device, then it should work just fine..
They usually must be installed in runlevel 3 (to get there, either login to the terminal as root and type 'telinit 3' OR open a console window, get root priveleges, and type 'telinit 3')

I am not sure about your audio drivers. What device is it? Is it an AC97 ? If so, support should be inside the kernel already. Please give some more info on your audio device. I could certainly be wrong, but i wouldn't think you normally should have to download something to get a realtek audio-chipset to work.
You *may* however have to use the ALSA-Mixer tool, or ALSA-conf tool, to un-mute the volume on your system. This is the case with some systems using ALSA.

Hope this helps you; if you need further info, just ask!
 
Old 04-05-2007, 07:31 PM   #3
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
All my mobo book says is "Realtek HD 7.1 Audio Codec" I guess I could go into the BIOS and look for a model, but I would have to reboot and can't right now. Is there a cmd in Linux that will tell me what is installed?
 
Old 04-07-2007, 12:16 PM   #4
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
So to install this NVIDIA driver, from a Terminal window, it tells me I can't do it while X is running. Can I use CTRL-ALT-F1? Or if not, how I do exit X to a cmd line without shutting down?
 
Old 04-07-2007, 12:27 PM   #5
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
enter a console window, su to root, and type 'telinit 3'
 
Old 04-07-2007, 04:15 PM   #6
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
I assume by "Konsole" you mean "Terminal" because I am not running KDE.

I typed 'Telinit 3' from a Terminal window, nothing happened.
 
Old 04-07-2007, 04:33 PM   #7
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
By "console" yes, I mean a console, terminal, or shell window. The desktop manager doesn't matter.
OK, most systems with X displays run in INIT level 4 or 5, when running the X environment. The command 'telinit 3' when entered into a root-permissions "console" window, tells INIT to quit X and quit init-level 4 or 5, and to switch to level 3. The intention here is to get to a multi-user run level without X running. Init 1 will not work, it is single-user mode.
Ultimately ANY multi-user run-level will probably work, just not the run-level where you use X. Try 'telinit 2' or 'telinit 4', and see what happens. It won't hurt anything.
 
Old 04-07-2007, 04:44 PM   #8
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
All 3 of those seem to be 'accepted' commands, in the fact that they come back to a cmd prompt without any errors, but don't show to be doing anything. I understand (kinda) what you are saying about the levels though

I tried all 3 of them (telinit 2,3,4) and afterwards typed
Code:
sh NVIDIA-Linux-x86-1.0-8174-pkg1.run
according to these instructions:
http://www.nvidia.com/object/linux_d..._1.0-8174.html

Each time I try this, it starts to run, brings up another window, and tells me that I am "running X and must exit in order to run this command.

I also tried doing it from CTRL-ALT-F1 and it still told me that X was running.
 
Old 04-07-2007, 05:02 PM   #9
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Hmm.. OK, use CTRL ALT F1, and login as root (if it is not logged in) and type:
'telinit 1'
That's gotta do something. If it doesn't, try 'init 1' or 'init 3'
If telinit 1 works, THEN login and type telinit 3.
When Going to init 1, the machine will basically reset, and land at single user mode, at the login prompt.
If none of this works, then you could use the Boot: prompt, assuming you have access to one when you start your machine, and at the boot prompt, enter your kernel name to boot, followed by 'init 3'. Then it will boot up and NOT start X.
If this can't be done, then edit the file /etc/inittab and do the following to it:

id:4:initdefault:
Change the above line to read:
id:3:initdefault:
save the file and reboot.

Last edited by GrapefruiTgirl; 04-07-2007 at 05:03 PM.
 
Old 04-07-2007, 05:07 PM   #10
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
How do I get back to X after doing CTRL-ALT-F1? I have tried several commands, but always end up rebooting, because I can't seem to get X to come back up from that page.

When I reboot, it starts X automatically, I never get to a prompt...not sure if the option ever comes up, it boots REALLY fast, so if it does, I don't see it.
 
Old 04-07-2007, 05:14 PM   #11
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
After CTRL-ALT-Fx , assuming you haven't killed X or changed the runlevel, you can just hit CTRL-ALT-F7 to get back to the desktop where X is.
(NOTE: I don't know of a system that uses a key other than F7 for X, but it probably exists. if CTRL-ALT-F7 does not do it, try the other function keys.)

NOTE - The above instructions for editing /etc/inittab, should make X not start after reboot.

Last edited by GrapefruiTgirl; 04-07-2007 at 05:17 PM.
 
Old 04-07-2007, 05:54 PM   #12
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Or you can just use System-> Administration-> Synaptic Package Manager. Once running, use search to find nvidia-glx and apply/install. No muss, no fuss, no CLI.
 
Old 04-07-2007, 06:00 PM   #13
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by fragos
Or you can just use System-> Administration-> Synaptic Package Manager. Once running, use search to find nvidia-glx and apply/install. No muss, no fuss, no CLI.
But someone told me earlier in this thread that the drives on nvidia's website were more up-to-date and better than the one that's in Synaptic.
 
Old 04-07-2007, 06:13 PM   #14
kc5hwb
Member
 
Registered: Jun 2001
Location: Grapevine, Texas
Distribution: Ubuntu 14.04, CentOS 7
Posts: 102

Original Poster
Rep: Reputation: 15
I installed the nvidia-glx pkg from Synaptic. I am about to reboot to see how it worked.

CTRL-ALT-F1 Results:
telinit 1 did put the machine into level 1 mode and when I tried to run the "sh" command listed above, it told me that running this cmd in level 1 was not advisable and it wanted me to stop the installation, which I did.

CTRL-ALT-F7 DID bring me back to the X view, so I typed CTRL-ALT-F1 again and got back to the root prompt. When I type telinit 1, then telinit 3, it takes me back to the X login screen.
 
Old 04-07-2007, 06:17 PM   #15
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Quote:
Originally Posted by kc5hwb
But someone told me earlier in this thread that the drives on nvidia's website were more up-to-date and better than the one that's in Synaptic.
Hmmm.. In this thread? Where did someone say that? I remember you asking "..will this particular driver work..." to which I replied that it would. And yes, it IS better than the opensource 'nv' driver included with most distributions. If nvidia makes available the exact same driver that Synaptic can get you, then it makes no difference in functionality; merely where you get it.
I apologize for any confusion I may have caused you.

Last edited by GrapefruiTgirl; 04-07-2007 at 06:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GeForce 6100 xorg.conf Composite help please lizard_king825 Linux - Hardware 5 01-25-2007 10:57 AM
How to install nvidia drivers Geforce 6100 netscaper Linux - Hardware 4 07-24-2006 04:47 AM
geforce 6100 ololad8 Linux - Hardware 1 07-14-2006 06:10 PM
No Picture, onboard video and geforce fx 5500 vid card on system, using geforce?? dragoncorp.org Linux - Newbie 1 04-17-2006 01:56 PM
Mainboard on GeForce 6100 with 3D acceleration webdevel Linux - Hardware 3 12-21-2005 06:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 11:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration