-   Ubuntu (
-   -   12.04 USB printer suddenly stalls "Rendering completed" (

qianian 06-12-2012 11:49 PM

12.04 USB printer suddenly stalls "Rendering completed"
After upgrading to 12.04, I printed several jobs no problem. Then I unplugged and reconnected the power supply to the printer, to find that it stopped hearing commands from my laptop. CUPS and the printer daemon indicate "Rendering completed" but there's no further progress. I've tried printing test pages from both CUPS and the daemon. Same message stalls for up to 40 mins (then I cancel it) while the printer goes to sleep.

CUPS and the daemon see when I unplug or turn off the printer, indicating "Paused" instead of "Idle" and the "Rendering completed" line disappears.

I followed instructions here to update CUPS but no change. I've restarted and replugged everything.

It's an HP Deskjet 1050 All-In-One connected to Lenovo Thinkpad R61i.

qianian 06-13-2012 12:36 AM

I deleted and re-installed the printer and it works now.

qianian 06-13-2012 12:51 AM

I take that back, the problem repeats when I print from gimp or Shotwell.

qianian 06-13-2012 02:00 PM

I'm currently working around this by un-Enable-ing the printer and grabbing the PDF from /var/spool/cups. It prints from Evince okay.

All times are GMT -5. The time now is 06:45 PM.