-   SUSE / openSUSE (
-   -   yast error (

drsethi 12-27-2006 04:19 PM

yast error
When I want to start yast it says password is wrong but by console I can start it with same password. Also I can log as root with same password. what is this problem?Messages are as follows on 1st and 2nd try
Incorrect password; please try again.
Conversation with su failed.

crazibri 01-04-2007 08:08 PM

I've got the same error.

It has to do with the new Sudoers module in Yast2.
I played around in there and now it doesnt accept the root password from KDE, but I can still get in to "su" via the shell.

Can someone post their /etc/sudoers file from a Suse 10.2 default installation?
Thanks! :D

drsethi 01-05-2007 11:08 AM

I logged as root and then started yast then changed root's password and it removed my problem.:)
By the way after some time my system crashed and became read only.:confused: It could not be repaired so I reinstalled Suse Linux.
Now working fine.

crazibri 01-06-2007 12:36 AM

Dont use Sudoers in Yast

I reinstalled Suse 10.2 to see the original suoders file in etc.


# sudoers file.
# This file MUST be edited with the 'visudo' command as root.
# See the sudoers man page for the details on how to write a sudoers file.

# Host alias specification

# User alias specification

# Cmnd alias specification

# Defaults specification

# prevent environment variables from influencing programs in an
# unexpected or harmful way (CVE-2005-2959, CVE-2005-4158,
# CVE-2006-0151)
Defaults always_set_home
Defaults env_reset

# In the default (unconfigured) configuration, sudo asks for the root password.
# This allows use of an ordinary user account for administration of a freshly
# installed system. When configuring sudo, delete the two
# following lines:
Defaults targetpw    # ask for the password of the target user i.e. root
ALL ALL=(ALL) ALL # WARNING! Only use this together with 'Defaults targetpw'!

# Runas alias specification

# User privilege specification
root    ALL=(ALL) ALL

# Uncomment to allow people in group wheel to run all commands
# %wheel        ALL=(ALL)      ALL

# Same thing without a password
# %wheel        ALL=(ALL)      NOPASSWD: ALL

# Samples
# %users  ALL=/sbin/mount /cdrom,/sbin/umount /cdrom
# %users  localhost=/sbin/shutdown -h now

All times are GMT -5. The time now is 11:12 PM.