LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   XP-VISTA-Suse 10.3 multi-boot (https://www.linuxquestions.org/questions/suse-opensuse-60/xp-vista-suse-10-3-multi-boot-599056/)

joint 11-12-2007 10:09 AM

XP-VISTA-Suse 10.3 multi-boot
 
Hi,
I got XP and Vista dual boot, and I'm willing to add Suse 10.3 to the set. Did any one of you tried this, will I have boot problems?
I read that Vista used to have this kind of issues on booting other OS's.

Micro420 11-12-2007 11:29 AM

Should be no problem as long as you install SuSE 10.3 last. Then, just edit GRUB. SuSE should be able to automatically set it up for you, but if it doesn't work, then we can help you.

joint 11-12-2007 11:50 AM

Ya thanks, I'll try that!

koen plessers 11-12-2007 12:51 PM

Hello

In case it doesn't work, try EasyBCD to configure Vista's bootloader.

Bye

Koen Plessers

joint 11-12-2007 03:40 PM

No, none of windows loading.
Got on menu:
Suse 10.3
suse failsafe blah blah..
windows Vista
windows XP

Errors:
rootnoverify (sda1,1)
Error 23: Error while parsing number
Press any key to continue...

rootnoverify (hd1,1)
chainloader (hd0,0)+1

Micro420 11-12-2007 04:20 PM

No problem. What's your physical layout? 2 hard drives? 3 hard drives? Which partitions have XP and Vista? Play around with GRUB. :

Code:

Rootnoverify (sda1,1)
Error 23: Error while parsing number
Press any key to continue...

Do you have a 2nd hard drive? Normally you don't see the (sda) in a GRUB file. GRUB uses the (hdx,x) format. Try changing this (I bolded the change)
Code:


rootnoverify (hd0,0)
chainloader (hd0,0)+1

The above is saying to use Windows bootloader on the 1st hard drive on the 1st partition

Can you post your /etc/grub/menu.lst file?

joint 11-13-2007 08:48 AM

So, I am going to make a second fresh install, cause I messed up nVIDIA driver install, fixed MBR and BOOT on Vista, and now I can do it all over again.
Is there a "must do" on install to sort all OS's booting?
(I used to setup dual-boot XP - Suse10.2 pretty well on boot settings during suse install.)
I got a Sata 160Gb (Vista), 80Gb IDE1 master (XP), 80Gb IDE1 slave (Suse) and 80GB IDE2 master (data and stuff).

joint 11-13-2007 02:32 PM

It happened again! :)
here we go:
Code:

Vista:
rootnoverify (hd1,1)
chainloader (hd3,0)+1

Code:

Win XP:
rootnoverify (hd1,1)
chainloader (hd0,0)+1

menu.lst:
Code:

# Modified by YaST2. Last modification on Tue Nov 13 20:14:27 WET 2007
default 2
timeout 8
gfxmenu (hd1,1)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3 - 2.6.22.12-0.1
    root (hd1,1)
    kernel /boot/vmlinuz-2.6.22.12-0.1-default root=/dev/disk/by-id/scsi-SATA_WDC_WD800BB-00JWD-WCAM91774813-part2 vga=0x31a resume=/dev/sdc1 splash=silent showopts
    initrd /boot/initrd-2.6.22.12-0.1-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3 - 2.6.22.12-0.1
    root (hd1,1)
    kernel /boot/vmlinuz-2.6.22.12-0.1-default root=/dev/disk/by-id/scsi-SATA_WDC_WD800BB-00JWD-WCAM91774813-part2 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.12-0.1-default

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title Windows Vista
    rootnoverify (hd1,1)
    chainloader (hd3,0)+1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title Windows XP
    rootnoverify (hd1,1)
    chainloader (hd0,0)+1


flaferriere 12-13-2007 04:24 AM

problem dual boot SuSE 10.3 XP
 
hello,

I have EXACTLY the same problem here. I am a seasoned Debian user but I am new to SuSE. A few days ago, I installed the 10.1 (for some compatibility reason). Everything goes seamlessly (much easier than Debian in my experience), windows partition was pushed aside, dual boot was working perfectly well.

I decided to upgrade to 10.3. My error message are much the same
rootnoverify (hd1,1)
chainloader (/dev/sdb1,0)+1
Error 23: Error while parsing number
Press any key to continue...

my menu.lst contains

#
#YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3 - 2.6.22.5-31
root (/dev/sdb3)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/sdb3 splash=silent showopts
initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3 - 2.6.22.5-31
root (/dev/sdb3)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/sdb3 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: linux-2.6.22.5-31-default###
title openSUSE 10.3
root (hd0,2)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_ST320410A_5FG54DDB-part3 splash=silent showopts
initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,2)
chainloader (/dev/sdb1,0)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Disquette
rootnoverify (hd0,2)
chainloader (fd0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe-2.6.22.5-31-default###
title Failsafe -- openSUSE 10.3
root (hd0,2)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_ST320410A_5FG54DDB-part3 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: xen###
title XEN
root (hd0,2)
kernel /boot/xen.gz
module /boot/vmlinuz-xen root=/dev/disk/by-id/scsi-SATA_ST320410A_5FG54DDB-part3 splash=silent showopts
module /boot/initrd-xen
If I can be of any help

flaferriere 12-13-2007 04:47 AM

by the way, the windows partition does not mount when running SuSE. When I try to do so, I get

mount: wrong fs type, bad option, bad superblock on /dev/sdb1,

missing codepage or helper program, or other error

in some cases useful info is found in syslog - try

dmesg | tail or so


fstab entry is

/dev/sdb1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0

when typing dmesg | tail I get

NTFS-fs warning (device sdb1): is_boot_sector_ntfs(): Invalid boot sector checksum.
NTFS-fs error (device sdb1): read_ntfs_boot_sector(): Primary boot sector is invalid.
NTFS-fs error (device sdb1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
NTFS-fs error (device sdb1): ntfs_fill_super(): Not an NTFS volume.
NTFS-fs warning (device sdb1): is_boot_sector_ntfs(): Invalid boot sector checksum.
NTFS-fs error (device sdb1): read_ntfs_boot_sector(): Primary boot sector is invalid.
NTFS-fs error (device sdb1): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
NTFS-fs error (device sdb1): ntfs_fill_super(): Not an NTFS volume.

seems that boot sector has been corrupted somehow. What can be tried to fix this?

yours truly

François Laferrière

gonzas144 01-21-2008 12:54 PM

Same
 
Hi

I have the same problem.
I have 2 Hard drives .
Number 0: RAID Disc. 500GB (With Linux SuSe 10.3)
Number 1: SATA2 250GB (With Windows Vista X64 Ultimate, working OK)

When I tried to boot Windows Vista the boot system gives me this error.

Error 23: Error while parsing number
Press any key to continue...

My boot config is this:

root (hd0,0)
savedefault
makeactive
chainloader (/dev/sda1,0)+1

I hate Windows it makes all more difficult...

Thank's


All times are GMT -5. The time now is 04:57 AM.