LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 09-02-2005, 09:43 PM   #1
Gweedo
LQ Newbie
 
Registered: Nov 2004
Posts: 6

Rep: Reputation: 0
XP bootloader issues with grub


Well. I just switched over to using Suse 9.3 Pro for my linux OS, but I'm now having problems getting into Win XP

Computer setup:
1) I installed XP onto it's own hard drive with an NTFS format
2) I installed Suse 9.3 onto another (master) hard drive
3) Grub bootloader installed by default and automatically put Windows as one of the three options to boot with... I changed nothing during the install process with the exception of some of the install pacages

Problem:
When I select XP with Grub I get an error message saying that the mount point can't be set or something like that. I know that Grub is setup on the hard drive with linux because I can physically unplug the drive and get into Windows without any boot errors. I guess this means I just need to somehow get Grub's settings changed to recognize XP

Current Settings:
If I go into the edit part of Grub for the XP options, it reads:

root (1,0)
kernel /vmlinuz root=/dev/hdb1
 
Old 09-02-2005, 10:15 PM   #2
juvestar15
Member
 
Registered: Aug 2005
Location: Australia
Distribution: Debian Sid
Posts: 60

Rep: Reputation: 15
Open up your /boot/grub/menu.lst

Under the windows part use this

title Windows XP
map (hd0,0) (hd0,1)
map (hd0,1) (hd0,1)
rootnoverify (hd1,0)
makeactive
chainloader +1
savedefault


First up, the hd0 and hd1 refer to the hard drive. in GRUB hd0 = hda, hd1 = hdb. My setup is similar, I have a 20GB IDE with linus as my master and a 200GB SATA as my Windows. Windows doesn't like being second to you need to map the hard drive to make it think it's first. The two map lines should do the trick.

Last edited by juvestar15; 09-02-2005 at 10:37 PM.
 
Old 09-02-2005, 10:32 PM   #3
Gweedo
LQ Newbie
 
Registered: Nov 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Awesome... I actually found the same commands just after starting this thread, and completely understand. One of those "if you just stop looking for it" sort of things. Now, I tried this out by editing things with the option when actually booting, and things worked great. However, I don't know how to perminately set these command lines. I tried using the yast bootloader options, and it saves everything, but only allows me to setup one map command line. How do I just simply get to and edit the file to add that last line?
 
Old 09-02-2005, 10:36 PM   #4
juvestar15
Member
 
Registered: Aug 2005
Location: Australia
Distribution: Debian Sid
Posts: 60

Rep: Reputation: 15
Ye Yast is a pain, it only let me add one line also.

Goto your terminal "sudo pico /boot/grub/menu.lst"
If sudo doesn't work, type "su" then just "pico /boot/grub/menu.lst"
That'll open up the file, just page down to the section you want and add the line.

Sorry hehe I've been giving you the wrong path. It's /boot/grub/menu.lst

Last edited by juvestar15; 09-02-2005 at 10:39 PM.
 
Old 09-02-2005, 10:40 PM   #5
Gweedo
LQ Newbie
 
Registered: Nov 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks... worked like a charm

Also, I finally noticed there was an option to edit the config files from within the yast options I was under. That looked to work about the same too, but I had already used your option, so I wasn't going to mess with it anymore

Thanks again
 
Old 09-02-2005, 10:45 PM   #6
juvestar15
Member
 
Registered: Aug 2005
Location: Australia
Distribution: Debian Sid
Posts: 60

Rep: Reputation: 15
Glad I could help. I'll check out the Yast editing also.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I disable the grub bootloader and enable the lilo bootloader? abefroman Linux - General 1 08-06-2005 09:53 AM
FC3 Bootloader issues wreckingcru Linux - Newbie 6 04-25-2005 06:18 PM
GRUB bootloader spits out "GRUB hard disk error" Crampedson Linux - Software 2 01-26-2005 07:34 PM
Mandrake 9.2 Bootloader Issues dwessell Mandriva 1 05-08-2004 09:51 AM
GRUB bootloader dbaker Linux - Software 1 06-11-2003 06:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration