LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 06-01-2005, 03:36 PM   #1
jimbrook
Member
 
Registered: Apr 2005
Posts: 39

Rep: Reputation: 15
Wireless Configuration Files; ralink rt2500


I am trying to run the Raylink rt2500 wireless driver under SuSE 9.2. I have ended up with two configuration files and modifications to the SuSE "wireless" file. Can someone help me out by looking at my configurations and parts of my log on?

As I understand from the documentation, I should be calling the ifcfg_ra0 file. However, I
believe the ifcfg-wlan-ra0 file is being created by the YaST configuration tool available through SuSE. See also the
calls by "wireless tools" that seem to indicate I am seeing the wireless router.

file:/etc/sysconfig/network/ifcfg-ra0
BOOTPROTO=dhcp
MTU='
REMOTE_IPADDR='
STARTMODE=auto
USERCONTROL=no
WIRELESS_MODE=managed
WIRELESS_AP=00:0f:669:3F:F5
WIRELESS_ESSID=Brook
WIRELESS_CHANNEL=6
WIRELESS_POWER=no
WIRELESS_KEY='

file:/etc/sysconfig/network/ifcfg-wlan-ra0
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
WIRELESS_AP=''
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL='6'
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='Brook'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='no'
WIRELESS_WPA_PSK=''
_nm_name='static-0'

This is the wireless configuration available through YaST, the configuration tool in SuSE

file:/etc/sysconfig/network/wireless
## Path: Hardware/Wireless
## Description:
## Type: yesno
## Default: ""
## ServiceRestart: network
# If you have a wireless NIC and want to set some special wireless parameters
# then you can do that here in this file globally for all cards you have. But
# you can write each of these variables to the interface specific ifcfg-* files
# to handle things per card.
# The WIRELESS_* variable names match the option names of iwconfig. Have a look
# at 'man iwconfig' for details. Except WIRELESS_NICK the variables do nothing
# if empty.
#
# This variables decides if the special handling for wireless HW is used. If you
# have only one network interface card and it is wireless you can set it here to
# 'yes'. But it is much better, if you use that variable in the interface
# configuration files 'ifcfg-*', which overrides the general settings made here.
WIRELESS=""

## Type: string
## Default: ""
# Set the operating mode of the device, which depends on the network
# topology. The mode can be Ad-hoc (network composed of only one cell and
# without Access Point), Managed (network composed of many cells, with
# roaming or with an Access Point), Mas
# master or act as an Access Point), Repeater (the node forward packets on the
# air), Secondary (the node act as a backup master/repeater) or Auto
WIRELESS_MODE=""

## Type: string
## Default: ""
# Set the ESSID (or Network Name - in some products it may also called Domain
# ID). The ESSID is used to identify cells which are part of the same virtual
# network.
WIRELESS_ESSID="Brook"

## Type: string
## Default: ""
# Set the nickname, or the station name. Most 802.11 products do define it,
# but this is not used as far as the protocols (MAC, IP, TCP) are concerned
# and completely accessory as far as configuration goes. If this variable is
# empty we use the hostname
WIRELESS_NICK="linux"

## Type: string
## Default: ""
# Set the Network ID (in some products it is also called Domain ID). As all
# adjacent wireless net
# to differenciate them (create logical colocated networks) and identify
# nodes belonguing to the same cell.
WIRELESS_NWID=""

## Type: string
## Default: ""
# Set the operating frequency or channel in the device. Value below
# 1000 are the channel number, value over this is the frequency in Hz. You
# must append the suffix k, M or G to the value (for exam
# 2.46 GHz frequency), or add enough '0'.
WIRELESS_FREQ=""

## Type: string
## Default: ""
# Channels are usually numbered starting at 1, and you may use iwpriv(8) to
# get the total number of channels and list the available frequencies.
# Depending on regulations, some frequencies/channels may not be available.
WIRELESS_CHANNEL="6"

## Type: string
## Default: ""
# Set the sensitivity threshold. This is the lowest signal level for which we
# attempt a packet recep
# is used to avoid receiving background noise
WIRELESS_SENS=""

## Type: string
## Default: ""
# For cards supporting multiple bit rates, set the bit-rate in b/s. The
# bit-rate is the speed at which bits are transmitted over the medium, the
# user speed of the link is lower due to medium sharing and overhead.
WIRELESS_RATE=""

## Type: string
## Default: ""
# Used to manipulate encryption or scrambling keys and encryption mode. To
# set the current encryption key, just enter the key in hex digits as
# XXXX-XXXX-XXXX-XXXX or XXXXXXXX. You can also enter the key as an ASCII
# string by using the s: prefix. 'off' disables encryption. Additionally you
# may add 'open' or 'restricted' after the key, open set the system in open
# mode (accept non-encrypted packets) and restricted discard non-encrypted
# packets.
# Examples: "0123-4567-89"
# "sassword"
# "sassword open"
# "off" (Don't do that! No! No! No!)
WIRELESS_KEY=""

## Type: string
## Default: ""
# RTS/CTS adds a handshake before each packet trans
# that the channel is clear. This adds overhead, but increase performance
# in case of hidden nodes or large number of active nodes.
WIRELESS_RTS=""

## Type: string
## Default: ""
# Fragmentation allow to split a IP packet in a burst of smaller fragments
# transmitted on the medium. In most cases this adds overhead, but in very
# noisy environment this reduce the error penalty.
WIRELESS_FRAG=""

## Type: string
## Default: ""
# If you need other options for iwconfig, then write the complete option string
# as you would append it to iwconfig but without the interface name to the
# variables below. For multiple options you may (but need not) add linebreaks in
# the string.
WIRELESS_IWCONFIG_OPTIONS=""

## Type: string
## Default: ""
# If you need to set options for iwspy, then write the complete option string as
# you would append it to iwspy but without the interface name to the variables
# below. For multiple options you may (but need not) add linebreaks in the
# string.
WIRELESS_IWSPY_OPTIONS=""

## Type: string
## Default: ""
# If you need to set options for iwpriv then write the complete option string as
# you would append it to iwpriv but without the interface name to the variables
# below. For multiple options you may (but need not) add linebreaks in the
# string.
WIRELESS_IWPRIV_OPTIONS=""

Here is the result of calling on the Wireless tools.

linux:/home/jimbrook # iwlist ra0 scan
ra0 Failed to read scan data : Resource temporarily unavailable

linux:/home/jimbrook # iwlist ra0 scan
ra0 Scan completed :
Cell 01 - Address: 00:0F:669:3F:F5
Mode:Managed
ESSID:""
Encryption keyff
Channel:6
Quality:0/100 Signal level:-209 dBm Noise level:-256 dBm

linux:/home/jimbrook # iwconfig
lo no wireless extensions.

ra0 RT2500 Wireless ESSID:"Brook" Nickname:"linux"
Mode:Managed Frequency=2.437 GHz Bit Rate=11 Mb/s
RTS thrff Fragment thrff
Encryption keyff
Link Quality:40 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions

linux:/home/jimbrook # ifconfig
eth0 Link encap:Ethernet HWaddr 00:12:17:4F:A5:08
inet6 addr: fe80::212:17ff:fe4f:a508/64 Scope:Link
UP BROADCAST NOTRAILERS MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:18 dropped:0 overruns:0 carrier:36
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:177 Base address:0xd000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:88 errors:0 dropped:0 overruns:0 frame:0
TX packets:88 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5768 (5.6 Kb) TX bytes:5768 (5.6 Kb)

ra0 Link encap:Ethernet HWaddr 00:12:17:98:BE:92
inet6 addr: fe80::212:17ff:fe98:be92/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1023 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:40920 (39.9 Kb)
Interrupt:169 Base address:0x4000
_________________________________

Excerpts from my "Boot Log" at startup

coldplug scanning input: **done
scanning pci: *********.WWdone
scanning usb: done
hwup: Loading module 'ra0' for device '0'
done
__________________________

Starting Firewall Initialization (phase 1 of 3) done
<notice>exit status of (random isdn SuSEfirewall2_init) is (0 0 0)
<notice>start services (network)
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8
done eth0 device: Linksys NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
eth0 configuration: eth-id-00:12:17:4f:a5:08
eth0 (DHCP) . . . . . no IP address yet... backgrounding.
waiting
<notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
<notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
Waiting for mandatory devices: eth-id-00:12:17:4f:a5:08 wlan-ra0
7 <notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
<notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
6 <notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
<notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
5 <notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
<notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
3 <notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
<notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
2 <notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
<notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
1 <notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
<notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710

eth0 interface could not be set up
failed ra0 interface could not be set up
failed ra0 device: RaLink Ralink RT2500 802.11 Cardbus Reference Card (rev 01)
ra0 configuration: wlan-ra0
ra0 warning: using NO encryption
<notice>checkproc: /sbin/dhcpcd 3716<notice>checkproc: /sbin/dhcpcd 3710
ra0 (DHCP) . . . . . no IP address yet... backgrounding.
waiting
Setting up service network . . . . . . . . . . . . . . . .failed
<notice>exit status of (network) is (7)
<notice>start services (syslog)
Starting syslog services<notice>startproc: execve (/sbin/syslogd) [ /sbin/syslogd -a /var/lib/ntp/dev/log ], [ CONSOLE=/dev/console TERM=linux SHELL=/bin/sh INIT_VERSION=sysvinit-2.85 REDIRECT=/dev/tty1 COLUMNS=158 PATH=/usr/local/sbin:/sbin:/bin:/usr/sbin:/usr/bin vga=0x31a RUNLEVEL=5 PWD=/ SPLASHCFG=/etc/bootsplash/themes/SuSE/config/bootsplash-1280x1024.cfg PREVLEVEL=N LINES=57 HOME=/ SHLVL=2 splash=silent SPLASH=yes _=/sbin/startproc DAEMON=/sbin/syslogd ]
<notice>startproc: execve (/sbin/klogd) [ /sbin/klogd -c 1 -2 -x ], [ CONSOLE=/dev/console TERM=linux SHELL=/bin/sh INIT_VERSION=sysvinit-2.85 REDIRECT=/dev/tty1 COLUMNS=158 PATH=/usr/local/sbin:/sbin:/bin:/usr/sbin:/usr/bin vga=0x31a RUNLEVEL=5 PWD=/ SPLASHCFG=/etc/bootsplash/themes/SuSE/config/bootsplash-1280x1024.cfg PREVLEVEL=N LINES=57 HOME=/ SHLVL=2 splash=silent SPLASH=yes _=/sbin/startproc DAEMON=/sbin/klogd ]
done
<notice>exit status of (syslog) is (0)
<notice>start services (SuSEfirewall2_setup)
Starting Firewall Initialization (phase 2 of 3) SuSEfirewall2: Warning: no interface active
WARNING: Error inserting ipfwadm (/lib/modules/2.6.8-24-smp/kernel/net/ipv4/netfilter/ipfwadm.ko): Device or resource busy
SuSEfirewall2: Firewall rules successfully set from /etc/sysconfig/SuSEfirewall2
done
<notice>exit status of (SuSEfirewall2_setup) is (0)
 
Old 06-02-2005, 01:36 PM   #2
rarsa
Member
 
Registered: Nov 2004
Location: Canada
Distribution: Puppy Linux/ Mint
Posts: 211

Rep: Reputation: 31
My recommendation with that chipset:

Use Ndiswrapper or install the drivers from serialmonkey. I don't know what drivers come with SuSE, but I am certain that the drivers provided by the chipset vendor don't work at all.

I have had exactly that same problem (or the same symptoms) with the rt2500 drivers. After configuring everything, I can't aquire an address from the DHCP server and it won't recognize a Manual IP.

I am using ndiswrapper in many different distributions without a problem. I have not tried the drivers from serial monkey.

I suggest you read the review of this chip set here

The nice thing about ndiswrapper is that you don't need those lenghty and cryptic configuration files.

Last edited by rarsa; 06-02-2005 at 01:40 PM.
 
Old 06-03-2005, 10:43 AM   #3
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Do NOT screw around with ndis wrappers for this card. Go to http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page ... get their drivers and follow their installation instructions carefully. When you get to the point where they want you to use the 'iw...' commands, do this first:

depmod -a
modprobe rt2500
ifconfig ra0 up

Then carry on.

This is not a difficult driver to get working and it is a great chipset.
 
Old 06-03-2005, 10:56 AM   #4
jimbrook
Member
 
Registered: Apr 2005
Posts: 39

Original Poster
Rep: Reputation: 15
Rickh -

Thanks. I've loaded the drivers from serialmonkey (in fact a couple of times). I get to the point where my wireless NIC card sees the network but will not connect.

Being an absolute "newbie" what does depmod -a; modprobe rt2500 do?

Also, the "iw" configuration tools -- can they be written into a script to use at boot?
 
Old 06-03-2005, 12:14 PM   #5
rarsa
Member
 
Registered: Nov 2004
Location: Canada
Distribution: Puppy Linux/ Mint
Posts: 211

Rep: Reputation: 31
That's exactly the same thing that happens to me in many different distributions with the rt2500 drivers.

That's why I'm using ndiswrapper.

Have you tried entering the commands manually to see if it works?

In a console do the following:
Code:
/sbin/iwconfig ra0 mode Managed      #or whatever mode your network uses
/sbin/iwconfig ra0 key restricted FE1664AA78  # replace the key with the actuall key for your network if there is any.
/sbin/iwconfig ra0 essid mynetwork    #replace 'mynetwork' with your network essid
/sbin/ifconfig ra0 up
/sbin/dhclient ra0                               #gets the IP address
/sbin/ifconfig ra0                                #check if the IP was acquired.
If you 'control' the network (e.g. is your home network)
Try disabling WEP/WAP and set it to broadcast the essid.
Configure your card without security
If it connects, it means that you are not entering the correct essid or key and you have somewhere to look at.

After you confirmed that it connects without security, turn security on and check what parameters you are entering incorrectly.

If this does not work, not even without security, I would recommend using ndiswrapper.

I don't understand rickh's strong recommendation to avoid using them (Actually said in very strong language)

ndiswrapper has worked for me each and every time in every distribution I've tried (about 10).

Maybe rickh know something I don't know.

Remember: The definition of insanity was to keep doing the same thing and expect different results.

If those drivers are not working with his particular card (regardless of being an rt2500 chipset) trying ndiswrapper won't hurt at all.
 
Old 06-03-2005, 02:58 PM   #6
jimbrook
Member
 
Registered: Apr 2005
Posts: 39

Original Poster
Rep: Reputation: 15
Thanks for the info. I have determined that the wireless card "sees" the signal. However, I don't think it is interpreting the ESSID. I have the first letter in my ESSID capitalized for security. I wonder if that could be giving it trouble. Maybe I will try changing it.

Also, I've not tried "dhclient ra0" to check the IP. Thanks for the suggestions. I may need more
 
Old 06-03-2005, 04:28 PM   #7
rarsa
Member
 
Registered: Nov 2004
Location: Canada
Distribution: Puppy Linux/ Mint
Posts: 211

Rep: Reputation: 31
dhclient ra0 <----- Gets the IP address

if you want to check if you have an ip address do

ifconfig ra0
 
Old 06-04-2005, 11:10 AM   #8
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Quote:
what does depmod -a; modprobe rt2500 do?
To tell the truth, I don't know ... I got them from another thread on these forums. All I know is that they 'wake up' the card so the 'iw...' commands will work.

Note to Raul Suarez: Sorry about the strongly worded recommendation against ndiswrappers, but that program is intended for use with products whose manufacturer's have been uncooperative with Linux developers. This is not the case with Realtek, and their cooperation should be noted by using the correct drivers.

Last edited by rickh; 06-04-2005 at 11:20 AM.
 
Old 06-04-2005, 04:57 PM   #9
rarsa
Member
 
Registered: Nov 2004
Location: Canada
Distribution: Puppy Linux/ Mint
Posts: 211

Rep: Reputation: 31
When you have questions about any command you can allways try the --help option or man <command> (e.g. man modprobe) to get a good idea of what you are doing.

From
Code:
depmod --help
depmod -a ---> probes all the modules. As I understand it checks what dependencies have the available modules so modprobe can load them.


modprobe rt2500 ---> Adds the rt2500 drivers module to the kernel.
 
Old 06-06-2005, 02:07 AM   #10
KohlyKohl
Member
 
Registered: Aug 2004
Location: Wausau, WI
Distribution: SuSE Linux Enterprise Desktop 10
Posts: 193

Rep: Reputation: 30
Card is supported natively under SuSE 9.3, might want to think about upgrading. Under 9.2 it would lock up my computer randomly, but not anymore. One more thing, SuSE 9.2 uses w0 for wireless cards instead of ra0 like every other distro uses(SuSE 9.3 uses ra0, no idea why they ever used w0). Unless there is a work around that I don't know of Shared keys and such are not supported for this card yet.

Last edited by KohlyKohl; 06-06-2005 at 02:12 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless; ralink; rt2500; SuSE 9.2; Help jimbrook Linux - Wireless Networking 5 02-15-2006 01:01 PM
Help with Ralink RT2500 2cubed Linux - Wireless Networking 7 10-25-2005 02:54 PM
Cannot connect to Internet using Ralink rt2500 wireless NIC dsuratman Linux - Wireless Networking 2 09-04-2005 05:32 AM
help with wireless (belkin f5d7000 with the ralink rt2500 chip) penguin tech Linux - Newbie 2 08-08-2005 03:43 PM
ralink rt2500 Jaster Debian 1 12-16-2004 06:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 09:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration