-   SUSE / openSUSE (
-   -   Win share will not auto mount, inclu in Fstab (

ZingSter 04-04-2005 11:19 AM

Win share will not auto mount, inclu in Fstab
HI Gang,
We have two systems in house running SUSE 9.1 Personal.

We also have a windose fileserver. I've successfully mounted the windows shares to one system running SUSE. I accomplished this by:
1st using the mount command with -o option listed the username=XXX,password=XXX
2nd, I added this information to fstab for each share.
Upon reboot the system will auto mount the windows shares no problem.

Now on the second SUSE system I can't get the windows shares to mount automatically. I did essentially the same thing on both systems.
I've manually mounted the file system and then added to fstab accordingly, however the windows shares will not mount automatically on this second system (which is identical to the first system hardware wise)
In order to mount the windows shares on the second system I must open a console and login as root, then mount -a and only then will the windows share mount.

Any ideas why on one system the windows shares will mount and on the other they will not?

Thanks in advance.

gman_O0O0 04-04-2005 11:27 AM

have you tried using smbfstab, that is the supposed preferred method for mounting samba shares at startup.

edit /etc/samba/smbfstab

ZingSter 04-04-2005 11:38 AM

Thanks for the idea. I have not tried using smbfstab on either system.
Maybe this will help solve my problem. Thanks again.

ZingSter 04-04-2005 04:15 PM

Nobody else has anything to add eh?

lesleyb 04-06-2005 07:22 AM

Well there must be some differences between each SuSE system.

One would think that, given the same hardware and software, everything is predetermined and the SuSE installs would be the same. Even with different hardware it should be possible to control it in the same way via the software.

However, I have used 7.3, 8.2 (which is still on my laptop) and am now on 9.2.

In the past I've re-installed 7.3 and 8.2 a number of times; yet to need to go thru that with 9.3.
I'd need to sit down with a box do an install making notes on options chosen and then redo the whole thing again to be definitively sure of this but my experience of SuSE installs is that you can do the same thing and the system comes up different each time. I haven't a clue why that happens but it is annoying. If you consider corporate needs to have similar installs on similar machines then it will cause problems.

I also have no idea how you might compare two installs to spot what the differences are and even if that was easy it might well be like looking for a needle in a haystack to find the one config variable that is affecting your automount.

Check everything on the SuSE boxes relevant to samba (and nfs?) and then work out something that works.

Sorry i can't help


All times are GMT -5. The time now is 05:48 AM.