-   SUSE / openSUSE (
-   -   Who tried OpenSUSE Linux 10.1? (

Progmaker 07-15-2006 02:15 AM

Who tried OpenSUSE Linux 10.1?
I currently have OpenSUSE Linux 10.0, but I've download 5 CDs of 10.1 version. Should I install 10.1? Yes, I understand, that this is newer version than my 10.0, but are there any important differences (except new program versions)? If not, I'll stick with my 10.0 :)

Micro420 07-15-2006 02:22 AM

I gave 10.1 a shot and switched to Ubuntu immediately. I found that 10.1 had problems with updating itself. I'm not sure if they fixed this, but I know that many people had problems updating SuSE 10.1 when it was first released. Novell must have messed up somewhere in their updating system. I'm sure they fixed this in their recent downloads, or for people who figured out how to update their system via another method it should be fixed.

Other than that, I had no complaints with SuSe 10.1 and didn't notice too much of a difference versus 10.0

reddazz 07-15-2006 02:56 AM

If you use the search function and search for similar threads to yours, you will find many comments regarding Suse 10.1. Personally I thought it was a step back from Suse 10 because many wireless cards won't work with 10.1 but they worked fine with 10 and there were many problems with the package manager.

Progmaker 07-15-2006 03:48 AM

Thanks to you both. So, maybe I won't install 10.1, but I'll download 4 CDs of Slackware Linux 10.2...

riba43 07-15-2006 11:42 AM

i switched from SuSE 10.0 to 10.1 immediatelly when it was on the web. I DL DVD, installed it and it works from the beginning. I did not have any problems, neither with my internet card, Tv card, web camera. I only had a problem with the configuration of my Epson laser printer EPL-6200L, because I had to google a bit to find an appropriate driver. But it works fine now. There are the problems with SMART upgrade, but I am using YAST and apt4suse. They are working great, and last time also SMART is working too. So I cant complain.

viswans 07-15-2006 04:04 PM


I installed Open Suse 10.0 and now 10.1 on my HP dvz6000 works perfectly smooth, very few problems (broacom wlan was not supported for sometime, now has native driver). I have tried FC5 and Kubuntu Drapper Drake before. FC kept bloating every time I did an yum update and ubuntu wont even boot after a full install. If you r doing a CD or DVD install its ok, but if you plan to do a net install like I did (remember to get the ip address of the yast mirror sites.

-=Graz=- 07-15-2006 09:08 PM

I installed SUSE 10.1 this weekend and was quite impressed with it in some ways.. I found in terms of hardware detection it was fantastic... It not only knew the video card i have in my laptop but also the screen size and resolution and it auto patched to 1280x800 res - first distro i have ever seen do this..
It detected my wireless IPW2200 card fine but did not seem to come with the firmware bundled so had to copy the files myself..Easily fixed though

I tried KDE first - which had the most enourmous array of apps i have seen on a base install - but it ran like an absolute DOG!

I then tried Gnome which is running a lot better but i am still not totally sold.. I also have had problems with the software updater... It says that there are updates to get and then the novell site appears to return some strange errors...

I have also found that as soon as i run that YaST thing the machine fairly much cr@ps itself... i watch the memory go from 500MB physical free to as low as 21MB!!
It then hovers around 21MB untill a rebpoot...
I know that ppl say the system is configured well if one has a large disk cache.... and small amount of free physical RAM but I have to laugh at having 620MB disk cache and 200MB+ app cache and 21MB of free ram...
I have 1024 MB of RAM in this machine and when in SUSE it has to start paging if i open firefox :)

jschiwal 07-15-2006 09:37 PM

I am running OpenSuSE10.1. I had a problem with the ndiswrapper version supplied by the package, so I rebuilt the program & driver from an earlier download. ( Hint, the ndiswrapper source has a ndiswrapper.spec file. If you extract this file to /usr/src/packages/SPECS and copy the tarball to /usr/src/packages/SOURCES, you can use "sudo rpmbuild -ba" to build your two new RPM files ).

Hardware support is improved. The new zen updater has problems, but it's possible to update the old way using YaST software updater.

For viewing DVDs or listening to MP3 files, you will want to use the packman sources for xine, mplayer, xmms and audacity.

I might still have a problem with defunct beagled-helper processes building up. All and all, I would recommend SuSE 10.1

-=Graz=- 07-16-2006 12:05 AM

jschiwal, out of curiosity - what are the stats on your RAM usage in SUSE..?
Have you noticed anything like what i mentioned about it using as much memory as it can for disk cache ? to the point of barely having enough to use the machine properly...

I dont recall ever seeing a setting that would allow me to specify anything like this.

drsethi 07-16-2006 12:36 AM

I didnot use 10.0 but installed and using 10.1. It is great. Does have some problems like yast got crashed and video codecs and crippled xine and kaffeine. These problems can be tackled by experinced users.

Martin Rasch 07-16-2006 10:18 PM

Trying OpenSuSE or SuSE 10.1
The item that might be confusing this discussion is there are two
SuSE distributions offered at Open SuSE site one is Beta 10.1
and other is GM or Retail version. The GM installation is as smooth as boxed 10.0. The Beta versions 4-5 all have had different kinds of problems. I have installed both GD and beta releases. If you have lots of free time install a beta and try and solve the problems. If you nedd to get an installtion up and running get the GM iso release and have a good time. As to memory settings this is note on ULIMIT FUNCTIONS:

ulimit Settings

The ulimit settings can be configured in /etc/sysconfig/ulimit. By default, only two limits are changed from the kernel defaults:


SOFTVIRTUALLIMIT=80 limits a single process so that it does not allocate more than 80% of the available virtual memory (RAM and swap).

SOFTRESIDENTLIMIT=85 limits a single process so that it does not occupy more than 85% of the physical memory (RAM).

These soft limits can be overridden with the ulimit command by the user. Hard limits could only be overridden by root.

The values have been chosen conservatively to avoid breaking large processes that have worked before. If there are no legitimate processes with huge memory consumption, set the limits lower to provide more effective protection against run-away processes. The limits are per process and thus not an effective protection against malicious users. The limits are meant to protect against accidental excessive memory usage.

To configure different limits depending on the user, use the pam_limits functionality and configure /etc/security/limits.conf. The ulimit package is not required for that, but both mechanisms can be used in parallel. The limits configured in limits.conf override the global defaults from the ulimit package.
The above was taken from SuSE 10.1 release notes. Have that good time.:p

EclipseAgent 07-16-2006 10:54 PM

I have installed and love OpenSuSE 10.1.
I started with SuSE back in 9.x and switched over from Fedora 1.

Maybe it's because I am on a laptop and run KNetWorkManager, but who knows.. I just don't think people give it a shot in depth enough and are quick to say .. Novell is f'ing it up, and I am trying a different distro..

-=Graz=- 07-17-2006 03:57 AM

Martin, thanks for that info... Now i see it i think i remmeber one of the last screens during the install process stating this as well..
This looks to be exactly what i might be looking for! :)

chestnut1969 07-17-2006 06:55 AM

Installed net install of 10.1, used Smart package manager as an alternative to yast

Compiled latest 2.6.17 kernel, Nvidia official drivers, installed XGL

Absolutely fantastic!

gkiagia 07-17-2006 07:28 AM

I use suse 10.1 and what I have to say is that both zen and yast are s***. Yast is too slow and hangs up quite easily (I usually close it with xkill :-). Zen seems nice but it is very slow too and doesn't really install anything: there is always a problem (the most common is the message "Transaction failed" which appears at the end of the installation after an hour of waiting for it to resolve dependencies). Solution: sudo rpm -Uvh package.rpm (fast and easy)

The updating system is also f***** up. Zen doesn't work as I said before and yast has several issues. First, it displays all the packages and not only the updates, which is confusing because you have to check manually the version numbers to ensure that you are updating. Secondly, it doesn't display sizes of patches so you can't really estimate how much time it needs to update. Finally, if the connection is broken during the update, yast hangs up and then you have to reboot and check manually what was installed and what wasn't.

KDE 3.5.1 also has some bugs. I have updated it to 3.5.3 to see a nice desktop system.

Everything else is wonderful. If there weren't yast and zen, suse 10.1 would be the best distro in my opinion.

All times are GMT -5. The time now is 11:35 AM.