LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 01-26-2018, 01:30 PM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,951

Rep: Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146
Weeds: WMaker not setting BG image w/3rd party apps.


TumbleWeeds: WIndowMaker: Not setting background image when using imlib2 3rd party apps?

I took hsetroot a long time ago, gave it what it needed and then some. It works with every Linux Distro I have ever tried until I got to this one, openSuse.

taking the WMaker in its repo, it does not set a background image. I figured maybe, so I compiled it from source installed it into my home directory, tried it again and still I get bad image returned when trying to set an png or jpg.

took everything out. even reinstalled leap converted it to weeds, tried it again. nothing, today I came up with the idea to install hsetroot to see if that will work, because the basis for setting the image is the same via imlib2. It did not.

So I know it is NOT my application. But rather the systems fault for getting the bad image returned.
Code:
userx@tumbles:~> hsetroot -full /media/data/wallpaper/papers/3d_bars-wide.jpg
Bad image (/media/data/wallpaper/papers/3d_bars-wide.jpg)
... mine ...
userx@tumbles:~> mh5000 -c=80x40 /media/data/wallpaper/papers/3d_bars-wide.jpg 
Bad Image: /media/data/wallpaper/papers/3d_bars-wide.jpg
sooooo does anyone got a clue on how to remedy this issue?

Last edited by BW-userx; 01-26-2018 at 01:32 PM.
 
Old 01-26-2018, 04:02 PM   #2
Mill J
Senior Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 1,089
Blog Entries: 2

Rep: Reputation: 459Reputation: 459Reputation: 459Reputation: 459Reputation: 459
Had a similar problem on opensuse once. Feh, qiv and all similar apps just complained about imlib2 stuff. If I remember right I installed nitrogen and it worked. I've since got rid of Suse and never regretted it.
 
Old 01-26-2018, 04:43 PM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,951

Original Poster
Rep: Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146
Quote:
Originally Posted by Mill J View Post
Had a similar problem on opensuse once. Feh, qiv and all similar apps just complained about imlib2 stuff. If I remember right I installed nitrogen and it worked. I've since got rid of Suse and never regretted it.
I'm getting that feeling... it's just a playing around on OS I've got Slack on here too. go look at DistroWatch and see what other independent distros are out there to check out.
 
Old 01-27-2018, 04:18 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,616
Blog Entries: 9

Rep: Reputation: 4096Reputation: 4096Reputation: 4096Reputation: 4096Reputation: 4096Reputation: 4096Reputation: 4096Reputation: 4096Reputation: 4096Reputation: 4096Reputation: 4096
it really has nothing to do with wmaker?

try manually setting the bg with one of those apps, what do you get?

can you look at the "bad" image with a viewer?
 
Old 01-27-2018, 09:23 AM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,951

Original Poster
Rep: Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146
Quote:
Originally Posted by ondoho View Post
it really has nothing to do with wmaker?

try manually setting the bg with one of those apps, what do you get?

can you look at the "bad" image with a viewer?
well I got rid of it, I'm now using that partition for NuTyX Linux (from scratch).
one of what apps? wmsetbg does not use the same methoidology for setting the background it uses X11 pixmaps
Code:
Pixmap CurrentPixmap = None;
char *PixmapPath = NULL;
whereas every other Linux Disto that has WMaker on it and using my app that use imlib2 and well as hsetroot, even feh that uses imlib2 as well as ImageMagic,does not work on openSuSe in WMaker but the others Linux distros with WMaker they do work.

Therefore, logical deduction states what then?

it has to be the Operating System and not the application.

and yes my images work in WMaker on other linux systems as well as fluxbox or other Windowmangers that do not set the background like say, xfce4 , plasma, and such others do. Just above the root window.

mine even works in jwm, which in how they do theirs, by each Vdesktop can have a different image I can get some really cool options going with it. but that takes a big of easy configuring.

Last edited by BW-userx; 01-27-2018 at 09:28 AM.
 
Old 01-27-2018, 09:33 AM   #6
Mill J
Senior Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 1,089
Blog Entries: 2

Rep: Reputation: 459Reputation: 459Reputation: 459Reputation: 459Reputation: 459
Quote:
Originally Posted by BW-userx View Post
well I got rid of it, I'm now using that partition for NuTyX Linux (from scratch).
Lol I switched from Suse to LFS on my project. For my main machine I filled the Void

How is NuTyX? I've been wanting to try it(no free space right now), but it's in line after slack.
 
Old 01-27-2018, 09:41 AM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,951

Original Poster
Rep: Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146
Quote:
Originally Posted by Mill J View Post
Lol I switched from Suse to LFS on my project. For my main machine I filled the Void

How is NuTyX? I've been wanting to try it(no free space right now), but it's in line after slack.
they have a wifi issue with some of thier iso on one of thier sights that demands a password to get in to the net, not good. as it set me back, and the developer in the fourm in here they have pointed me to a different sight they have with their distro already set up with a desktop, as the oneI got only had xorgs basic gui, just terminals,which looked kind of cool.

I was hopping to get that one working with wifi so all I needed to do was get a web browser installed, then play around inside of that basic gui until I got frustrated by it with it limitations. Then put WMaker on it.

Now I am downloading (oops, its done now, 10 ~20 minutes downloading, not bad.) xfce4 flavor which works well with WMaker. .. now that it is down got to dd it to a stick then I'm off to installing it on here. Then I'll know more about it.

the installer is basic so its simple to use.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3rd party library rosy Jovita Linux - Newbie 15 03-16-2010 04:08 AM
Can print through 3rd party software, but not from gnome apps lsutiger Linux - Software 3 07-28-2009 07:58 PM
RHEL 5 and 3rd Party Repositories. zcrxsir88 Linux - Security 2 02-18-2008 07:58 PM
3rd party package managers? crontab Slackware 3 10-06-2007 10:34 AM
Safety of 3rd party cd's robby737 Linux - Security 5 06-16-2004 11:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 01:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration