LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 06-19-2005, 01:11 PM   #1
dohanc
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse 9.1
Posts: 12

Rep: Reputation: 0
Webpage Browsing DNS lookup SLOW


Browsing the web is extremely slow to lookup DNS entries. Sometimes a webpage can take 1-2 minutes loading. Downloading (once a lookup has been completed) can go up to 500kB/s. No problem with internet speed here. Pinging and nslookup a page is intantanous. Strangely will 95% of pages load very slowly, google, yahoo and msn load quickly (except for ads where it has to lookup other addresses) This occurs with both Konqueror and Firefox. The basics are all set up correctly. DNS servers are NOT set to the router IP but the ISPs DNS servers (otherwise wouldn't work at all).

I have done A LOT of research on this before posting. This has largely been blamed due to IPV6 lookups. Most solutions tell you to disable IPV6 lookups as decribed here: http://portal.suse.com/sdb/en/2003/1...illa_ipv6.html

While most users seem to say this fixes the problem it still does not for many other users including myself. Most of these users are forced to go to another distro as even the latest Suse 9.3 has these problems. I upgraded to the latest SuSEfirewalls included on the 9.3 distro and turned SuSEfirewall2 completely off. I have upgraded my Linksys router to the latest firmware. I have tried using only one DNS server. Putting them in differenet orders, everything.

Does anyone have ANY other suggestions to try? I know I can set up BIND to do local caching however this is not a fix by any means. Everytime I go to a new page (as in going to a new link from google) it will take forever. I am very frustrated over this problem. I would like to mostly like to understand how 100% of Suse 9.x users don't have this problem.

Last edited by dohanc; 06-19-2005 at 04:11 PM.
 
Old 06-19-2005, 04:19 PM   #2
dohanc
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse 9.1
Posts: 12

Original Poster
Rep: Reputation: 0
I'm really frustrated now! I got it working. What was wrong? Human-error. I apoligize for wasting a thread.

/etc/modprobe.conf in Suse 9.1 by default was:

alias net-pf-10 ipv6
#install net-pf-10 /bin/true

Now, the instructions at the suse support site shown above was to change that to:

Change

alias net-pf-10 ipv6

to

alias net-pf-10 ipv6
install ipv6 /bin/true


Now, instead of me copying and pasting it directly, I said, oh I just uncomment that second line. That would make sense. I didn't bother trying to load the page on Suse because that would have taken forever. Looking at more closely it was simply human-error.

Some notes: I still am suprised that disabling the SuSEfirewall2 (as su: SuSEfirewall2 stop) did not fix the IPV6 problem temporary because from what I understand it is the firewall screwing up the IPV6 messages. I also don't fully understand why a few sites were fast.

If someone wants to offer a theory for this, I would be interested. Thanks...
 
Old 07-07-2005, 02:57 PM   #3
Motown
Member
 
Registered: Dec 2003
Location: land of oz
Distribution: centos
Posts: 104

Rep: Reputation: 15
Perhaps the sites that resolved quickly have ipv6 addresses, as well as v4
 
Old 07-09-2005, 02:15 PM   #4
ng0g
LQ Newbie
 
Registered: Jul 2005
Location: Boone Iowa
Distribution: SuSE 9.3
Posts: 8

Rep: Reputation: 0
I just upgraded from SuSE 9.0 to 9.3 I had no browser speed or dns lookup speed problems with 9.0, but all of my browsers (mozilla, konqueror, and firefox) are REAL slow with 9.3. Konqueror under 9.0 used to have a little "resolving" message that came up in the lower left hand corner while it was doing the dns lookup. Konqueror under 9.3 does not do this for reasons I have not figured out yet. My version of 9.3 was just purchased straight from SuSE's website about 3 weeks ago. I used YaST to do ALL of the updates so I should have the latest version of the firewall and I still have the problem. Any thoughts? Anything I should check? I noticed that the /etc/modprobe.conf file has a request at the top that says NOT to edit it but to put changes in another file. However the "cure" above says to edit /etc/modprobe.conf. Which one is correct, or are they both correct and this is an exception?
 
Old 07-11-2005, 07:40 AM   #5
bigchris
Member
 
Registered: Jul 2005
Posts: 41

Rep: Reputation: 15
Slow Browsing in 9.3

I'm here for the same reason, looking for answers to why DNS lookup takes so long in 9.3 Pro. I was interested to discover that browsing was super fast using the 9.3 Live Eval disk on the same machine!

I think there may be some real unhappy campers out there when they realize that the installed version doesn't come anywhere close to matching the speed of the demo version!
 
Old 07-11-2005, 11:56 AM   #6
angrysurgeon
LQ Newbie
 
Registered: Jul 2005
Posts: 5

Rep: Reputation: 0
Got the same problem as well (SUSE 9.3). I asked around on the irc chat channels and there was a guy who had this problem and had managed to solve it. Here is the log:

me> It goes sooooooooooo slow, compared to windows, to surf
me> does it have to do with the preinstalled firewall on suse?
i noticed osmething similar when firefo was installed in my homedirectory
i installed it as root and it seemed okay
me> how does one install it "as root"?
1. it could have something to do with the firewall i suppose, but i wouldnt think so
2. su root
3. type in your root password
4. go to the directory where firefox-install extracted to
5. run it
6. follow the prompts
7. but install somewhere like /usr/local/firefox
or /usr/lib/firefox
8. then type (w/out quotes) " ln -s /usr/local/firefox/firefox /usr/bin/firefox
that will link from /usr/bin to where the real firefox executable is
me> aha, damn, what a crap really. That the speed of firefox is dependent on where its located.

Look, im a complete newbie, i have tried whats been said above but it doesnt work for me.

Last edited by angrysurgeon; 07-11-2005 at 01:26 PM.
 
Old 07-12-2005, 02:17 AM   #7
bigchris
Member
 
Registered: Jul 2005
Posts: 41

Rep: Reputation: 15
Okay, this worked for 9.3! Turn off IPV6 support using this procedure.

In a terminal window run (su to root):
then type
#echo "alias net-pf-10 off" >> /etc/modprobe.conf.local (Enter)
#echo "alias ipv6 off" >> /etc/modprobe.conf.local (Enter)

Then, in the address line of FF enter:
about:config
(no spaces)
next in the filter line enter:
ipv6

double click on
network.dns.disableIPv6 to change value from "No" to "Yes"

close FF and restart computer

When the computer reboots you should see significantly faster DNS lookup by FireFox. There are some other FF tweaks that may help even more but this was the "biggie".

Last edited by bigchris; 07-18-2005 at 10:25 PM.
 
Old 07-12-2005, 04:12 AM   #8
angrysurgeon
LQ Newbie
 
Registered: Jul 2005
Posts: 5

Rep: Reputation: 0
This solution seems to work. My lookuptimes have been halved (from like 25 secs for ebay.de to like 13-14 now), but im still not satisfied. Windows 2k still does it faster. Anyway, Thanks alot!

What i was wondering is, could you perhaps direct us toward other tweaks, which one can do with firefox?
 
Old 07-12-2005, 08:45 AM   #9
Firn
LQ Newbie
 
Registered: May 2005
Location: Maastricht, Netherlands
Distribution: SuSE 10.0; Debian Etch
Posts: 24

Rep: Reputation: 15
one of the best known tweaks you can do to speed up firefox:

First, type "about:config" into the address bar and hit return. Scroll down and look for the following entries:
network.http.pipelining
network.http.proxy.pipelining
network.http.pipelining.maxrequests

usually, the browser will make one request to a web page at a time. by doing the next steps, you'll enable it to make more requests at the same time, which speeds it up quite a bit:

Alter the entries found in the first step as follows:
Set "network.http.pipelining" to "true"
Set "network.http.proxy.pipelining" to "true"
Set "network.http.pipelining.maxrequests" to some number like 25, this means it will make 25 requests at once. (or more, if you think your connection can handle more, making like 40 requests on dial up for example wont work, only clog up your bandwidth).

Lastly right-click on the page and select New-> Integer.
Name it "nglayout.initialpaint.delay" and set its value to "0". This value is the amount of time the browser waits before it acts on information it receives. If you're using a broadband connection you'll load pages quite a bit faster now!
 
Old 07-15-2005, 03:31 PM   #10
ng0g
LQ Newbie
 
Registered: Jul 2005
Location: Boone Iowa
Distribution: SuSE 9.3
Posts: 8

Rep: Reputation: 0
Konqueror still real real slow

Trying all of the "fixes" above, I have nearly everything running at a reasonable speed except Konqueror. It is still incredibly slow.
Does anyone have any thought on a fix for this?

Thanks,
Steve NG0G
 
Old 07-15-2005, 07:12 PM   #11
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
/etc/modprobe.conf gets built by SuSE so it is subject to change. Make your changes to /etc/modprobe.conf.local and your changes will survive /etc/modprobe.conf being rebuilt by SuSE. There are many factors that affect speed and a good number of those change dynamically. For example, cable connections, like Comcast, degrade over time because cable is a bus like Ethernet and speed is dependent on the number of concurrent users. Summer school vacation may also be a factor -- kids eat bandwidth. The host site has a major impact based on the size of the pipe used. Notice how major sites like Google always perform better -- fat pipes. This is not to say that 9.3 may have impacted speed as well.
 
Old 07-15-2005, 08:53 PM   #12
bigchris
Member
 
Registered: Jul 2005
Posts: 41

Rep: Reputation: 15
Re: Konqueror still real real slow

Quote:
Originally posted by ng0g
Trying all of the "fixes" above, I have nearly everything running at a reasonable speed except Konqueror. It is still incredibly slow.
Does anyone have any thought on a fix for this?

Thanks,
Steve NG0G
I came out in exactly the same place! Hope you get an answer to the Konqueror issue because it is clearly much slower than FF.
 
Old 07-15-2005, 09:53 PM   #13
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
If you're using Firefox, get the "Bandwidth Tester" extension. That will yield objective measurements that may be helpful. Time of day also has an impact on performance. If you're a night owl like me, you'll be able to see if the problem is load related.
 
Old 07-16-2005, 04:50 AM   #14
bigchris
Member
 
Registered: Jul 2005
Posts: 41

Rep: Reputation: 15
Fragos, I'll do as you suggested, but believe me if you could see the two browsers perform on my machine you wouldn't doubt for a millisecond that Konqueror is way slow. It does look to be primarily in DNS lookup and I am aware that my network is not optimized because my DNS address is pointing at my router instead of my DSL ISPs DSL server, but that isn't bothering FF. Also, I did not see this problem with the Live Eval CD, only the installed 9.3 Pro version.
I'll keep digging...

A correction and a solution!
The 9.3 Live Eval DVD is equally slow - I was confusing it with a Knoppix 3.9 which does browse at good speed. Sorry for that confusion.

I added the following lines to /etc/modprobe.conf.local and now Konqueror flies too!
alias net-pf-10 off
alias ipv6 off

Try it, you'll love it!

Last edited by bigchris; 07-16-2005 at 10:26 PM.
 
Old 07-16-2005, 06:53 AM   #15
ng0g
LQ Newbie
 
Registered: Jul 2005
Location: Boone Iowa
Distribution: SuSE 9.3
Posts: 8

Rep: Reputation: 0
konqueror slow

Making the changes to FF and Mozilla fixed any speed problems with them for me. But no matter what changes I have made Konqueror is really, really, slow. So slow that occasionally I am fooled into thinking it is hung.

My ping times for both url and ip are fine. My isp just cranked the speed up, I am close to 5mb per second now. Mozilla and FF find, and open web pages quickly. Konqueror is so slow that it is nearly unusable. I am continuing to experiment with Konqueror and to comb the web for a solution. I am finding that a lot of folks seem to have this same problem. Many seem to have just given up on Konqueror. I want all 3 browsers, (mozilla, FF, and Konqueror) as I keep all 3 set up differently for different tasks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow DNS Lookup with SuSE 9.3 hera SUSE / openSUSE 14 07-26-2005 08:25 PM
Slow DNS lookup sendas4 Linux - Networking 1 07-05-2005 01:14 AM
Traceroute, Ping, Domain Name Server (DNS) Lookup, WHOIS, and DNS Records Lookup netoknet General 1 05-09-2005 04:43 AM
Slow DNS lookup sanjeevdas Linux - Networking 3 03-26-2004 02:19 AM
slow DNS lookup nowonmai Linux - Networking 5 08-17-2003 01:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 10:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration