-   SUSE / openSUSE (
-   -   VNC from a Windows box to Linux (

abneru 07-04-2005 02:13 AM

VNC from a Windows box to Linux
I am trying to setup my linux box so that I can be able to VNC into it from a windows box. How can I do this correctly?

sugna 07-04-2005 07:08 AM

I've managed to do that successfully from XP to Mepis over a LAN. I just installed RealVNC on each system and it worked as it should without any hassle. (Well, it wouldn't have been a hassle if I knew how to use Linux, anyway . . .)

But I can't get it to work properly the other way around! On Win XP, I just get the linux console on a grey background but no pretty KDE windows. I'm a complete newbie to Linux still stumbling around in the dark, so any help would be appreciated!

theYinYeti 07-04-2005 08:29 AM

AFAIK, when accessed, the VNC service starts a VNC server with an X session inside, by using the "startx" command. So whereas your usual desktop is set by KDM, GDM, or whatever display manager you use, for VNC it is the .xinitrc that does the choice. Try this .xinitrc:

(Note: I don't have Linux at hand, so check that the path is the good one.)


overlord73 07-04-2005 08:49 AM

hi abneru,
where do you hang?
vnc-server installed and running on linuxbox?

sugna 07-04-2005 09:05 AM


Thanks for replying. I did manage to find a /usr/bin/startkde, and after reading some other help earlier today, I have also created a .xinitrc file (though earlier I missed the dot at the beginning -- i'm guessing that matters). Is "/usr/bin/startkde" all I need to enter into that file? Do I need a '&' after it or something like that? Does it need to come before/after something else? And do I need to reboot after changing it, or can I just end the session and start a new one -- or can I just start up a new session of vnc and be on my merry way?

Please bear with me here -- I have absolutely no experience in editing config files like these. It looks like I'm gonna have to get used to it though!

theYinYeti 07-05-2005 02:15 AM

I don't really know. I would expect /usr/bin/startkde to be enough, without a &, in the .xinitrc file (the dot matters, because it is part of the filename, and xinit looks for .xinitrc, not xinitrc... simple as that; for your information the dot makes the file hidden in your file browser, or with the ls command).
Actually, I think the perfect content in .xinitrc would be

exec /usr/bin/startkde
(note the "exec" at the start of the line)
Nothing more is needed in that file, though you may add more if you wish. If you do so, you'll have to run any other application before kde, and with a "&" at the end of the line. Example:

/usr/bin/gkrellm &
/usr/X11R6/bin/xeyes &
exec /usr/bin/startkde

And no need to reboot. Just start a new session with "startx" and check that all is as you wish. If so, try again with VNC.

For your information, if you already have N graphical sessions running (counting VNC ones), and you want to start a new one with startx, then you have to run startx like that:

startx -- :N

sugna 07-05-2005 05:24 AM

Thanks for the instructions. I've put that entry in the .xinitrc file, but to no avail. The same thing is still happening.

By the way, why are files starting with dots hidden -- even to the root user?

overlord73 07-05-2005 05:29 AM

hmm? no posts from abneru...problem solved?

abneru 07-05-2005 06:12 AM

Sorry for the silence, I actually didn't have access to my machine at the time. I will try the solutions given though. Thanks.

sugna 07-05-2005 07:13 PM

Problem solved! (for me, anyway)

Someone on the RealVNC mailing list suggested that I replace 'twm' with 'startkde' in the /.vcn/xtartup file. It worked!!

Instructions from elsewhere had said to replace this twm entry with kdm or gdm, both of which achieved nothing.

A very positive 'Linux moment' for this newbie! May there be many more!

sugna 07-06-2005 05:26 AM

Oh dear, looks like I've broken it again!

After a pleasant half-day of being able to operate MEPIS from WinXP, I've managed to regress back to my earlier state. I installed Apache on MEPIS (via VNC), which seemed to go smoothly, until I tried to start it and failed dismally. Typing "apachectl start", even from the directory containing that very script, merely returns "Command not found". (See for more).

Anyway, after 'installing' Apache and rebooting, vnc is back to providing only the console on XP. The /.vnc/xstartup file still contains the line I added for startkde.

Could my attempted apache installation have interfered with VNC in any way???

sugna 07-06-2005 07:10 AM

Update on last post:

I can usually get VNC to work properly by manually running 'startkde' on the console that appears. But this makes me wonder -- why isn't the xstartup entry taking care of this?

Brian Knoblauch 07-07-2005 12:08 PM


Originally posted by sugna
Typing "apachectl start", even from the directory containing that very script, merely returns "Command not found". (See for more).

Go to the directory and do "./apachectl start". Current directory is not in the default path.

sugna 07-08-2005 12:02 AM

Thanks! I thought it might have had something to do with the path, but I couldn't work out why it wouldn't run even from the apache2/bin directory. Now I know what ./ means. So is linux unlike msdos in that it does not default to the current directory if "./" is omitted in a path?

win32sux 07-08-2005 02:29 AM


Originally posted by sugna
Now I know what ./ means. So is linux unlike msdos in that it does not default to the current directory if "./" is omitted in a path?
yes, any (sane) distribution will have omitted the current directory from the path... ;)

All times are GMT -5. The time now is 06:00 PM.