-   SUSE / openSUSE (
-   -   Virtualbox driver (

collieman 10-20-2007 09:18 AM

Virtualbox driver
I have installed 10.3 on my laptop and 10.3x64 on desktop - Both working fine.

I added Virtualbox onto both through Yast.

I can run Virtualbox on both but get the same error when I try to start a virtual machine:

"VirtualBox kernel driver not installed. The virtual kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-Setup the kernel module by '/etc/init.d/vboxdrv setup' as root

VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED),"

I have searched for a file called 'vboxdrv' but not found.

Any guess' re problem.



Brian1 10-21-2007 09:46 AM

I never used it before but quick read through the docs and forum from their site mentions this. Have you run this command? vboxdrv setup

If this does not help then check the forum and help docs on their site. Might find the answer from a search there. Also searching here showed similiar things to be done.


seelenbild28 10-21-2007 12:37 PM

looks like that you did a kernel upgrade, didn't you? this message says everything you have to do:

Re-Setup the kernel module by '/etc/init.d/vboxdrv setup' as root

that means, open a console, login as root via "su" password and run the command "/etc/init.d/vboxdrv setup". this compiles the vboxdrv kernel module again against the new kernel. then start virtualbox and it will work...

wer lesen kann ist klar im vorteil*g

collieman 10-21-2007 01:29 PM

Yes, I had tried that but could not find vboxdrv.

Deleted the installation and downloaded from the vbox site. All working now, many thanks for the replies.


seelenbild28 10-27-2007 04:18 PM

most probably you did not do that as root:

/etc/init.d/vboxdrv setup


you will have the same problem after a kernel upgrade...

garthkh 07-13-2008 06:54 AM

Virtualbox driver
I am running an upgrade from Suse 10.3 to Suse 11.0 and have the same problems as Collieman. I also can't run the driver from root. I get the following:
garthlinux:/home/garth # /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module done
Recompiling VirtualBox kernel module, NOT. It has been packaged. done
Starting VirtualBox kernel module failed
(Kernel module not found)
garthlinux:/home/garth #

I have done the installation from YAST from the DVD and installed every VirtualBox component.
I wondered about downloading fresh from the VirtualBox site but the latest download there is for Suse 10.3. Will this install ok in 11.0?

I had first tried to get XEN running but discovered that it needed a larger processor than I have (ie AMD 1800+). I'm sad about that as I was quite keen to see XEN working.

Where should I go from here?

pilotgi 07-13-2008 07:31 AM

You should be able to load the module manually by executing as root:

modprobe vboxdrv

garthkh 07-14-2008 09:29 AM

modprobe vboxdrv doesn't seem to do anything. I see the man on it says it will load a module but I see nothing and VirtualBox still give the same error.
How do I find out if I even have a vboxdrv module?

pilotgi 07-14-2008 04:23 PM

After using modprobe, use lsmod to see a list of all the modules that are loaded. If vboxdrv is there then the problem is elsewhere.

garthkh 07-31-2008 10:41 AM

Sorry I've taken a while to reply, I've been away.
Yes the lsmod command reveals that vboxdrv is there.
So where do I go to from here?

1kyle 08-01-2008 12:51 AM

You are much better off using VMWARE. Use the FREE part VMPLAYER.

Now the trick is to be able create Virtual machines as VMPLAYER can only run them not create them.

So what you do is download a nice little paackage called QEMU and follow the instructions


Vmware is much more stable than virtual box and using vmplayer in combination with qemu you have most of the facilities of vmware workstation for FREE and a much more compatable virtual machine as any virtual machine you create on Linux will also run on Windows WITHOUT CHANGE (assuming you can copy the virtual machine to a writable Windows disk partition).



garthkh 08-01-2008 02:53 AM

Thanks 1Kyle. I will take a look into this. Will VMPLAYER handle Win98? And must I download a VMPLAYER - what do I need to have ... I haven't looked in my DVD setup for it yet? Is VMWARE and XEN the same thing?

Back to getting Virtualbox working so I can at least see what it does, I have another display now when I try to run it.....

The VirtualBox kernel driver is not accessible to the current user. Make sure that the user has write permissions for /dev/vboxdrv by adding them to the vboxusers groups. You will need to logout for the change to take effect..
VBox status code: -1909 (VERR_VM_DRIVER_NOT_ACCESSIBLE).

Result Code:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

I have taken a look (using YAST) at my User and Group security and I don't see anything re vboxdrv. How can I set up what this message is asking for?

pilotgi 08-01-2008 11:26 AM

You need to add your user name to /etc/groups. I'm not in front of my Linux box right now but there's a line in /etc/groups for vboxdrv or vbox something.

Use your favorite editor to add you name to this line and save the file. You'll probably have to log out or reboot for it to take effect.

1kyle 08-02-2008 05:25 AM

Xen and vmware are quite separate. Vmware is a company that provides commercial (and free) software which enables you to create and run virtual machines based on a basic "common Hardware" set.

XEN works differently -- I'm not a guru so I can't tell you how it works but "Virtualisation" is done by quite different means than VMWARE (or Virtual Box for that matter).

Just download the vmplayer rpm -- it may even already be on the distribution disks. Otherwise down load from

QEMU might also be on your distribution disks.

Vmplayer will certainly handle Win98 (and Win 95 and even Windows 3.1). That's the WHOLE point of Virtual machines --you can run a myriad of different operating systems on them.

Don't start too many Virtual machines at once as they are really MEMORY intensive --most modern physical machines have enough CPU power --a typical dual processor is more than enough to power 2 or 3 concurrent Virtual Machines --but You'll need at least 2GB (preferabbly 4 or 8GB) to use 3 or 4 Windows virtual machines concurrently.

Unless your Host operating system is VISTA (UGH HIDEOUS) then Windows itself will only see 3GB RAM max however much you've installed so in any case you are better off running Windows Virtual Machines on Linux.

Note a restriction however with Virtual Machines -- you won't necessarily be able to use hardware that doesn't use "Standard" processing calls -- in other words if your device actually by-passes windows itself and calls the BIOS directly you will probably get some problems -- this will occur mainly in some types of Video recording apps but most things will run fine on a VM.



garthkh 08-03-2008 12:21 AM

Thanks for giving such a detailed reply. I will try it out.
I did try to run vmware first from an rpm I downloaded and I got all sorts of missing dependencies. To save time I tried XEN from the DVD and got it up but it wouldn't allow any systems added and I found out that it needs a higher end processor than I am using. Thats when I started with VirtualBox.
I have some family and friends who are still using Win 98 for for software they don't want upgraded, so using the virtual machine facilities seems to be the way to go.
I even have a great OCR scanning program that I got in my Win98 days and I get tied of rebooting into 98 to get to that facility. I use OCR quite a bit and I haven't yet found anything free in Linux that comes anywhere close to really good OCR scanning software that is available on Windows.

All times are GMT -5. The time now is 06:32 AM.