-   SUSE / openSUSE (
-   -   Very strange Firefox problem (

ccin1492 07-30-2009 06:45 PM

Very strange Firefox problem
After updating firefox from 3.0.x to 3.5.1, it wouldn't start and I would get this message: "Could not find compatible GRE between version 1.9.1 and 1.9.1". From past experience this told me that the firefox and xulrunner were out of sync. So I went ahead and removed both packages and re-installed using zypper.

Ok, so now firefox will start but all I get is a blank page/tab with the title "Untitled". That's it. No other messages. If I open another tab, I get the same thing. Below is a list of things I've tried to solve this problem, in no particular order:

- shutdown firewall.
- uninstall and re-install firefox using zypper.
- delete /home/<user>/.firefox
- kick pc

None of those worked. What I finally did do was download the tarball directly from and installed that in my home directory. When I fired that up, it worked. The web pages load fine.

I'm still not sure why the packages provided by opensuse won't work, but I can eliminate the firewall and my local configuration (.firefox) as culprits.

I'm guessing when I remove the packages using zypper, I'm not completely removing it. I might be missing a package or too. Here's the list of packages that I removed:


Is there a cleaner way to remove firefox? Please let me know. Other thoughts and advice would also be welcomed. Thanks.

ronlau9 07-31-2009 05:31 AM

If you are removing firefox using Yast or zypper make sure that all the
hidden files are removed too.
But if you do so all you're personal settings are gone too
Mostly I just download it from mozilla in home dir and run it from

ccin1492 07-31-2009 02:47 PM

I did remove the hidden directory ".firefox", but that had no effect. I didn't think it should anyway. I might go ahead and file this a bug in opensuse. There's no reason why this problem should happen after an update.

As a workaround I have installed it in my home directory. That works fine.

All times are GMT -5. The time now is 03:52 AM.