-   SUSE / openSUSE (
-   -   USB Bluetooth Dongle not recognized (

Heart 11-11-2005 09:52 AM

USB Bluetooth Dongle not recognized

I'm trying to get my Yakumo USB Bluetooth Dongle to work (the same dongle works on Suse 9.3 but doesn't on 10.0 now :confused: ).

All bluez-packages are installed....

When I plug in the dongle /var/log/messages tells me

Nov 11 18:41:10 linux kernel: usb 3-1: new full speed USB device using uhci_hcd and address 3
Nov 11 18:41:10 linux hcid[19111]: HCI dev 0 registered
Nov 11 18:42:47 linux kernel: hci_cmd_task: hci0 command tx timeout

KBluetoothD in kicker is always gray and I can't right click the symbol for example when dongle is plugged in.

When I unplug the dongle I get a KBluetoothD message which says "Bluetooth adapter was unplugged".... hmm, why it recognize it when I unplug it !?


inux:/home/heart # /etc/init.d/bluetooth status
Checking service bluetooth (enabled) :
      hcid  (activated)                                              running
      hidd  (activated)                                              running
  hid2hci  (activated)
      sdpd  (activated)                                              running
      opd  (activated)                                              running
    rfcomm  (activated)
      pand  (activated)                                              running
      dund  (activated)                                              running

Hardware-Information shows me:

53: USB 00.0: 11500 Bluetooth Device
  [Created at usb.122]
  UDI: /org/freedesktop/Hal/devices/usb_device_a12_1_noserial_if0
  Unique ID: KRJj.nQKjiuCfL84
  Parent ID: uIhY.L8MkAwMeNm9
  SysFS ID: /devices/pci0000:00/0000:00:10.2/usb3/3-1/3-1:1.0
  SysFS BusID: 3-1:1.0
  Hardware Class: bluetooth
  Model: "Cambridge Silicon Radio Bluetooth Device"
  Hotplug: USB
  Vendor: usb 0x0a12 "Cambridge Silicon Radio Ltd."
  Device: usb 0x0001
  Revision: "5.25"
  Driver: "hci_usb"
  Speed: 12 Mbps
  Module Alias: "usb:v0A12p0001d0525dcE0dsc01dp01ic*isc*ip*"
  Driver Info #0:
    Driver Status: hci_usb is active
    Driver Activation Cmd: "modprobe hci_usb"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #52 (Hub)



krisealv 11-25-2005 12:42 PM

Exact same problem
I've got a belkin f8t003 ver 2 usb dongle. I get these lines in the messages log


Nov 25 19:22:51 linux hcid[15612]: HCI dev 0 unregistered Nov 25 19:22:51 linux kernel: usb 1-1: USB disconnect, address 2 Nov 25 19:22:57 linux kernel: usb 1-1: new full speed USB device using uhci_hcd and address 3 Nov 25 19:22:57 linux hcid[15612]: HCI dev 0 registered Nov 25 19:23:03 linux kernel: hci_cmd_task: hci0 command tx timeout
and the "bluetooth unplugged" message when removed.

It seems as hough the kbluetooth program stalls untill I remove the dongle, if you click the grey icon while the dongle is inserted, nothing happens until you remove the dongle.

I also get three "Could not connect to sdp server" warnings that I used to get on Suse 9.3, but on that Suse the bluetooth got initialized right after the last warning.

Heart 11-25-2005 02:32 PM

Hm, can't get it to work until now :(

...on Suse9.3 it worked too here (as said)!

fragos 11-25-2005 05:11 PM

SuSE made considerable changes in the are of auto-mounting. When I first installed 10.0 there were some quirks with USB memory sticks. It was possible for Linux to remember a stick was plugged in but get confused about permissions. Removing the stick and plugging it back in brought everything into sync. It would appear that updates via SuSE watcher have fixed that problem. So I have two suggestions 1st have you been updating? 2nd will re-inserting after removal get it to work?

Heart 11-26-2005 03:41 AM


Originally posted by fragos
.....em. So I have two suggestions 1st have you been updating? 2nd will re-inserting after removal get it to work?
Updated: yes
re-inserted: 1000 times...


Be.Gurmeet.Be 11-27-2005 12:17 PM

Two things , Heart ,

Does the Light on Dongle Blinks , [ If it has Light ]

Second, please , can you specify what are connecting to the system through Bluetooth Dongle ?

You look fully familiar with Bluetooth Functioning in Linux.

So if you can not sort it out then.........

any way, I think i may help you if you illustrate a little more your problem........


krisealv 11-27-2005 02:38 PM

Mine does, blinks that is.

Heart 11-27-2005 05:06 PM

I think I'm one little move away from goal...

I've tried it in the console...

- plugged in my usb bluetooth stick (light blinks on the stick)
- then

# hciconfig
hci0:  Type: USB
        BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
        RX bytes:0 acl:0 sco:0 events:0 errors:0
        TX bytes:0 acl:0 sco:0 commands:0 errors:0

- then

linux:/home/heart # hciconfig hci0 up
linux:/home/heart # hciconfig -a
hci0:  Type: USB
        BD Address: 00:02:72:82:16:81 ACL MTU: 192:8 SCO MTU: 64:8
        RX bytes:77 acl:0 sco:0 events:9 errors:0
        TX bytes:31 acl:0 sco:0 commands:8 errors:0
        Features: 0xff 0xff 0x0f 0x00 0x00 0x00 0x00 0x00
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy:
        Link mode: SLAVE ACCEPT
        Name: 'EBL'
        Class: 0x000000
        Service Classes: Unspecified
        Device Class: Miscellaneous,
        HCI Ver: 1.1 (0x1) HCI Rev: 0x20d LMP Ver: 1.1 (0x1) LMP Subver: 0x20d
        Manufacturer: Cambridge Silicon Radio (10)

linux:/home/heart # hcitool scan
Scanning ...
        00:0E:07:85:94:A3      K700i

^^^looks really good I think... (K700i is my mobile phone from Sony Ericsson)

Then I want to do the last step


# rfcomm connect 0 00:0E:07:85:94:A3 1
Can't connect RFCOMM socket: Resource temporarily unavailable

..but this doesn't work.

Shouldn't come now the pin request?! So only one step left I think..

If you have an idea please let me know!


fragos 11-27-2005 05:59 PM

I don't know if you have control over bluetooth timeouts. You might look at making timeouts longer. Its not beyond possible that the default connect timeout is too short.

uberNUT69 11-27-2005 06:12 PM

- make sure that rfcomm and l2cap are loaded as modules
- make sure udev is running/enabled
- tail -f /var/log/syslog
- hcitool info 00:0E:07:85:94:A3
... and post the log messages

Heart 11-28-2005 08:48 AM

Hmmm, played again and again with the pin file and also in yast - bluetooth with secrets disabled and enabled it again, restartet bluetooth service.... and so on...

Then obex push (send file from pc) worked and also after some testing the obex ftp from konqueror worked. Now I also can make my rfcomm0 .....

The only thing which doesn't work is when I try to send a file from my phone to the pc the phone says "send" but at my pc I don't get a dialog which ask me how to store this file. So it goes to nirvana I think...

As said from konqueror-obex-ftp I come to my phone folder structure and can copy files from handy to pc!

fragos 11-28-2005 04:51 PM


Bluetooth has protocols which are subject to the variability of software. Your phone may be the culprit or perhaps Linux needs to be a bit more forgiving of Bluetooth protocols. OpenSuSE may want to look into this. Why not report it as a potential bug. Excuse my curiosity, but are you a Brit? The UK is the only place I remember hearing a cell phone called a handy.

Heart 11-28-2005 06:48 PM

...we say "Handy" in germany here ;)

Be.Gurmeet.Be 11-30-2005 12:49 AM

dear heart,

so far as concern to the files which sent successfully to your System from Phone

Check ;



all the successfully sent files will be there.

usually , Linux does not show any progress bar while file is being transferred to system.

any thing else.


Just Explain, if any thing else you are find wrong with Linux.


Heart 11-30-2005 01:17 AM


Originally posted by Be.Gurmeet.Be
THANKS, didn't know that... The files are in there ;)

Is there a config file where I can change this directory (for example that send files were transfered to my home directory)?

All times are GMT -5. The time now is 11:26 AM.