LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 05-16-2008, 02:30 PM   #1
anurnberg
LQ Newbie
 
Registered: Dec 2006
Location: madrid, spain
Distribution: Novell SLED 10
Posts: 24

Rep: Reputation: 15
Udf-fs problem with X-Plane for Linux


Hi,

I am trying to run X-Plane on my Suse system. The install went smoothly, but at the launch of the programme I get a message that says that the DVD is not a UDF system . I installed udftools, but the programme keeps advising me that I have no UDF mounted.

This is the message I get:

linux-ale:/home/alex # umount /dev/dvd && mkdir -p /mnt/dvd && mount -t udf /dev/dvd /mnt/dvd
mount: block device /dev/dvd is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/dvd,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Can anyone help me understand this?

Thanks for your help.

Alex
 
Old 05-17-2008, 06:48 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Check if the udf kernel module is loaded.
lsmod | grep udf

If not, then modprobe the module:
sudo /sbin/modprobe udf

You may also be able to mount the dvd drive using the iso9660 filesystem. I just tested out both ways on a Wild Wild West (the TV show not the movie) DVD.

Last edited by jschiwal; 05-17-2008 at 06:52 AM.
 
Old 05-18-2008, 11:29 AM   #3
anurnberg
LQ Newbie
 
Registered: Dec 2006
Location: madrid, spain
Distribution: Novell SLED 10
Posts: 24

Original Poster
Rep: Reputation: 15
udf mounted, but...

thanks jschiwal,

I did as you suggested, and now the shell returns this:

linux-ale:/home/alex # lsmod | grep udf
udf 76932 0


However, X-Plane's DVD still keeps saying that the DVD is not mounted as udf... any clues?

Many thanks in advance for your help.

Alex
 
Old 05-18-2008, 11:34 AM   #4
anurnberg
LQ Newbie
 
Registered: Dec 2006
Location: madrid, spain
Distribution: Novell SLED 10
Posts: 24

Original Poster
Rep: Reputation: 15
more info...

I did a dmesg | tail, this is the result

linux-ale:/home/alex # dmesg | tail
vboxdrv: Found 2 processor cores.
vboxdrv: fAsync=0 u64DiffCores=882.
vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
vboxdrv: Successfully loaded version 1.6.0 (interface 0x00070001).
ISO 9660 Extensions: Microsoft Joliet Level 1
ISO 9660 Extensions: RRIP_1991A
UDF-fs: No VRS found
ISO 9660 Extensions: Microsoft Joliet Level 1
ISO 9660 Extensions: RRIP_1991A
UDF-fs: No VRS found


Does this mean something to you?

thanks, alex
 
Old 05-18-2008, 06:27 PM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
I looked up what VRS stands for:

http://www.mscience.com/faq72.html

I don't know if this is something used on a writable disc only, but it seems that your disc may be recorded using ISO-6990 but doesn't contain UDF stuctures. As I understand it, UDF is an extension of ISO9660.

See if you can manually mount the disc using each filesystem.

Also, with the disc in the drive try:
udevinfo -q env -n /dev/dvd

Also, /dev/dvd is probably a symbolic link to the actual device node such as /dev/sr0. You might want to look at the target node and use that instead. You could also have udev or hal issues if the /dev/dvd device node isn't being created after inserting a dvd.

Code:
ls -l /dev/dvd

sudo umount /dev/dvd
sudo mount -t iso9660 /dev/dvd /mnt/dvd

sudo umount /dev/dvd
sudo mount -t udf /dev/dvd /mnt/dvd
See if both mount attempts succeed. Also try with a video DVD disc to eliminate a difference in discs.

Also, how was the disc recorded. If it was burned in Window's Vista, they modified their implementation of UDF version 2.01 from the standard. Even Window's XP won't be able to read such a disc.

One last thing to check is if the nsl_utf8 kernel module is loaded as well. I don't know it this is needed or if this module also provides support for utf16. There isn't an nls_utf16 kernel module that I could find.

You might want to read the udf.txt file in the kernel documentation for some general background info.

I have a bad dvd drive on my laptop, so I use an external drive. So my /dev/dvd device points to /dev/sr0 while /dev/dvd1 points to the drive that I actually use:
Code:
/dev/dvd -> sr0
jschiwal@hpamd64:/usr/src/linux-2.6.22.17-0.1/Documentation> ls -l /dev/sr1
brw-rw----+ 1 root disk 11, 1 2008-05-16 12:46 /dev/sr1
jschiwal@hpamd64:/usr/src/linux-2.6.22.17-0.1/Documentation> ls /dev/dv* -l
lrwxrwxrwx 1 root root 3 2008-05-16 12:46 /dev/dvd -> sr0
lrwxrwxrwx 1 root root 3 2008-05-16 12:46 /dev/dvd1 -> sr1
lrwxrwxrwx 1 root root 3 2008-05-16 12:46 /dev/dvdrw1 -> sr1
If you have a similar situation, the software may be making the assumption that /dev/dvd is being used and recreating the link to point to /dev/sr1 may fix the problem.

Here is something you may find of use as well:
Code:
halmount /dev/sr1
/dev/sr1 mounted on /media/WWW_S1_D3

Last edited by jschiwal; 05-18-2008 at 06:57 PM.
 
Old 05-20-2008, 03:55 PM   #6
anurnberg
LQ Newbie
 
Registered: Dec 2006
Location: madrid, spain
Distribution: Novell SLED 10
Posts: 24

Original Poster
Rep: Reputation: 15
nothing...

Hello jschiwal,

Many thanks for your help so far. For the moment, I could not solve the problem.

In demo mode, everything works just fine.
When I run de DVD (I can watch and DVD that I load in my system), it keeps saying two things:

- DVD is write-protected
- No UDF-FS (in this case, the dmesg | tail command still says that VRS is missing).

the annoying thing is that in demo mode everything works.

Thanks,

Alex
 
Old 05-20-2008, 07:59 PM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
So the program writes to the DVD! In that case, you do need the UDF module loaded. You might want to google for
"udf packet write". I didn't realize that the program would actually write to the DVD. I think that your kernel needs UDF packet writing
support enabled. A 2.4 kernel may need a patch to enable packet writing.

If your system has the .config file saved, you might want to locate the start of UDF support settings.
You can also get the configuration of a running kernel from the /proc/config.gz file:
zcat /proc/config.gz | less


I don't know if these instructions are applicable for your kernel or when using this program.
The x-plane program probably does this itself.

Code:
How to create a UDF filesystem ready for writing to a DVD/CD-R
--------------------------------------------------------------

As root, execute the following commands. (After "count=", supply the
required size in MB of the filesystem.)

   dd if=/dev/zero of=udfimage bs=1M count=10
   mkudffs udfimage
   mkdir udfmnt
   mount -o loop -t udf udfimage udfmnt

You need Linux 2.4+ with UDF read *and* write support enabled. Now you
can copy data to the "udfmnt" directory. After an "umount udfmnt", the
file "udfimage" can be written to the medium.
http://olympus.het.brown.edu/cgi-bin.../README.Debian

Be sure to read the README file for udftools in /usr/share/doc/packages/udftools/. I didn't realize that
this program was writing to the disc. So the previous advice was to try mounting the disc for reading.
Sorry that I missed that. I'm not at my Linux computer right now so I couldn't look in the kernel .config
settings for clues.

Quote:
In demo mode, everything works just fine.
In the demo mode, are you booting the system to the demo disc? If so, then you are booting up with a different kernel, which may have different kernel options enabled or different kernel modules loaded. Going to a virtual terminal [CTRL-ALT-F1] and entering "lsmod" can give you a list of loaded kernel modules to compare. However, some kernel settings won't be modules and others might be built in (option Y instead of M). If this is a 2.6 kernel, there might be a /proc/config.gz file you can save to disk (e.g.: zcat /proc/config.gz >/mnt/home/usrname/zplane.conf) and compare with the config of your own kernel when you boot normally.

Last edited by jschiwal; 05-21-2008 at 01:20 AM.
 
Old 05-31-2008, 04:48 AM   #8
anurnberg
LQ Newbie
 
Registered: Dec 2006
Location: madrid, spain
Distribution: Novell SLED 10
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks again

Quote:
Originally Posted by jschiwal View Post
So the program writes to the DVD! In that case, you do need the UDF module loaded. You might want to google for
"udf packet write". I didn't realize that the program would actually write to the DVD. I think that your kernel needs UDF packet writing
support enabled. A 2.4 kernel may need a patch to enable packet writing.

If your system has the .config file saved, you might want to locate the start of UDF support settings.
You can also get the configuration of a running kernel from the /proc/config.gz file:
zcat /proc/config.gz | less


I don't know if these instructions are applicable for your kernel or when using this program.
The x-plane program probably does this itself.

Code:
How to create a UDF filesystem ready for writing to a DVD/CD-R
--------------------------------------------------------------

As root, execute the following commands. (After "count=", supply the
required size in MB of the filesystem.)

   dd if=/dev/zero of=udfimage bs=1M count=10
   mkudffs udfimage
   mkdir udfmnt
   mount -o loop -t udf udfimage udfmnt

You need Linux 2.4+ with UDF read *and* write support enabled. Now you
can copy data to the "udfmnt" directory. After an "umount udfmnt", the
file "udfimage" can be written to the medium.
http://olympus.het.brown.edu/cgi-bin.../README.Debian

Be sure to read the README file for udftools in /usr/share/doc/packages/udftools/. I didn't realize that
this program was writing to the disc. So the previous advice was to try mounting the disc for reading.
Sorry that I missed that. I'm not at my Linux computer right now so I couldn't look in the kernel .config
settings for clues.


In the demo mode, are you booting the system to the demo disc? If so, then you are booting up with a different kernel, which may have different kernel options enabled or different kernel modules loaded. Going to a virtual terminal [CTRL-ALT-F1] and entering "lsmod" can give you a list of loaded kernel modules to compare. However, some kernel settings won't be modules and others might be built in (option Y instead of M). If this is a 2.6 kernel, there might be a /proc/config.gz file you can save to disk (e.g.: zcat /proc/config.gz >/mnt/home/usrname/zplane.conf) and compare with the config of your own kernel when you boot normally.

Thanks jschiwal, sorry for replying so late - I was on trip and had no access to my computer. I am trying now your advices, and let you know how it goes.

Really appreciated your help, Alex
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: ATI Linux & X-Plane: It Works LXer Syndicated Linux News 0 01-28-2008 01:30 AM
Stuck again trying to reinstall x-plane in linux rooman Linux - Newbie 1 03-30-2007 07:14 AM
LXer: Linux on a Plane: What a Pain! LXer Syndicated Linux News 0 03-14-2007 06:46 PM
X-Plane 8 linux demo released ror Linux - Games 7 01-11-2007 03:16 PM
LINUX PLANE MODEL Project and Legal question Kostya Osetskyy General 5 04-10-2006 04:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 09:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration