LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 05-06-2006, 03:57 PM   #1
allelopath
Member
 
Registered: Jan 2003
Location: New Mexico
Distribution: Ubuntu 18.04.3 LTS
Posts: 539

Rep: Reputation: 30
The powersave daemon is not running


When starting my laptop with a newly installed opensuse 10.0, i get this message:

The powersave daemon is not running
Starting it will improve performance:
/usr/sbin/rcpowersaved start

1. What does it mean by "improve performance"?

2. If yes to 1, then how do i have it automatically start up?
 
Old 05-07-2006, 08:58 AM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
If you are using a laptop, running powersaved is important because it helps conserve battery life and deals with other issues regarding power management. You can start powersaved at boot up by starting a console, switching to root and doing "chkconfig powersaved on".
 
Old 05-07-2006, 11:12 AM   #3
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
I also had this problem on my laptop where it would suggest I use powersaved. I just kept ignoring it and one day, it disappeared! Now the message does not pop up anymore. I'm not sure if it was because of some updates or if it stops bugging you after awhile.
 
Old 05-08-2006, 06:53 PM   #4
allelopath
Member
 
Registered: Jan 2003
Location: New Mexico
Distribution: Ubuntu 18.04.3 LTS
Posts: 539

Original Poster
Rep: Reputation: 30
the command suggested:
chkconfig powersaved on
and also the command suggested by the warning:
/usr/sbin/rcpowersaved start

do not prevent the message from appearing (in a dlg box) at startup

However, performing the 2nd command first thing on startup comes back with "daemon already running".

I guess the warning is shown regardless and will expire after some time.
 
Old 05-08-2006, 07:00 PM   #5
allelopath
Member
 
Registered: Jan 2003
Location: New Mexico
Distribution: Ubuntu 18.04.3 LTS
Posts: 539

Original Poster
Rep: Reputation: 30
Also went to Yast -> System -> System Services (Run Level)
and enabled 'powersaved', even though it already was.
Still get the error message
 
Old 05-09-2006, 02:50 AM   #6
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
I suggest you file a bug report abgout this issue to the Suse devs.
 
Old 05-09-2006, 09:43 AM   #7
allelopath
Member
 
Registered: Jan 2003
Location: New Mexico
Distribution: Ubuntu 18.04.3 LTS
Posts: 539

Original Poster
Rep: Reputation: 30
so, after a day (with numerous reboots), the dlg no longer appears.
 
Old 05-25-2006, 04:43 PM   #8
saturn76
LQ Newbie
 
Registered: May 2006
Posts: 5

Rep: Reputation: 0
Unless you have laptop, you don't really need powersave, I guess. You might switch it off and then check "do not run on start up" when it shuts down. That did it for me.
 
Old 05-26-2006, 09:20 AM   #9
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Quote:
Originally Posted by allelopath
so, after a day (with numerous reboots), the dlg no longer appears.
EXACTLY! That's what I was saying in my post. The message just mysteriously disappears. Very odd!
 
Old 05-27-2006, 06:12 AM   #10
litlmary
Member
 
Registered: May 2005
Location: Texas, somewhere near Houston (I think)
Distribution: See my sig
Posts: 308

Rep: Reputation: 30
same thing happened to me on my laptop. I got a warning on nearly every boot that the powersave daemon was not running, but manually starting the daemon would result in a message that it was already running. Then one day it just stopped bugging me about it. I don't know if it coincided with a YOU patch installation or not, but it hasn't happened in weeks or months...
 
Old 07-18-2006, 08:13 AM   #11
ghettobeamer
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Rep: Reputation: 0
I definately got the same error. I just installed SUSE 10 about 2 weeks ago so I keep on hoping it will go away. Any new advice on how to get rid of it if it doesn't?
 
Old 07-18-2006, 08:16 AM   #12
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
I too had this error with 10.0 and after trying quite a few things, and not finding a solution it just dissapeared for me also.

I havne't had this issue once with 10.1 yet.
 
Old 07-18-2006, 08:22 AM   #13
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
I think that the "powersaved" daemon is started in the background and simply hasn't started yet when kpowersave starts.
 
Old 07-18-2006, 08:31 AM   #14
ghettobeamer
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Rep: Reputation: 0
Kpowersave daemon not running and cannot distinguish between battery and charging

That is possible jschiwal, but I still get many errors. For instance I don't have the option to change the CPU frequency until I open up YaST2 Power Management Module. Then I get an error when I try and exit out of the module. My laptop does not understand the difference between battery power and charging. It always says it is charging which is frusterating cause I never know what the battery level is. Any ideas on this stuff? Thanks.
 
Old 07-18-2006, 09:20 AM   #15
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
I had this on an HP laptop -- I also got some side effects -- no USB mouse would work nor was any network card detected.

I re-booted the laptop with ACPI=OFF and all the errors went away -- of course when shutting down the system you had to physically switch the power off after the power down sequence had finished -- but not a real hassle.

I think it depends a lot on what laptop you have --some work with ACPI, some with "Partial ACPI" and some where you just have to turn the whole thing off.

Cheers

-K
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rcpowersaved daemon is not running iskiri SUSE / openSUSE 1 01-04-2006 01:58 PM
KPowersave's "The powersave daemon is not running" error MichaelMax SUSE / openSUSE 4 12-05-2005 11:58 AM
Running in daemon mode socks Slackware 1 10-15-2004 08:27 PM
running OpenSSL daemon Chiel Linux - Newbie 2 08-31-2004 07:59 AM
The lisa daemon does not appear to be running. Alex Housley Linux - Networking 3 10-18-2003 11:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 04:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration