LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 11-15-2008, 05:07 PM   #1
Larse
LQ Newbie
 
Registered: Feb 2007
Location: Stockholm, Sweden
Posts: 14

Rep: Reputation: 0
SuSE10.3 "run fsck manually!"


I have a problem here because I installed my SuSE10.3 in swedish, but will try and translate.

After 'bout a year with the system running smooth on a separate P-ata-disk I got an errormessage with the regular fsck that occurs every 20th boot:

fsck failed. Please repair manually and reboot. The root
file system is currently mounted read-only. To remount it
read-write do:
bash# mount -n -o remount,rw /
Attention: Only CONTROLL-D will reboot the system in this
maintance mode. Schutdown or reboot will not work.


I stopped there, tried to run fsck -n (without any changes) and got several error reports among them:
Superblock last mounted in the future. Fix? no
Superblock last written to in the future. Fix no

Pass1: Deleted inode nr........... has dtime 0. Fix? no
Pass 2-4, no errors
Pass 5: Checking group information consistency: Block bitmap differences; ---4 lines with block numbers. Fix? no

Number of free blocks counted is wrong (..... instead of ...... counted)
Inode bitmap differences -426626. Fix? no
Number of free inodes is wrong...... Fix? no

Warning Filesystem still has errors!

fsck.ext3 /dev/sdb6 failed (status (0x4) Run manually!


(Still I can boot the system to start in an ordinary way. Edited: And I found out that that was because when I now ran fsck -n I had already run it from the Debian-system on another partition! See below.)

I could not find any instruction how to run fsck on an unmounted /dev/sdb6 so I first tried to run it from a Debian installation I have got on another partition on the same disk. It made some corrections in the filesystem and it was finally error-free.... At least that what it looked like, and was reported.

When I returned to SuSE, and booted it failsafe I halted at login and ran a e2fsck -n and GOT NEARLY exactly the same errorreports as above!

Finally ran e2fsck "sharply" from the Rescue system on the installation DVD. Corrections were made to the filesystem. Finally it was error-free. -Returned to and booted SuSE failsafe, ran fsck -n and got exactly the same kind of error reports as I first got! Some block number were changed, but the same kind of errors. -And I was again asked to run fsck MANUALLY?

Other tests I've made indicates that there are no harddrive errors.

How do I run fsck manually?
And how do I do it on an unmounted filesystem?
And how do I do it in a way that SuSE accepts as "fixed?

Anyone (who doesn't recommend installing Ubuntu

Regards
Lars

Last edited by Larse; 11-17-2008 at 06:49 AM.
 
Old 11-15-2008, 08:25 PM   #2
jiobo
Member
 
Registered: Nov 2008
Posts: 180

Rep: Reputation: 36
Quote:
Only CONTROLL-D will reboot the system in this
maintance mode. Schutdown or reboot will not work.
Run fsck in this maintenance mode of SUSE. Then, use Ctrl-D to reboot. There are various options for fsck, see man fsck. You can use the auto "yes" to fix errors, or you can manually type in "y" and enter key each time it finds an error.

Once a drive starts getting errors, it can be more error prone in the future. Try to back up any important data first, or after you have fixed the errors and booted back up. You may lose data if you run fsck before you have backed up data though. It is your call.
 
Old 11-16-2008, 02:36 AM   #3
Larse
LQ Newbie
 
Registered: Feb 2007
Location: Stockholm, Sweden
Posts: 14

Original Poster
Rep: Reputation: 0
You mean I should run fsck when /dev/sdb6 (the partition with errors) is mounted? rw?

The reason I looked for a way to do it unmounted is I've read som many warnings about that.

(Ok about the backup, I did it as son as the first boot errormsg occurred

Lars
 
Old 11-16-2008, 10:44 AM   #4
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: openSUSE 15.2, Microware OS-9, MX-19, Bodhi 5.1.0
Posts: 256

Rep: Reputation: 41
Quote:
Originally Posted by Larse View Post
I stopped there, tried to run fsck -n (without any changes) and got several error reports among them:
[FONT="Courier New"]Superblock last mounted in the future. Fix? no
Superblock last written to in the future. Fix no
I have seen this error on my computer whenever the time/date has been incorrectly or excessively modified. What I do is power down, boot with a live CD (Knoppix or SUSE live) to make sure that no partitions are mounted then run fsck on all the partitions and accept all the changes it recommends. I think your problem lies with a bad or erratic clock setting.
 
Old 11-17-2008, 06:43 AM   #5
Larse
LQ Newbie
 
Registered: Feb 2007
Location: Stockholm, Sweden
Posts: 14

Original Poster
Rep: Reputation: 0
Thank You ionmich and jiobo for the help so far!!

I am beginning to wonder if I haven't got the whole thing wrong?

You may excuse me now if I may sound respectless, not to You two, but to the authors of fsck

When the auto-filesystem-check runs -in my case every 20th boot and with the options -a -C0- it reports "failed" and comes up with the message in the beginning of this thread ONLY if there are system-critical errors in the filesystem (and the option -a corrects only errors that are auto-correctable, without any intervention).

I finally found out that "run fsck manually" simply meant "with any option except -p and -a" and "in maintainance mode" probably meant the mode the autofsck-script set the machine in when leaving the above message or runlevel 1. The warning to do so only when the partition/filesystem is unmounted is very adequate! I e running it from a start-diskette, a live-CD/DVD, the installation-CD/DVD or from another Linux-system on the same machine.

Running fsck or fsck.ext3=e2fsck without options or with the "manual" options -c, -b, -v delivers a very extensive error report, in the case of -f an extremely extensive error report. But doesn't give any hint of which of the errors that are system-critical.

I guess (and perhaps I'll edit my thread-start) that when I ran fsck.ext3 on my unmounted SuSE-partition with errors (successively with -n, -b and lastly -f -option) from another partition (with Debian) on my machine, that made it! And THAT was what made my SuSE bootable again.

My trouble was that when I ran fsck -n on the now working and mounted SuSE-partition I still got heaps of reported errors! And this was the reason I started this thread. I was trying to correct filesystem errors that were there, but never were system-critical.

(I can tell that because I finally tried running fsck on the mounted SuSE-partition after having made a ghost-image of it, apart from backing up my important files. I did it with care, many times successively, and finally got rid of all filesystem errors! And with that the whole functionality of the SuSE-system! )

I tried my hypothesis that fsck reports "too many" and non-system-critical errors by running it in my recently installed Debian-etch (equally on Ext3, not modified and used very little). -I got error-reports of the same kind and in about same amount as in my now corrected SuSE! Equally "the superblock last mounted in the future", you can correct that as many times you want, it comes back!)

To round this up: What I learned is that whenever I get a "halt" during boot from the auto-fsck again, I'll run fsck from another Linux-system, a startdiskette or the installation-DVD. And I'll probably run it without options, because I think that is the "softest" option beside -a/-p. -In this way fsck will correct the necessary, critical errors. -And, by the way, I tuned up my autofsck to run every second boot, in case I got the whole thing wrong

Best regards
Larse

PS. Anyone who sees that I got the whole thing about fsck wrong: PLEASE TELL ME! Or if anyone knows a way to make fsck "filter-out" the system-critical errors. DS.
 
Old 11-27-2008, 03:46 AM   #6
jiobo
Member
 
Registered: Nov 2008
Posts: 180

Rep: Reputation: 36
You can run fsck when you boot up another Linux install on an umounted partition, as you did with your Debian installation of Linux. When you boot up Suse, and it complains that fsck found errors, it should bring you to a "maintenance mode" shell that you can then run fsck from. Fsck has a built in safety warning that should tell you if the partition is mounted rw. You can also find out if the partition is mounted rw before you run fsck.
 
Old 11-28-2008, 07:27 AM   #7
Larse
LQ Newbie
 
Registered: Feb 2007
Location: Stockholm, Sweden
Posts: 14

Original Poster
Rep: Reputation: 0
Thank You jiobo!

I'll save Your remarque!

Since last I now have had the autofsck tuned to run every 2nd boot (In my case ~2 times/day, now for 2 weeks) and everything is A-OK.

Best regards
Larse
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"fsck failed. Please repair manually and reboot" after chaning non-system partition undeaf SUSE / openSUSE 17 02-07-2014 01:18 PM
E:dpkg was interrupted,you must manually run"dpkg --configure -a" to correct problem loplop4 Debian 5 09-29-2008 12:11 PM
fsck returns "run manually" ursahoribl Linux - General 4 10-14-2006 12:40 AM
re "cant connect to internet using suse10" and "will this work?" beejayess Linux - Newbie 12 07-11-2006 03:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 05:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration