LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 02-24-2006, 06:52 PM   #1
RedBoot
LQ Newbie
 
Registered: Dec 2005
Distribution: SUSE Linux v 10
Posts: 22

Rep: Reputation: 15
Question SUSE NFS client can't detect an NFS server


Hello,
I'm trying to setup NFS. I've used the Yast Network NFS Server setup and have another PC setup as NFS client. At the client I click on Add server, it looks for NFS servers for about a minute and come back with a blank list.
So attempting command line I do:

cat /etc/exports
/shared/ *(rw,root_squash,sync) 192.168.1.24/24 (rw,root_squash,sync)

exportfx -r

showmount -e
Export list for linuxsrv:
/shared )everyone)

Still doesn't work.

I checked the "open firewall" box. Firewall shows NFS server and NFS client listed.

Not sure what to try next...
 
Old 08-09-2007, 02:05 AM   #2
gsr_kashyap
Member
 
Registered: Jul 2004
Location: india
Distribution: Ubuntu 14.04
Posts: 155

Rep: Reputation: 15
the steps are simple
from commd prompt type: yast2 nfs_server which pops a gui.
you will find
->nfs server choose start
->then check enable nfsv4 (better give localdomain)
->add the directory u want to export
->click finish

wola your nfs server is finished!!
 
Old 08-18-2007, 12:42 AM   #3
jlmuzzio
LQ Newbie
 
Registered: Aug 2007
Location: Hawaii
Distribution: SuSE 10, Red Hat 7.3, Fedora 7
Posts: 1

Rep: Reputation: 0
Aloha gsr_kashyap,


What you mean by "->then check enable nfsv4 (better give localdomain)"
there is no such an option in the context mentioned above...
so your advise does not give any light for the problem mentioned by RedBoot.

I happened to have the same problem and spend money with Suse 10 Bible, went to this forum and the problem persists. Is that so hard to make NFS work with SuSE 10?. As the Yast2 visual interface suggests, it should be a breeze right. But still no NFS working.
Could somebody help here?
Sincerely yours,

Muzzio
 
Old 01-19-2009, 04:05 AM   #4
dsupriya
LQ Newbie
 
Registered: Jul 2008
Posts: 5

Rep: Reputation: 0
no module "nfs_server"

yast2 nfs_server
No such client module nfs_server
 
Old 01-19-2009, 11:56 PM   #5
gsr_kashyap
Member
 
Registered: Jul 2004
Location: india
Distribution: Ubuntu 14.04
Posts: 155

Rep: Reputation: 15
I am not sure of which version of suse server are u using but..
as soon as u start yast2 nfs_server, The gui starts and
the check box with enable nfsv4 is just below firewall settings

I am using SLES10(32bit).

wish I could add any screen shot here
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to mount a nfs mount from linux client to AIX nfs server dennyqian AIX 13 04-11-2016 11:30 PM
NFS client = Linux, NFS server = Mac OS X Tiger --> Hell of a problem make Linux - Networking 9 03-10-2006 05:16 AM
nfs client on knoppix 3.9 - problem mounting nfs drive Rod Butcher Linux - Networking 1 09-21-2005 04:18 AM
SuSE 9.0 NFS client with RHL 7.3 NFS server ocjacob Linux - Networking 0 02-01-2005 01:01 PM
nfs client should it use tcp or udp to nfs serve rportmapper andersonas Linux - Networking 2 06-30-2004 12:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 10:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration