LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 06-20-2019, 07:47 AM   #1
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 192

Rep: Reputation: Disabled
Suse Leap 15 left to do its own upgrade is now unuseable


Hi all,

=== Dell OptiPlex 780
=== X86-64
=== Intel Graphics Media Accelerator 950
=== Intel 4 Series Chipset Integrated Graphics Controller
=== Intel Gigabit Ethernet Controller
=== Intel(R) Core(TM)2 Quad CPU Q8400 @ 2.66GHz
=== 8Gb RAM
=== Intel SATA Controller [RAID mode]
=== 2 x 1Gb HD (Mirrored)
=== PIONEER DVD-RW DVR-219L

I always used to 'zypper up' but was assured that the built in leap 15 tools were OK, and so they have been, up until now.

I can boot to get a variety of starting options, for at least three seemingly different versions, none of which get me to a useable Linux screen or interface.
I have to power off and start again. Messages are too few and too fleeting for me to capture.
I've downloaded an iso of 15.1 and hope to go for an upgrade.

Advice would be invaluable.

Regards

Chris
 
Old 06-20-2019, 08:17 AM   #2
dc.901
Member
 
Registered: Aug 2018
Location: Atlanta, GA - USA
Distribution: CentOS 6-7; SuSE 8-12
Posts: 521

Rep: Reputation: 145Reputation: 145
Have you tried to rescue and review messages and boot.log file to see if it gives any useful info?
After grub screen, if you press F2, it should show you boot up messages instead of the graphical node. Perhaps something there that may be useful?
 
Old 06-20-2019, 08:31 AM   #3
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 192

Original Poster
Rep: Reputation: Disabled
Hi DC.901
At various times I have tried running through all the F keys. The only response was as reported earlier.

I'll go and boot now, I'll focus on F2 only:

Ok

I have a screen with nine entries.

I'm offered tumbleweed in the first two. I've never installed tumbleweed!

I'm offered Leap 15.0 on dev/md124p2 and an advanced option.

I'm offered Leap 15.0 on dev/md126p2 and an advanced option.

I'm offered Leap 42.3 on dev/md126p4 and an advanced option.

And finally I'm offered Leap 15.0 on dev/md126p2 with no advanced option.
 
Old 06-20-2019, 09:14 AM   #4
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 192

Original Poster
Rep: Reputation: Disabled
I've been typing for 15 minutes, getting as much data as I could but I'm using android to get it to you and it just lost the lot!

It seems to report that it timed out waiting for device dev-disk-by/xxxxxxx xxx.device

Dependency failed for /home

Unless I am mistaken, this is reporting a disk problem but I'm running raid mirrored and it tells me all is well!

I've attach a raid jpg

The degraded disk shown, is not part of the array.
Attached Thumbnails
Click image for larger version

Name:	20190620_150825.jpg
Views:	7
Size:	264.3 KB
ID:	30767  
 
Old 06-20-2019, 10:10 AM   #5
dc.901
Member
 
Registered: Aug 2018
Location: Atlanta, GA - USA
Distribution: CentOS 6-7; SuSE 8-12
Posts: 521

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by Crb999 View Post
It seems to report that it timed out waiting for device dev-disk-by/xxxxxxx xxx.device

Dependency failed for /home
So, perhaps, try to either boot into single user mode (or rescue mode then mount /)
Update /etc/fstab and comment out /home then reboot...
This way, OS should come up without /home mounted then you can figure out what's going on with /home
 
Old 06-20-2019, 10:23 AM   #6
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 192

Original Poster
Rep: Reputation: Disabled
To be frank, I don't know how to get into single user or rescue mode! Sorry.

I've three more pictures dealing with mounting the part ions if that helps any.

Ill stick them on but then I'm away for the rest of the evening teaching, (not Linux, karate).

I come back here tomorrow though.

Thanks DC.09
Attached Thumbnails
Click image for larger version

Name:	20190620_154834.jpg
Views:	3
Size:	258.4 KB
ID:	30769   Click image for larger version

Name:	20190620_154913.jpg
Views:	8
Size:	253.8 KB
ID:	30770  
 
Old 06-20-2019, 11:53 AM   #7
Sauerland
Member
 
Registered: Jul 2017
Distribution: openSUSE Leap
Posts: 55

Rep: Reputation: Disabled
Quote:
I'm offered tumbleweed in the first two. I've never installed tumbleweed!
I think you have installed Software by an such named 1-Klicker........
And this was Software for Tumbleweed.
Now you have an mix of Leap and Tumbleweed.......
 
Old 06-20-2019, 12:15 PM   #8
petelq
Member
 
Registered: Aug 2008
Location: UK
Distribution: openSUSE(Leap and Tumbleweed) and a regularly changing third
Posts: 378

Rep: Reputation: Disabled
You may still be able to fix it if you can boot to a console screen. Reomove any repos, with zypper rr, that are not leap 15 and run zypper dup. That should fix it. If you struggle to boot choose a leap 15 item fom the menu and type "e". Then add space 3 to the end of the linux line** and F10. This will boot to console if it is possible.

** also check that it's pointing to the correct kernel version.

Last edited by petelq; 06-20-2019 at 12:18 PM. Reason: to add finall line.
 
Old 07-01-2019, 11:40 AM   #9
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 192

Original Poster
Rep: Reputation: Disabled
Hi all.
Nothing was able to get me a screen from which I could collect information.

I removed all three drives, A, B and C.

A and B were mirrored, C I used as a backup.

I restarted with Drive C as the new primary drive, onto which I installed Suse LEAP 15.1 without problem.

So I now have a running system again.

I then put the old A disk in at the C position. All my data was there. I guess all the logs are too so if you would like to see a specific log, name it and tell me how to find it, and I'll get it on here.

I already have a few other questions but as this thread was about Leap 15 failing, and I'm past that, I'll ask my questions of 15.1 in a new thread.

No sign of 1-Klicker Saurland but I would be deeply concerned if an app for 43.n could crash an update!

If anybody want logs, just shout, shortly I close this thread.

Thanks for your help.

Regards

Chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer detecting right-click as left-click, left-click as left-click and middle with 2 fingers pressed as right-click Festerdam Linux - Newbie 5 06-19-2017 05:41 PM
LXer: openSUSE Leap 42.2 is out, how to upgrade safely from openSUSE Leap 42.1 LXer Syndicated Linux News 0 11-17-2016 07:18 AM
SuSE 10 Konqueror links disappear; unuseable tuxnottux SUSE / openSUSE 1 09-01-2006 12:30 PM
SuSE 10 Konqueror links disappear; unuseable tuxnottux SUSE / openSUSE 1 09-01-2006 10:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 05:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration