LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 12-14-2004, 09:24 AM   #1
jdozarchuk
Member
 
Registered: Sep 2004
Location: Akron OH
Distribution: RH, SuSe, Debian
Posts: 33

Rep: Reputation: 15
Suse Enterprise 9 and Exceed


Hello,

I have enabled XDMCP in /opt/kde3/share/config/kdmrc, just like on my suse 8 boxes. However, when I launch Exceed from a PC, I cannot see the node. kdmrc config is identical to the one on SUSE8, but does not seem to work. has anyone run across this?

Thanks!

John
 
Old 12-14-2004, 03:00 PM   #2
cjcox
Member
 
Registered: Jun 2004
Posts: 307

Rep: Reputation: 42
Don't try to do this manually.

Use YaST. You'll want to go to Security and Users->Security Settings->
About the 3rd panel (click on Next) you'll see a button to enable remote
desktop access. Click it, apply and restart kdm.

Work fine here.

Unless your client happens to on a ".local" domain
 
Old 12-15-2004, 06:25 AM   #3
jdozarchuk
Member
 
Registered: Sep 2004
Location: Akron OH
Distribution: RH, SuSe, Debian
Posts: 33

Original Poster
Rep: Reputation: 15
Are you doing this on Suse9? I applied your suggestion, and still the same problem. The only way I can get Exceed to see my box is by starting the "xdm" process. Which I don't understand, because that process is not running on the SLES8 machines...
 
Old 12-15-2004, 10:21 AM   #4
cjcox
Member
 
Registered: Jun 2004
Posts: 307

Rep: Reputation: 42
I did this ON SLES9.

My Hummingbird is version 9.0.0.3 and I used the XDMCP Broadcast entry, then connected to the SLES9 entry.

You can verify what is listening on your linux box with:
netstat -vatun

And look for a wide open listen on port 117

Make sure the SLES9 firewall is disabled or not blocking.
 
Old 12-15-2004, 10:39 AM   #5
jdozarchuk
Member
 
Registered: Sep 2004
Location: Akron OH
Distribution: RH, SuSe, Debian
Posts: 33

Original Poster
Rep: Reputation: 15
Firewall is completely turned off. I do not have anything on port 117 from netstat -vatun. Here's my output:

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:32768 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:513 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:2049 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:756 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:821 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:631 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN
tcp 0 0 10.102.162.84:750 163.243.16.85:32772 TIME_WAIT
tcp 0 0 10.102.162.84:800 163.243.16.85:2049 ESTABLISHED
tcp 0 0 10.102.162.84:721 10.102.129.62:111 TIME_WAIT
tcp 0 0 10.102.162.84:722 10.102.129.62:56697 TIME_WAIT
tcp 0 0 10.102.162.84:749 163.243.16.85:111 TIME_WAIT
tcp 0 0 10.102.162.84:752 163.243.16.85:111 TIME_WAIT
tcp 0 0 :::22 :::* LISTEN
udp 0 0 0.0.0.0:2049 0.0.0.0:*
udp 0 0 0.0.0.0:32770 0.0.0.0:*
udp 0 0 0.0.0.0:818 0.0.0.0:*
udp 0 0 0.0.0.0:833 0.0.0.0:*
udp 29040 0 0.0.0.0:68 0.0.0.0:*
udp 0 0 0.0.0.0:111 0.0.0.0:*
udp 0 0 0.0.0.0:753 0.0.0.0:*
udp 0 0 0.0.0.0:631 0.0.0.0:*
udp 0 0 127.0.0.1:123 0.0.0.0:*
udp 0 0 0.0.0.0:123 0.0.0.0:*
udp 0 0 :::123 :::*



For more information that I have not specified, which may help.

-KDE is the default Windowing environment
-Firewall is off
-/etc/X11/xdm/Xaccess is set to allow any hosts to get a login window
-/opt/kde3/share/config/kdm/kdmrc enable XDMCP= true

Exceed (8.0): XDMCP Broadcast, I have the IP address of all the SLES9 machines in the xdmcp.txt file, and when I fire up Broadcast mode, I do not see my SLES9 boxes.

If I go to the SLES9 machine and type "xdm" as root, and re-launch Exceed, the machines show up. But, on the SLES8 machines, there is no need to run "xdm".

Am I missing anything else? Thank you very much for your help on this.
 
Old 12-15-2004, 11:47 AM   #6
cjcox
Member
 
Registered: Jun 2004
Posts: 307

Rep: Reputation: 42
Did you restart kdm after making the YaST changes?

Not sure why it didn't work. When I did the test I mentioned, it was from a
fresh install of SLES9 (unmodified.. just to make sure I didn't misrepresent
anything).

????
 
Old 12-15-2004, 12:20 PM   #7
jdozarchuk
Member
 
Registered: Sep 2004
Location: Akron OH
Distribution: RH, SuSe, Debian
Posts: 33

Original Poster
Rep: Reputation: 15
I definitely restarted KDM (even rebooted). We are baffled here at why this doesn't work. I even switch the DIsplaymanager to KDM and still, Exceed cannot see it.

Thanks for your help. Could you do a
"ps-ef | grep dm " on your system and send me the output? I want to make sure I am running the same processes.
 
Old 12-17-2004, 05:32 PM   #8
cjcox
Member
 
Registered: Jun 2004
Posts: 307

Rep: Reputation: 42
root 3176 1 0 11:03 ? 00:00:00 /opt/kde3/bin/kdm
root 3181 3176 6 11:03 ? 00:00:10 /usr/X11R6/bin/X -nolisten tcp -br vt7 -auth /var/lib/xdm/authdir/authfiles/A:0-bIahTx


Here's the line from my netstat showing that xdmcp is listening globally...

(netstat -vatu | grep xdm.. is how I got this)
udp 0 0 *:xdmcp *:*

Again, from an initial SLES9 install, I did what I mentioned in the prior message to enable kdm to listen globally. Kdm should run by default in runlevel 5.
 
Old 01-06-2005, 01:50 AM   #9
phalaenopsis
LQ Newbie
 
Registered: Jan 2005
Posts: 1

Rep: Reputation: 0
Hi,
I had the same problem. You have to enable XDMCP in /etc/opt/kde3/share/config/kdmrc. This works fine for me.
Regards,
Alain
 
Old 01-06-2005, 06:38 AM   #10
jdozarchuk
Member
 
Registered: Sep 2004
Location: Akron OH
Distribution: RH, SuSe, Debian
Posts: 33

Original Poster
Rep: Reputation: 15
Hey, that was the trick, I discovered that a few weeks ago!

For others out there, here is the final configuration for Exceed XDMCP on SUSE Enterprise Server 9:

1. In /etc/X11/xdm/Xaccess, find the following line and uncomment it (remove the "# "): # * #any host can get a login window

2. In /etc/X11/xdm/xdm-config, comment out the following line - it should be at the end - the comment character is a "!"

DisplayManager?.requestPort
0

3. In /etc/opt/kde3/share/config/kdm/kdmrc, change the following lines in the "[Xdmcp]" section. Enable=false ==> Enable=true #Port=177 ==> Port=177

4. Restart xdm and xinetd (or just reboot the box!)
 
Old 01-06-2005, 10:22 PM   #11
cjcox
Member
 
Registered: Jun 2004
Posts: 307

Rep: Reputation: 42
Glad that worked for YOU... however, I have done several SLES9 installs and correcting the Security setting via YaST was all that had to be done.
 
Old 04-12-2007, 11:32 AM   #12
archangel4
LQ Newbie
 
Registered: Apr 2007
Posts: 1

Rep: Reputation: 0
ANy help to set up SLES10, running Gnome,for Exceed would be greatly appreciated. -newbie
 
Old 04-12-2007, 11:50 AM   #13
cjcox
Member
 
Registered: Jun 2004
Posts: 307

Rep: Reputation: 42
For SLES10:

I changed my YaST Security setting to allow remote graphical login.

Then I edit /etc/sysconfig/displaymanager and changed

DISPLAYMANAGER_REMOTE_ACCESS="yes"
DISPLAYMANAGER_ROOT_LOGIN_REMOTE="yes"
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes"

And ran SuSEconfig, and when to runlevel 3 and back to 5 (or you can reboot).

Then I simply did an XDMCP Query to the host from Exceed... worked fine.
 
Old 06-10-2008, 12:52 PM   #14
btborders
LQ Newbie
 
Registered: Jun 2008
Posts: 1

Rep: Reputation: 0
Firewall config

Hi,

Will exceed work with the firewall enabled on SUSE9?



Regards,

Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse Enterprise 9.0 Authentication Problem cruel72 SUSE / openSUSE 4 10-21-2006 10:17 AM
SUSE Enterprise 9 pbounds Linux - Software 2 10-23-2005 07:22 AM
installing and using SQL ? in Suse Enterprise 9 SyncMaster Linux - Software 1 05-19-2005 02:44 AM
SuSE 9.1 Pro or SUSE LINUX Enterprise Server 9? Mega Man X Linux - Distributions 11 09-24-2004 10:51 AM
Exceed and Suse Beefy Linux - General 2 08-11-2003 09:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 03:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration