LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 02-16-2005, 11:35 AM   #1
gionni25
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Rep: Reputation: 0
SUSE 9.2 sound goes away after reboot!!!


Sorry, In the thread I have posted before I wrote in Italian.
My problem is the following: in Suse 9.2 the sound goes away after a reboot. So I have to reinstall the sund fonts from the original cd by Creative Sound Blaster 5.1 sound card each time.

Can anyone help me? Suse 9.2 is a hint for me, except the sound, I must solve it!!
 
Old 02-17-2005, 12:14 AM   #2
Killroy
LQ Newbie
 
Registered: Dec 2004
Distribution: SuSe 9.1
Posts: 9

Rep: Reputation: 0
Try setting up your sound so that it works. Then log out (NOT REBOOT). After you have logged out log back in and sound should work. If it does then log out again... and then reboot. Once back up you should log back in and then have sound. By logging out first you have saved your session and preference settings (this should be automatically done.... but I had this same problem in 9.1 and this work around fixed it). Even after that if it works and you have to reboot before logging out it should return with sound. Unless you have a total unsafe shut down in which case you will lose sound again and be forced to set it back up and log out saving your session again. Let me know if this doesn't work for you.
 
Old 02-17-2005, 08:06 AM   #3
gionni25
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Tank you Killroy for your attention.

Yesterday I partially solved my problem: I realized that I had a Logitech USB webcam connected. I tried to disconnect it and to reboot: I had finally my sound system working again with all the system sounds. I understood that the webcam probably had been recognized as another soundcard that Suse was not able to configure, making sound dissappeared.
It remains to discover how I can use Logitech webcam having the sound system working too..
 
Old 02-17-2005, 02:01 PM   #4
one_ro
LQ Newbie
 
Registered: Nov 2004
Location: Romania
Posts: 20

Rep: Reputation: 0
I have the same problem, and I tried your solution... but it didn't work
I logged out, but after logging back in my sound was set to zero again.
Is there any other solution?
Thank you,
Adrian
 
Old 02-17-2005, 06:00 PM   #5
Killroy
LQ Newbie
 
Registered: Dec 2004
Distribution: SuSe 9.1
Posts: 9

Rep: Reputation: 0
What type of sound card is it? Do you have more than one installed? Try deleting your sound card in YaST. The readd it and configure it. hit the volume button and hit test make sure you have sound. Then go into control center under sound and multimedia check to ensure that you are running the proper drivers for that card. use it's sound test--- if you get nothing then try another driver set (ALSA, OSS, Threaded). Test sound and Midi. If sound works good. If midi doesn't you should be alright so long as sound works (I haven't solved the midi issue yet --- I think it has to do with incompatible hardware. Once you have verified that sound works there pull open a sound app like XMMS and play a song... sound? ok. Now log out saving session. Now try... should work...
If in control center you don't have sound then you need to reboot after adding the sound card (sometimes you do.. sometimes you don't). Once logged back in verify that you have sound in YaST and then make the appropriate changes in Control Center. Follow the steps mentioned before and you should be good. Let me know if you aren't.. if you still have trouble please post your hardware types and profiles as well as any errors you receive. What window manager you use... etc.
 
Old 02-17-2005, 06:06 PM   #6
Killroy
LQ Newbie
 
Registered: Dec 2004
Distribution: SuSe 9.1
Posts: 9

Rep: Reputation: 0
As for the Logitech.... Well I have the orbit myself and I haven't managed to figure that one out. I didn't have a problem with SuSe reading it as a sound card but I don't have it working yet either. I heard rumor that someone has put out makeshift ported drivers for logitech devices... I have yet to find them yet though.... I want them as I have The elite keyboard and MX500 mouse...
IF ANYONE KNOWS WHERE TO GET THEM PLEASE LET ME KNOW!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
Old 02-18-2005, 02:57 AM   #7
one_ro
LQ Newbie
 
Registered: Nov 2004
Location: Romania
Posts: 20

Rep: Reputation: 0
Hi again,

Thanks for reply; SuSE does indees detects my sound card (Creative Sound Blaster Live! 5.1). When increasing the volume I hear sounds, the test sound is ok... everything is fine until I reboot (or log out). After this, my volume is set to zero again.
It seems that SuSE does not save my configuration, for some reason.

Another weird thing is that I can't possibly read my other NTFS partitions. Only when I do it as root I can read them. I tried to chwon it but it won't let me do it because it NTFS is read-only.
(The NTFS partitions are on the first HDD, and I installed my SuSE on the second HDD, if this helps)

Cheers,
Adrian
 
Old 02-18-2005, 10:37 AM   #8
Killroy
LQ Newbie
 
Registered: Dec 2004
Distribution: SuSe 9.1
Posts: 9

Rep: Reputation: 0
For the NTFS... you need to change the permissions on the mount point... i.e. /mnt/windows or in my case just /windows. Change the permissions so that all can read write and execute. chmod a+r, a+w, a+x /windows. The NTFS drives are mounted in folders just like cd-roms and other devices. You will not be able to make the permission changes on the drive itself as it is read only and it is mounted to a folder. Also you can not write to NTFS anyway... it just isn't possible right now... (I hate that too).

As for sound ---- That is odd that it isn't saving the volume settings... at least it is just volume and not the sound card itself. You might go into YaST and configure sound... change the settings for volume and output in there to 100... then control your speaker sound by it's own volume or by the volume bar in your system tray. Give that a try... I will do a bit of research and see if I can find the cause of this problem in the mean time.

Keep me posted I will keep checking here --- let me know if this works/doesn't work.
 
Old 02-21-2005, 02:24 AM   #9
one_ro
LQ Newbie
 
Registered: Nov 2004
Location: Romania
Posts: 20

Rep: Reputation: 0
Hi Killroy,

Sorry for my late reply, I was away for the weekend. I solved the problems with the NTFS partitions: just a few more options in fstab.
With the sound, I the trouble is only partially solved.

Just for the sake of it, I reinstalled SuSE with Gnome: I had no problem whatsoever.

Reinstalling SuSE with KDE again, I get the sound volume to zero. What's different this time: the sound starts *exactly* in the moment I open the sound card configuration window in YaST (weird, isn't it?).

Yersterday I had a double trouble: even after setting the volume, I had sound only in the right ear... The problem dissapeared only after stopping and starting the sound system (in Control Center).

Oh, and XMMS now *always* start with its volume to 100%

It seems that various problems appear and dissapear without any obvious reason; for example, I have many programs starting when I log in, whituout specifically asking for that. But this does not happen all the time, only here and then.

I like SuSE very much, but these really seem to be some bugs... I wish I knew how to set them right.

Cheers,
Adrian
 
Old 02-21-2005, 10:03 AM   #10
Killroy
LQ Newbie
 
Registered: Dec 2004
Distribution: SuSe 9.1
Posts: 9

Rep: Reputation: 0
hmmm... I don't have some of those problems like many unasked for programs running at start-up off and on. Now --- These programs wouldn't happen to be programs you were using right before a reboot or logout would they? See if you have open apps when rebooting or logging out they are saved in the session info and will then start when kde starts. Unless you close all of those apps before you log our or reboot.
XMMS automatically stores your volume settings (in my experience). It kind of takes a snapshot of where you were when you closed it and it opens just like that.
I have found that sound is quirky at best.... I am constantly finding new little bugs and such. Just keep at it and you will get it eventually.
 
Old 02-22-2005, 05:35 PM   #11
Knurpht
LQ Newbie
 
Registered: Jul 2004
Distribution: SuSE 9.1 Professional
Posts: 10

Rep: Reputation: 0
About your NTFS/FAT: change /etc/fstab like this:

/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb1 /windows/D vfat iocharset=iso8859-1,users,gid=users,umask=0002 0 0
/dev/hda5 /windows/E ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
 
Old 02-22-2005, 08:34 PM   #12
youngtom
Member
 
Registered: Feb 2005
Location: Rio de Janerio
Distribution: suse 9.1, suse 9.2, redhat enterprise, ubuntu, kubuntu
Posts: 104

Rep: Reputation: 15
Here's something to try if your sounds goes away after a reboot

http://portal.suse.com/sdb/en/2004/0...ndsilence.html

Muted Sound Card
Applies to: SUSE LINUX 9.1

Symptom
Despite having been properly set up according to YaST, your sound card does not produce any sound. The problem can be temporarily solved by reconfiguring your sound card, but arises again as soon as the system is restarted.
Cause
ALSA volume settings are overwritten by the tools in the package kdemultimedia3-mixer when KDE starts.
Solution
Disable KDE's mixer support and use sound mixers for the ALSA sound system only (e.g., kamix). For this purpose, proceed as follows:
Make sure all mixer applications have been unloaded. If not, you should see a speaker icon on the tray beside the clock in the lower right corner. In this case, right-click it and select Quit from the context menu.
If the question [Should KAMix start automatically immediately after you log in?] pops up when closing the mixer, confirm with Yes and skip to steps 13 and 14 of these instructions.
Start the YaST Control Center and select Software -> Install and Remove Software.
Search for "kdemultimedia".
Right-click the package kdemultimedia3-mixer then select Delete from menu that opens.
Press Accept in the lower right corner.
Finish the YaST Control Center.
Open a console (e.g., press [Alt]+[F2] and run the command konsole.
Enter the command su - in the console.
Enter the administrator's (root) password when prompted to do so. No characters (asterisk or similar) are displayed when typing it.
Execute the following commands in the given order:
rcalsasound stop
rm /etc/asound.state
rcalsasound start
alsactl store
Log the root user out of the console by pressing [Ctrl]+[D].
Enter the command kamix & .
Confirm the pop-up message [KDEInit could not start "CheckHardware".].
Close the console by pressing [Ctrl]+[D].

--------------------------------------------------------------------------------

Keywords: mute,sound,sound card,91,kde,kmix


--------------------------------------------------------------------------------

 
Old 02-22-2005, 11:19 PM   #13
gmagill
LQ Newbie
 
Registered: Feb 2005
Posts: 1

Rep: Reputation: 0
sound only for root

I followed the SUSE 9.2 instructions and that got sound working just fine for root. However, if I log in as any other user, I hear nothing again... Any ideas?
 
Old 03-01-2005, 03:18 PM   #14
one_ro
LQ Newbie
 
Registered: Nov 2004
Location: Romania
Posts: 20

Rep: Reputation: 0
Evrika!
It worked just fine for me, as normal user.

gmagill, when you followed the instructions, where you logged as a normal user or as root? Try as a normal user, open a konsole an su... then the rest.

Thanks Killroy, you've been of an immense help.
All the best,
Adrian
 
Old 03-11-2005, 03:47 PM   #15
guaguanco
LQ Newbie
 
Registered: Mar 2005
Posts: 1

Rep: Reputation: 0
Similar problems with sound

I too have seen my ability to play sounds vanish after installing kmixer.
I've tried applying the 'Muted Sound Card' procedure offered by SUSE, bu it hasn't worked.
When I try running kamix from the commandline, I get the message:
'Did not find any soundcard', and kamix terminates immediately without bringing up any windows.
When I look in the YAST tool, it shows
'Creative SoundBlaster AudioPCI 128' in a 'Running' state, and a sound test from YAST works fine. But KDE can't play a damn thing!
Any clues? In general I like the SUSE distribution, but this sound problem is going to drive me away before long!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 8.0 <-> Suse 9.3 login screen reboot tkmbe SUSE / openSUSE 1 11-09-2005 07:28 AM
sound goes out after each reboot.(sb audigy 2 ze) gonus Linux - Hardware 2 02-23-2005 07:29 PM
SUSE 9.2 no sound after reboot!!!! gionni25 SUSE / openSUSE 1 02-16-2005 01:20 PM
No sound after reboot Suse 9.2 using 82801 driver danielph SUSE / openSUSE 7 01-19-2005 04:38 PM
Suse9.1/ALSA/Audigy/No Sound/I run alsaconf after reboot(s) to get sound FastFeet Linux - Hardware 23 07-12-2004 06:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 01:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration