LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   SuSE 9.2 Pro megaraid does not see drives (https://www.linuxquestions.org/questions/suse-opensuse-60/suse-9-2-pro-megaraid-does-not-see-drives-269222/)

xipper 12-22-2004 12:08 PM

SuSE 9.2 Pro megaraid does not see drives
 
I am currently running SuSE 9.0 on an old HP Netserver using a cached Netraid SCSI Raid controller (D4943A 60003). This controller is an American Megatrends controller used by HP. 9.0 installed cleanly, recognized the drives and has had 0 (zero) problems with it over the last year that I have been running it.

I just purchased a SuSE 9.2 package and have been attempting to install it over the last couple of weeks and had no luck. The auto install recognizes the card and pulls the megaraid module for it, which by the way is what 9.0 recognized, then it gets to the configuration screen and errors saying that no drives have been detected. I tried a manual install, and tried both of the 2 megaraid modules provided by SuSE, resulting in the same error message.

I searched the SuSE support database and found a post with a similar problem, however it turns out the solution is for 9.1. Apparently the newer megaraid modules are for newer firmware AMI controllers, SuSE provides a "megaraid (Older Version)" module in 9.1 that resolved the problem.

I registered my package and submitted a support request on my 90 "unlimited support" that comes with the purchased package only to be told that "unlimited" only means you can submit as many times as you want for 90 days. SuSE has refused to work with me on this or even so much as acknowledge the problem, their response was to go the forums for help.

Has anyone encountered this problem and found a solution. I tried installing from the 9.1 modules, but the installer won't accept it.

PS: SuSE's 9.2 installer has really changed, I have tried installing it on a couple of other systems I am running 9.0 on without problems and one fails the Hard Disk Controller search and freezes, the other fails on the video card and display (no working modules found in their distro for either of these as well).

Thx

Xip

cjcox 12-23-2004 10:03 AM

No solution. I have SCREAMED at Novell/SUSE on this. Of course, they'll "kindly" remind you that RAID cards are NOT supported.

It's sad when you consider all of the HP and Dell machines that used these controllers.

What is needed... SUSE/Novell needs to make the driver (suitable for buring to floppy and loading by the installer) available from their website. Also a kernel update via YOU that fixes the problem once in initially.

I've been tempted to do it (make the modules myself)... but I'm actually decommissioning my last old-style megaraid. Btw, the new ones work (but you probably new that).

cjcox 12-23-2004 10:04 AM

> "new that"

I meant "knew that"... need to slow down.

xipper 12-23-2004 05:02 PM

Well,


at least I don't feel alone now. I am digging around to see if I can find the sources for the working module and take a look at it. If I have any luck, I will certainly share it with you (provided you don't work for SuSE).

Another thought, for what I am doing, hot-swap is not a necessity, I am mainly interested in the hardware striping. The AMI is nice with the added value of caching. If you can suggest a working AMI SCSI, that would be great.

I was also looking at ripping out the hot-swap cage and installing some ATA/133's with an ATA RAID controller, those have gotten really cheap now, I haven't run across a cost effective cached controller yet though.


Thx

Xip

MaRX@Speedy 01-07-2005 08:34 AM

By the way
 
Have u got that thing work??

I have played with netraid a lot..
and at the moment i am running novell server 9 on
2 hp netraids..
you have to start install normally, and after that, you have to go and unload megaraid module, and load megaraid_old to system
once you have done that installation will go normally through..

But.. everytime you boot your system, you have to boot it from the cd.. and load megaraid_old module
and the just press that boot installed os, and thats it..

I am allso eager to know, has anyone fixed this little module problem. If anyone have any idea with this problem, please
let me know..

So I think I just should complie a new kernel.. and maybe i am right.. but.. any information you can give is good..

Thanks.. MaRX

cjcox 01-07-2005 10:05 AM

Yes.. megaraid_old is the key and it did not compile for the SUSE 9.2 build.. so the problem is getting that module in SUSE 9.2.

There is no megaraid_old with SUSE 9.2, unless you have managed to build it yourself... but certainly makes things difficult at initial install time.

MaRX@Speedy 01-07-2005 11:11 AM

do they have to ruin everything that is good... :(

cjcox 01-07-2005 01:52 PM

I screamed at them on this one.... but since they don't have to support RAID controllers at all (!!), it wasn't well received.

I now own a Megaraid U320-2... works fine with the newer module (which really begs the question why LSI did not build a module that could handle both.. I've been told that this weird dual-module thing is more the fault of LSI than anything else).

In general I like LSI Megaraid's, but because of this (screams into the deaf ears at LSI) I am looking at alternative solutions for down the road.

3sportthing 01-15-2005 01:58 PM

>But.. everytime you boot your system, you have to boot it >from the cd.. and load megaraid_old module
>and the just press that boot installed os, and thats it..


Marx
Have You tried editing the
/etc/sysconfig/kernel file?

add "-old" to the end of "megaraid" in the INITRD_MODULES section.

then run "mkinitrd" to complete the modification to the /etc/sysconfig/kernel file.

3sportthing...

cjcox 01-16-2005 04:43 PM

There is NO megaraid_old module with SUSE 9.2. It failed during their build and therefore it didn't ship.

MaRX@Speedy 01-17-2005 01:11 AM

thanks 3sportthing...

I have searched that file long time, I am going to reboot this server no, so
wish me luck, i'll need it..

Ill tell if that works..

But anyway, thank you sportthing..

MaRX@Speedy 01-18-2005 01:59 AM

3sportthing rcks.. :D

it finally works, and i am able to move it to stand alone
place

vakanderson 08-16-2007 02:37 PM

Simple solution for Perc2 on SuSE 10.2
 
I'm not sure if there are still folks out there trying to get old PERC cards to work with newer distros, but I wanted to convert a few PowerEdge 4400 systems we have into iSCSI targets so I filled them with drives and tried to load SuSE 10.2. After much searching for solutions I was having no luck getting the RAID volume recognized by the installer. Then I found this mailing list entry:

http://lists.us.dell.com/pipermail/l...ch/030075.html
and
http://support.dell.com/support/edoc...m#Objects_Menu

In a nutshell, changing the adapter's emulation mode to Mass Storage (from I2O) was all that was needed for the megaraid driver to load at install, as well as subsequent reboots.

Note: make sure you update the firmware on the card to ensure stability, and also change the emulation mode after the update - I found out the hard way that a firmware update reverts this setting to the default of I2O!


This may work for other distros and legacy PERC cards as well, but I haven't tested any.

Hope this helps...


All times are GMT -5. The time now is 02:51 PM.