LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 02-16-2005, 07:23 AM   #1
id09542
LQ Newbie
 
Registered: Nov 2002
Location: Bloomington, Il
Distribution: SuSE 9.2
Posts: 22

Rep: Reputation: 15
SuSE 9.2 install on AMD64 problem


I have the ISO image of the install, but due to mobo issues of some sort, I must start the install in text mode by holding the shift key down. No problem with that, but I have no option to install the 64-bit version, the 32-bit version is the one that installs.

Any idea how I can force the 64-bit install?

I am installing on a AMD 3500 CPU, which is recognized by the install program.
 
Old 02-16-2005, 07:39 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
I guess the ISO image only contains the 32bit version. To get the 64bit version, you may try an FTP installation (boot from CD and set a SUSE server as source, pointing to the x86_64 directory).
 
Old 02-16-2005, 08:05 AM   #3
id09542
LQ Newbie
 
Registered: Nov 2002
Location: Bloomington, Il
Distribution: SuSE 9.2
Posts: 22

Original Poster
Rep: Reputation: 15
The FTP directory of the 64-bit is a symbolic link back to the 32-bit version on all the mirors I see. I figured this meant both are incorporated in the same image. When I try the full gui install I do have the option of 32/64 install via the F9 key. The gui install method dies once it begins, thus the reason for doing the text install.
 
Old 02-16-2005, 04:42 PM   #4
broch
Member
 
Registered: Feb 2005
Distribution: Slackware-current 64bit
Posts: 462

Rep: Reputation: 32
I did FTP install of SuSe 9.2 64-bit and that is what I have (files listed as x86_64 version or i586 (for example OO.org is 32-bit, Firefox is for x86_64 so 64-bit)

for example this is the 64-bit directory for SuSe 9.2 64-bit
ftp://mirror.mcs.anl.gov/pub/suse/x8...2/suse/x86_64/
No symbolic links there.

and this is 32-bit directory for SuSe 9.2 64-bit
ftp://mirror.mcs.anl.gov/pub/suse/x86_64/9.2/suse/i586/

So FTP install is either only for 32-bit or 64-bit (one need to get correct mini iso)
Don't know how it it with DVD, allways preffered method for me was network installation
 
Old 02-19-2005, 04:09 PM   #5
id09542
LQ Newbie
 
Registered: Nov 2002
Location: Bloomington, Il
Distribution: SuSE 9.2
Posts: 22

Original Poster
Rep: Reputation: 15
My ISO CD does appear to contain the 64-bit code. My network adapter is not recognized during the install so I cannot do an FTP install.
How can I tell the ISO install to use the 64-bit code on the disc instead of the 32-bit code?
 
Old 02-19-2005, 04:41 PM   #6
broch
Member
 
Registered: Feb 2005
Distribution: Slackware-current 64bit
Posts: 462

Rep: Reputation: 32
If you have 64-bit iso cd then that is what is going to be installed. If 32-bit os will be installed then probably you have burned wrong cd. I never used DVD (I prefer ftp install), so I can't help you with DVD installation. Sorry.

In case of ftp install you need to bring up the module for your NIC before you will be able to configure it. Check what modules are bgought up. If you will not be able to find a module for your NIC then you can do it manually.

What NIC do you have?
 
Old 02-19-2005, 10:16 PM   #7
id09542
LQ Newbie
 
Registered: Nov 2002
Location: Bloomington, Il
Distribution: SuSE 9.2
Posts: 22

Original Poster
Rep: Reputation: 15
I downloaded the ISO from the SuSe mirror, it contains the 32-bit and the 64-bit version. I show ../i586 and ../x86_64 directories. I am guessing somewhere the install is only looking for the i568 directory.

I have a Gigabyte nForce4 mobo which has a built-in Nvidia NIC. This driver does come supported on the ISO disc.
 
Old 02-20-2005, 02:24 PM   #8
snakedriver
Member
 
Registered: Nov 2003
Location: North East Arkansas
Distribution: Suse 9.2 x86-64
Posts: 59

Rep: Reputation: 15
On my x86-64 install DVD. @ bootsplash screen hit F7, select 32- or 64-bit, return,
you are set for install! If you don't have that option, then I guess you have 32-bit ver.

Snakedriver

Last edited by snakedriver; 02-20-2005 at 02:26 PM.
 
Old 02-20-2005, 02:47 PM   #9
broch
Member
 
Registered: Feb 2005
Distribution: Slackware-current 64bit
Posts: 462

Rep: Reputation: 32
Quote:
how ../i586 and ../x86_64 directories
This is misunderstanding: 64-bit version contains 32-bit programs. So you are not installing 32- or 64-bit version. You are installing 64-bit version with some 32-bit software.


Quote:
On my x86-64 install DVD. @ bootsplash screen hit F7, select 32- or 64-bit, return,
you are set for install! If you don't have that option, then I guess you have 32-bit ver.
See above, this does not apply to the installation mini cd.
 
Old 02-21-2005, 05:07 PM   #10
id09542
LQ Newbie
 
Registered: Nov 2002
Location: Bloomington, Il
Distribution: SuSE 9.2
Posts: 22

Original Poster
Rep: Reputation: 15
I can't use the bootplash as it locks my PC, thus the reason for using the text mode install.

If I go ahead and finish the install using the text mode method it completes successfully, but the 32-bit version is installed. How do I tell it to use the 64-bit route for the initial install? My previous post was incorrect, the ISO disc does not support my NIC.
 
Old 02-21-2005, 06:39 PM   #11
snakedriver
Member
 
Registered: Nov 2003
Location: North East Arkansas
Distribution: Suse 9.2 x86-64
Posts: 59

Rep: Reputation: 15
try this one:
ftp://mirror.storagetek.com/pub/syst...86_64/9.2/iso/

Snakedriver
 
Old 02-21-2005, 06:44 PM   #12
bluesman2333
Member
 
Registered: Dec 2003
Location: Phoenix, Az.
Distribution: Xubuntu Edgy
Posts: 330

Rep: Reputation: 30
I had something like this happen. Do a memory check with your SUSE CD and see if you have bad memory addresses. Mine system did and I could only boot to runlevel 3.
 
Old 02-24-2005, 08:05 AM   #13
SAJBER
LQ Newbie
 
Registered: Feb 2005
Location: Sweden
Distribution: Debian Sarge RC4
Posts: 25

Rep: Reputation: 15
can't I download the ISO for 64 bit at:
ftp://ftp.suse.com/pub/suse/x86_64/current/iso/ ?

and if I download the cd mini install do I really have to type
linux26 install-ftp://ftp.suse.com/pub/suse/x86_64/current (or x86_64/9.2) to install the 64 bit version, or can I run the install anyway without typing anyting?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install problem: Suse 9.2 AMD64 Nvidia 'forcedeth' kernel module croutonjones SUSE / openSUSE 1 01-16-2005 04:50 PM
Suse 9.1 AMD64 X800 + Network Problem Hyphon Linux - Newbie 2 10-30-2004 11:37 AM
SuSE 9.1 AMD64 install troubles Vresk Linux - Newbie 4 10-04-2004 12:02 PM
How to install SUSE 9.1 on AMD64? otseng Linux - Newbie 6 09-10-2004 01:19 PM
amd64 suse 9.0 pro installation problem bertathome Linux - Distributions 18 05-12-2004 03:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 06:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration