LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Suse 9.2 - Firefox - SSL (browser doesn't load secure pages) (https://www.linuxquestions.org/questions/suse-opensuse-60/suse-9-2-firefox-ssl-browser-doesnt-load-secure-pages-286845/)

jclement30 02-06-2005 05:38 AM

Suse 9.2 - Firefox - SSL (browser doesn't load secure pages)
 
I'm having a problem with Suse 9.2: Mozilla Firefox will not load secure web pages. But here is the strange thing: Firefox will load ssl pages when I am on the network at work, but not on my home network. Now, before you tell me to open firewall ports, the firewall is fine, and OTHER NON-MOZILLA Browsers load ssl pages normally (specifically Konqueror.) If it were a firewall problem, Konqueror wouldn't be able to open the pages, nor would the browsers on any of the other machines on our network.

So, here is what I am running: A Dell Inspiron 5150, P4 3.06 GHZ HT, 512 RAM, 100 GB HD, Onboard BCM 10/100 NIC, Internal Intel Pro Wireless 2200. This is dual booting XP-SP2 and Suse 9.2.

At work, everything works fine.

At home:

All other non-Suse 9.2 systems on the network (Windows, Linux or Unix) work fine. (ergo: not a firewall problem.)

On my WinXP/Suse9.2 system:

In windows, both IE and Firefox can load ssl pages.

In linux, Konqueror can load ssl pages. Mozilla and Mozilla Firefox sit there looking like it is loading the page, but ultimately doing nothing. I've left it for 24 hours and come back to find it still sitting there, loading... Other tabs still work for browsing non-ssl pages. TOP shows nothing unusual. Clearing cache does not help. Turned on pipelining...nogo. All SSL options are on, and about:config shows all ssl options enabled except for the 2 null options, which should not matter.

I've tried a new profile...nogo. I've created a new user....nogo. new user and new profile...nogo. I pulled all browsers and reinstalled them...nogo. I've pulled openssl and reinstalled...nogo. I formatted my computer and reinstalled Suse 9.2... NOGO! GRRR! And to add to the misery, there have been firefox updates via YOU, but they have not fixed the problem. I really hate to give up and start using Konqueror as my primary browser. (No offense Konqueror developers - but Konqueror is just not Firefox.)

Another note, firefox worked fine back when I used Suse 9.1 (but my wireless NIC did not.) Oh...using /etc/init.d/network stop and start, I have tried all the above with both NIC's active and with one active and one disabled.

So, at this point, does anyone have any further suggestions?

jclement30 02-06-2005 05:59 AM

just correcting mispelling errors in the above post.

gd2shoe 02-07-2005 09:46 PM

You say it works at work? What are the differences?

firefox can be picky sometimes. I've never seen it have a problem with ssl before though. I've noticed firefox consistently slow to connect to vsftpd (takes several minutes, but it does connect).

I wish I could be more help. Have you posted on the mozilla forums yet?

jclement30 02-10-2005 06:32 AM

I just posted on mozillazine.

http://forums.mozillazine.org/viewto...222461#1222461

juanchurro 02-14-2005 11:14 AM

Think I got it
 
Hi there,

I just went to suse 9.2 as well, in order to try to get apm working (no dice). Anyway, I had the same problem, it seems that when my new box requested all of the dhcp info, the router was at the top of the list for dns servers. (you can check this by lessing /etc/resolv.conf). I simply put the real dns servers first in the resolv.conf and firefox works like a charm. Long-term, I imagine that you might have to dissallow the suse config tool (yast?) from messing with your dns setup....

Why is firefox not as robust the weird dns setup as konquerer? I have no idea.

Hope it helps.

gd2shoe 02-14-2005 04:52 PM

juanchurro: Thanks for posting back. Luckily, I don't have this particular problem (It just interests me).

My router is the only dns server in my resolv.conf file. Sounds like firefox just doesn't like something that your router is doing. This is good information to know, because it may not be a router next time that provides problematic dns info.

juanchurro 02-14-2005 11:57 PM

Interesting...

Hmm, I'd be interested to see if that solved jclement's problem. I just tested my little theory out by re-requesting an ip , etc, from my router. Sure enough, the resolv.conf file lists my router as the first dns server, and sure enough, firefox broke again.

Here's something interesting though: ssh was *really* slow when my router is listed first, suggesting to me that my router fails to resolve, then my ssh on my suse box requests from the next server down and so on. My point is that my router may just list itself as a dns server, but not really work. ssh is robust enough to time-out and move on. Apparently, konquerer is even more robust, in that it *seems* that it fails early with the router as a dns server and moves down the list, and stays down the list. Firefox appears simply to look at the first dns server and stick with it indefinately. Maybe I should report this as a low priority feature request on bugzilla.

This is all just speculation, but it certainly is interesting.

gd2shoe 02-15-2005 01:49 AM

It may already be a known bug. If it isn't, then I'm sure they would like to know.


All times are GMT -5. The time now is 11:29 AM.