-   SUSE / openSUSE (
-   -   SuSE 9.2 DVD no longer recognised as Installation Source (

Marrea 02-11-2005 06:53 AM

SuSE 9.2 DVD no longer recognised as Installation Source
I've been using SuSE 9.2 for about a month and have generally been very impressed with it. However, earlier this week I encountered the self-same problem I experienced before with 9.0, namely the SuSE DVD suddenly not being recognised when trying to install extra programs off the disk.

I wanted to install a particular program. YaST asked for the DVD so I inserted it and clicked OK, whereupon instead of continuing to install, YaST again asked for the DVD.

I went to the Software Media Source window of Change Source of Installation, highlighted the DVD entry and tried Edit, Refresh. This produced the following message:

"There is no product information available at the given location. If you expected to address a product, return back and enter the correct location. To make rpm packages located at the specified location available in the package selection, continue."

Pressing the Back button merely resulted in the same error message being displayed. Pressing Continue just entered dvd:/// under both Name and URL.

Then the CD drawer refused to open until I typed umount /dev/hdc in a console.

So, maybe foolishly, I deleted the original SuSE DVD entry altogether, reinserted the DVD and clicked on Add, DVD. Again all that appeared in the Software Media Source window was dvd:/// under both Name and URL. And again clicking on Edit, Refresh resulted in the same error message about no product information being available at the given location.

I can still use Konqueror to navigate to the relevant rpm directory on the DVD and install programs from there so I assume it isn't a mounting problem.

I can also insert a SuSE 9.0 or 8.2 disk and they are recognised OK. But of course I don't want to use those earlier disks as installation sources.

I have a laptop combo drive. /dev/dvd, /dev/cdrom and /dev/cdrecorder all point to /dev/hdc

Originally I had something like SuSE Linux 9.2 and dvd:///devices=/dev/hdc under the Name and URL parts respectively of the Software Media Source window.

When adding an FTP site to the Installation Source a box appear where you can type in the URL but this doesn't happen with the DVD and CD options. How can I enter dvd:///devices=/dev/hdc again? Or is the solution more complicated than this? Up until now I had been installing additional programs from the DVD perfectly OK. Why should YaST suddenly refuse to co-operate?

KimVette 02-11-2005 01:43 PM

You are missing a semicolon. Change this:


To this:


Also, make sure that the source is enabled ("on") in YaST, and for testing purposes try disabling other defined sources.

Marrea 02-12-2005 07:36 AM

Many thanks, KimVette.

How do I actually go about amending the entry in the Software Media Source window? When I insert the DVD and click on Add, it places dvd:/// under the Name column and dvd:/// under the URL column but I can't find any way to select the line and change the URL bit to dvd:///;devices=/dev/dvd.

At the moment, I don't have any other installation sources listed.


Marrea 02-12-2005 12:53 PM


I've been having a further look at this today and am pleased to report I have now managed to solve the problem.

I decided to try a Repair Installed System from the SuSE DVD. The Automatic Repair showed everything OK apart from a missing package, yast2-trans-en, from the Minimal Package Selection. I clicked on Repair to install the missing package. The "Writing the system configuration" appeared but then reported that it had failed to install the package. So I chose Custom Repair and selected Check Package Database and Minimal Package Selection, following which all minimal required packages were reported as being found.

I checked in Install and Remove Software and saw that yast2-trans-en had indeed been installed. But otherwise only my already installed programs were listed. I went to Change Source of Installation and clicked on Add, DVD. This time there were no error messages and it was added, as SUSE LINUX Version 9.2 under the Name column and dvd:/// under the URL column. I went back to Install and Remove Software and all the DVD packages, installed and not installed, were listed - which looked promising! Just to make doubly sure everything was OK I selected a program at random and it installed successfully.

Now whether the missing yast2-trans-en had anything to do with this or not, I don't know but at least running the System Repair seems to have done the trick, so why should I worry !!

All times are GMT -5. The time now is 02:54 PM.