-   SUSE / openSUSE (
-   -   SuSE 9.2 DVD ISO install "Cannot read package data from installation media" problem (

BEaton 04-06-2005 09:01 PM

SuSE 9.2 DVD ISO install "Cannot read package data from installation media" problem
I've been trying to install SuSE 9.2 from the 3.2 GB DVD iso I downloaded. I know that I'm supposed to use the FTP install, but when SuSE boots, I have no network available (my wireless network card, D-Link DWL-G120 is not support successfully on my box--even with the ndiswrapper solution).

Each time I boot to the DVD, it eventually tries to run Yast to install, but I can't get past the opening screen due to the "Cannot read package data from installation media" problem.

I've read dozens of pages searched from Yahoo, etc. on this topic, and so far none of the suggestions have worked:

I tried booting from the DVD ISO burned into a DVD.

I tried using WinRAR to unpack the iso on my harddisk and use the harddisk installation.

I tried deleting partitions (someone said the same problem went away when he deleted his existing linux partition)...

I've tried using the mini-iso boot, but as I said, I can't access my network, so the FTP install won't work.

None of these solutions worked... They all give me the same "Cannot read package data from installation media" error message on the "Software" item in Yast.

By the way, I think the DVD media is good (this time), because I've (literally) downloaded it about 6 times: the first several times, either the Download manager failed or the DVD burn failed or it looked like the files were empty, but I'm not seeing that this time... And WinRAR was able to unpack it to the hard-disk.

P.S. I was able to get Mandrake 10.1 to install, but gave up on it because it was having too much trouble with building the prerequisites for Mono (my reason for using Linux in the first place--to port a .Net app to work on Linux). Since SuSE figures prominently on the Mono page, that seemed like a good distro to try.

Anyway, is there anything I can do to get SuSE to install by booting to Mandrake first? Or any other suggestions you might have (including another distro suggestion for using Mono?)


Pete M 04-07-2005 02:03 AM


The only support I can give you is that it took me 6 attempts to download and burn a usable DVD

I eventually downloaded the split iso from Here, checked the MD5SUMS, joined them on the command line using

cat SUSE-Linux-9.2-FTP-DVD.iso.part1 SUSE-Linux-9.2-FTP-DVD.iso.part2 > SUSE-Linux-9.2-FTP-DVD.iso

This is Linux there are Windows options available

From then on everything went fine


BEaton 04-07-2005 08:20 PM

Thanks for the reference. That did the trick.

I did a diff between the original ("in-one-fell-swoop") DVD iso and the concatenated one from the website you referenced and they were different! My guess is that the "all-in-one" iso is bad to begin with... (or it was somehow downloaded bad by 3 different download managers).

Anyway, thanks again. After three weeks of trying, I'm finally running SuSE!


Pete M 04-08-2005 01:27 AM


Problem is most download managers can't cope with 3.2Gb

Pleased it worked for you, enjoy Suse


All times are GMT -5. The time now is 05:14 AM.