LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Suse 9.2 3d accelleration (https://www.linuxquestions.org/questions/suse-opensuse-60/suse-9-2-3d-accelleration-275171/)

Cryptix 01-07-2005 07:21 PM

Suse 9.2 3d accelleration
 
I have been having some problems enableing 3d accelleration in Suse 9.2, i have tried running the Yast2 Online Update but whenever i try to select the nvidia driver the update always stops at 50% complete no matter if i have all other packages installed or none. The complete OS has been installed on my system, no packages are missing. So i tried to get the driver working manually, so i downlaoded the driver from nvidia official site (i have tried 6629 and 6111 drivers) and followed the instructions for suse users, when i bring the os down to runlevel 3 and install the driver i get an error saying it couldnt be installed on the 6111 driver, and it installs but wont return to init 5 on the 6629 driver. I'm really in a pickle so any help would be GREATLY appreciated.

Caeda 01-08-2005 08:59 PM

After installing the driver did sax2 run sucessfully?

oily_rags 01-09-2005 11:07 PM

I installed the nvidia drivers from online update, it worked for me and I checked the x.org configuration file, and it did have nvidia written into it not nv, but when I ran this game "action" that came with suse, it says no 3d hardware detected and it ran very choppy, so I don't think it's actually working, though even in yast it says 3d enabled. What else can I check or tweak to get it working?

oily_rags 01-09-2005 11:21 PM

oops, I rebooted and everything is working good now. hehoheho :)

Cryptix 01-10-2005 12:14 AM

sax2 did not run

Cryptix 01-12-2005 10:52 PM

any help whatsoever?

Caeda 01-13-2005 08:56 AM

You'll probably need to re-install suse, and after running every update in you except for nvidia. Reboot. Then download the drivers from nvidia's site and try to install them.

Cryptix 01-18-2005 06:06 PM

Already tried.... not working

Darkangel90 01-18-2005 07:24 PM

what video card do you have. Have you updated your kernel?
To install the drivers:

Use the nvidia installer for 1.0-6629.


1)sh NVIDIA-Linux-x86-1.0-6629-pkg1.run -q
2)mine i had to do a: modprobe nvidia
3) Configure X.Org with: sax2 -m 0=nvidia and configure sax, if it works corretly, when you
startx, you will see a nvidia splash screen.

irishboy0 01-22-2005 03:46 PM

Hey, I have a similar issue, maybe if we can figure mine out, then we can figure out Cryptixs' problem. When I very first installed my GeForce FX 5200 128, and downloaded and installed the driver over YaST, everything worked after a reboot. Tux racer was actually fun to play.:) Anyway, I had to re-install SuSE due to an unrelated issue with a FireFox upgrade from 1.0PR to 1.0 and Konqueror. Anyway, after a fresh install I downloaded the nVidia driver thru YaST just like last time. Went in "graphic card" config and enabled my 3d, when I test it with SaX2, my X server crashes with the message: (EE) NVIDIA(0): ***ABORTING***
(EE) Screen(s) found but none have a useable
configuration.
So, disabling 3D is the only way I can get to my graphic desktop. I know I am missing something simple as I have had Linux for about a month now. Any help would be appreciated ;)
Below is my machine config:
Hardware: Hewlett Packard Vectra VL 400 MT
1 Ghz Pentium III
256 MB of RAM (pc133)
nVidia Geforce FX 5200 AGP (128 MB of Vram) on an AGP port
Dual Head version
DVD rom (generic)
hp cd writer 9100 series
HDD Western Digital 20 GB and a Seagate 200GB ultra ATA 100
Software: Win98 SE, WinXP, and SuSE 9.2 Pro with kernel 2.6.8-24.10-default. Using just KDE desktop (will try GNOME later).
Thanks for any help I can get!

hirakendu 01-29-2005 01:08 AM

I have an MX4000 and running SuSE 9.2 Pro. I couldn't get the 6629 working.I'll try to get it work. But you can get a 6111 working on a kernel which is 2.6.8+ by the following instructions:

1. Run the driver installer with the extract option

$ sh NVIDIA-Linux-x86-1.0-6111-pkg1.run -x

2. A directory is created called:

NVIDIA-Linux-x86-1.0-6111-pkg1

3. cd into the directory and edit this file:

$ vi usr/src/nv/nv.c

4. Go to line 3697

:3697

5. Edit this line:

case PM_SAVE_STATE

and change it to read

case PM_SUSPEND_MEM

6. Save the file

:wq

7. Su to become root

8. Type this to get rid of X

$ init 3

9. Log in as root

10. Run the installer by cd'ing into the same directory where the NVIDIA file was extracted to:

$ cd NVIDIA-Linux-x86-1.0-6111-pkg1

and find a file called nvidia-installer and run it

$ ./nvidia-installer

Now the driver will compile

11. install:
$ modprobe nvidia
$ sax2 -m 0=nvidia (thats a zero)
13. Permanent:
create a file "/etc/modprobe.preload" and add the following line to it:
nvidia

Thats it. (Courtesy - googling)

Note, this driver is good enough for me to play doom3 with 15fps ( he he) at low quality. And I have an athlon 2000+ with just 256mb (266mhz) system ram !


All times are GMT -5. The time now is 01:22 AM.